Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
78,587 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2007 Audi A4 engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2007 Audi A4:

Unsubscribe any time. We don't sell/share your email.

2007 Audi A4 Owner Comments

problem #14

Jul 162016


  • 70,000 miles


Car started blowing white smoke and oil consumption increased to 1 quart per 500 miles. Dealership replaced PCV valve, which should have been replaced under csc-10043026-6562. However, since the check engine light never illuminated, the dealership and Audi refuse to cover this issue under the extended warranty, despite the fact that the defective part is specifically called out in their customer service campaign.

- Edmonds, WA, USA

problem #13

Jun 092015


  • 123,542 miles
High pressure fuel pump failure resulting in damage to camshaft, cam follower and internal metal shavings from defect at 123,542 miles.

- Webster , NY, USA

problem #12

Jan 122015

A4 4-cyl

  • 94,450 miles
I picked up my Audi A4 a few weeks ago left the dealer went about five miles and the car starts miss firing bring it back for a new coil pack, one week later oil light came on low oil not even 700 miles and add one 16 oz of oil so started to park car in garage oil on garage floor lots of oil so far not very happy with the car. Bringing it to Audi repair shop they said they will look for the leak. I should have come here first to see, what I see now I would not have brought something other then Audi now waiting to see if it burns or consumes any oil if so should I call the Audi dealer. I paid 9,850.00$

- Pine Bush, NY, USA

problem #11

Sep 102013

A4 4-cyl

  • 75,000 miles


From day one in August 2013 when I bought this car it burns oil at an extreme rate. A quart every 500 - 800 miles. It calls for synthetic oil by castrol which is close to $10 a quart. Do the math. The car manufacture say that is with in the specs for how engine was built. This is truly highway robbery and Audi should be held responsible. I went on Audi forums and thousands of people in the U.S. and the U.K. complain of the same problem. Please do something about it. I as 50 years old and been paying taxes for 35 years. Working since I was 15 years old. Stand up and do something for a Agency that was put in place to do so. I would greatly appreciate it. I look forward to your response.

- Orlando, FL, USA

problem #10

Dec 012014

A4 4-cyl

  • miles
I purchased a vehicle from better way auto sales on 10-31-14. After 2 weeks of driving, my check engine light came on. My odometer was also going up pretty fast, went from 89,000 miles to 93,000 miles in less than a month. My brake light was also on permanently even when I wasn't pressing the brakes. I bought it to a mechanic & he gave me a list of issues that was wrong with the car. I called the dealership where I purchased the vehicle from to make a appointment to bring my car in to get fixed. They gave me an appointment weeks from when I called. After having my car for a few days, they called saying my dealership warranty has expired so they can't fix it. I'm 100% sure I didn't drive 4,000 miles in 3 weeks. The dealership warranty expires after 90 days or 3,000 miles which ever one comes first. I also purchased a extended warranty which the dealership said my extended warranty don't cover the parts needed. The labor of everything is expensive that they want me to pay out of pocket. I suspect that there's some odometer fraud going on or some type of scam. I also feel as though the issues with the car should've been fixed before selling. They claim there was a safety inspection done on car but aren't brakes included in inspection? I have little knowledge when it come to things of this nature but I do suspect something wrong is going on with better way auto sales.

- North Haven , CT, USA

problem #9

Jun 012014


  • 89,000 miles
Traveling on the freeway at 60mph. The esp(stability control) and epc lights came on. 5 seconds later the engine shuts off and I keep rolling at 60mph but decreasing speed. Luckily I was on a straight away and there was no need to turn but once the engine turned off the steering wheel was hard to turn and I could not pull over. There was an exit and I was able to stop on the off ramp. After putting the vehicle in park. I took the key out then, put it back on the ignition and tried to turn the vehicle on. The vehicle would not turn back on. When it finally turned on the vehicle stalled back off and the "check engine" light came on. After sitting in the vehicle for 5min in off. I then turned the vehicle on and it started off. I went to the dealership and told them what had happen they told me that it had never happened before with other Audi's but that it sounded like it was the crank shaft sensor. After looking online and doing research many other Audi owners had the same problem they stated that the "engine speed sensor" aka crankshaft sensor would go out and their engine would stall while driving. This is a safety issue! airbags go off when the engine shuts off and the steering wheel is hard to be turned. Please do something about it!

- Sammamish, WA, USA

problem #8

Aug 012013

A4 4-cyl

  • 75,000 miles


Extremely bad oil consumption the car uses a quart under 1000 miles and has received all of the updates with this problem that Audi offers. This is a manufactures defect that plague many models and this should be recalled to assist the consumer before its too late.

- Traverse City Mi, MI, USA

problem #7

Aug 142010

A4 4-cyl

  • 30,000 miles
August 2010 at 30K miles, add oil light came on within 2,000 miles of last oil change. Took it into the dealership, they fixed pressure regulating valve. Add oil light continues to come on between oil changes, approx 1K to 3K miles. Dealership stated it was normal for that yr/model. May 2013 at 69K miles, white foul smelling smoke comes from exhaust upon acceleration and car drives rough. Happens intermittently. Dealership states no codes or problems upon test driving. June 2013 it happens again and this time needs to be towed. Dealer fixes fuel injectors. August 2013 happens again on numerous occasions. Dealer does oil consumption test. Fails test. Sept 2013 dealership replaces piston rings and cylinder head. Add oil light continues to come on and white smoke and shaking intermittently. Oct 2013 take back to dealership. They replace turbo. All of the above services done at no charge due to extended service contract. Dec 2013 it happens again. Dealership finds another leak in the valves. Dealership now wants to charge me 50% of repairs although problem started before warranty expired. Currently car is not repaired. It is drivable but continues to need oil every 1K miles or so and intermittently produces white smoke and shakes.

- Wheaton, IL, USA

problem #6

Sep 032013

A4 4-cyl

  • 74,500 miles
Oil warning light came on. This is after a 75,000 mile checkup was performed (even though the car has less than 75,000 miles) the car petered out on me, had it towed to the dealership service where I was told it had a blown engine.

- Birmingham, AL, USA

problem #5

Feb 032014

A4 4-cyl

  • 124,000 miles
This Audi and many others suffer from excessive oil consumption. About 1 quart synthetic oil is used/lost every 1000-2000 miles.

- Somerville, MA, USA

problem #4

Jan 052014

A4 4-cyl

  • 124,000 miles


Low pressure alarm came on and engine stalled. Mechanic told me the cam shaft chain is broken and that is fairly common occurrence and that Audi does not have any maintenance schedule for the chain. There is several thousands in damage and serious injury could have resulted if this had this occurred at highway speeds.

- Somerville, MA, USA

problem #3

Mar 112009

A4 4-cyl

  • 55,000 miles
Excessive oil consumption.

- Waldorf, MD, USA

problem #2

Aug 142013

A4 4-cyl

  • 87,500 miles
Excessive oil consumption a quart every 1000 miles or less.

- Traverse City, MI, USA

problem #1

Nov 132012

A4 4-cyl

  • 78,227 miles
After a stop light changed to green I started a left turn. Immediately the car started to "shake". it seemed like I was driving over some lane divider bumps. I noticed the engine light was on so I found a safe place to pull over. The car had to be towed. The dealership diagnosed a faulty ignition coil.( all four ignition coils were already replaced in 2010 because of a recall). Again I had all 4 ignition coils replaced. I also had to have spark plugs replaced; (possibly because of the faulty ignition coils ruining some of the plugs. The spark plugs were replaced about 20,000 miles ago.) I was told by the dealership that the original recall of the ignition coils did not cover this event. I feel there should be another recall for the ignition coils and include spark plug replacements.

- Oceanside, CA, USA

Not what you are looking for?