Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

2.7

hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
54,998 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2011 Audi S4 drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2011 Audi S4:

Unsubscribe any time. We don't sell/share your email.

2011 Audi S4 Owner Comments

problem #14

May 302016

S4

  • 69,000 miles

A D V E R T I S E M E N T S

At about 49K miles the car would sometimes lurch backwards when in reverse or going from reverse to park. Took into mechanic. No diagnostic codes showed up. Around 60K miles the car overheated. Audi stated it needed a new thermostat which was around $1000. Drove the car across country from ca to co. Around 62K miles car went into limp mode and would not get out of 1st or 2nd gear. "gearbox malfunction" warning came on. Stated not to go into reverse. Drove home slowly. Next morning all warning lights were off. Took to mechanic. No problems could be found. May 2016 at 69K miles car went into limp mode again. Couldn't get rpms up. Reset codes using diagnostic tool. Drove from Utah to co. Car went into limp mode probably 40 times on I-70. Car would lurch forward. Made it to dealer (prestige in lakewood, co). Mechatronics found to be faulty and car in need of entirely new transmission. Cost $12,000. Dealership ¿paid¿ $8000. I paid $4000. This seems to be a common problem with this make/model/year.

- Indian Hills, CO, USA

problem #13

Apr 192016

S4

  • 62,000 miles
Dsg mechatronic failure. Was replaced under cpo warranty. However problem persists. While driving car goes into neutral with TPMS + gearbox malfunction. This is a known problem with Audi S4 2010 and 2011.

- San Diego, CA, USA

problem #12

Jan 252016

S4

  • 48,000 miles
This vehicle suffers from a faulty mechatronics unit, causing the car to mis-shift and surge while driving, or fail to move forward when stopped in traffic in "D" drive, due to parking brake drive-select malfunctions. In these cases the car must be turned off, in traffic in order to move forward again. This technique has worked so far but I am afraid this will not work eventually, and become a safety issue on the roadway.

- Denver, CO, USA

problem #11

Oct 202015

S4

  • 76,000 miles

A D V E R T I S E M E N T S

Engine - excessive oil consumption (1qt refill is require for every 750miles). Dsg transmission ¿ getting gearbox malfunction, you can continue to drive on dashboard. This is due to P179E - drive range sensor electrical error.

- Plano, TX, USA

problem #10

Jul 082014

S4

  • 45,000 miles
Vehicle would exhibit strange shifting behavior in low gears. When upshifting or downshifting from 1-2-3 and vice versa the transmission would sometimes hesitate or shift inappropriately. Audi dealership updated software and checked the problem numerous times. They could not find any problems not any error codes. Problem would come and go usually when it was hot outside. A little over a year (Sept 2015) car has again been oddly shifting in low gears and even revving to high rpms before downshifting in automatic mode. Car finally threw and error code saying gearbox malfunction and car went into limp mode. The transmission could not find the right gears to shift. Car has been exhibiting symptoms of mechatronic unit failure for over a year now.

- Seattle, WA, USA

Search CarComplaints.com for these popular complaint phrases...

problem #9

Sep 222015

S4

  • 50,000 miles
After turning my car on a gearbox malfunction warning appeared but said I could continue driving. After driving the message and service light eventually went off with everything going back to normal. The car appears to have a very common mechatronic unit issue that is part of the faulty dsg that Audi has put in the B8 S4 model.

- Naperville, IL, USA

problem #8

Sep 022015

S4

  • 65,000 miles

A D V E R T I S E M E N T S

Rough/clunking shifting in stop and go traffic. Car will lurch forward, or lack power when accelerating.

- San Jose, CA, USA

problem #7

Jan 012015

S4 6-cyl

  • 87,453 miles
I was accelerating, after leaving a restaurant, into traffic. I received the "dsg malfunction light" and suddenly at about 20mph my lurched forward and failed to respond to the throttle and shut off in traffic. Car restarted after about 30 seconds but definitely not something that should go without notice. If I was on the interstate and throttle went out situation could have been much worse.

- Atlanta, GA, USA

problem #6

Jan 022015

S4

  • 61,794 miles
I was cruising at approx. 55mph on my way to work. I had no symptoms of anything prior to the transmission failure. Suddenly the car started vibrating and decelerating as if I had a flat tire. I made an emergency merge into the center median and was luckily nobody rear ended me. After inspection of my tires which were ok I got back in car. D or R would not work. The car would not move.

- Millersville , MD, USA

problem #5

Aug 142014

S4 6-cyl

  • 31,000 miles
Transmission shifts clunk when coming to a stop from 3, 2, to 1, and shifts noisily and abruptly particularly in stop and go traffic, or in extreme temperatures ie middle of summer on a hot day.

- Richfiled, MN, USA

problem #4

Nov 292014

S4 6-cyl

  • 79,366 miles

A D V E R T I S E M E N T S

Audi recently replaced my 2nd thermostat (1st was 11/2012 and the 2nd was 11/24/2014), not under warranty, and returned my car to me after holding onto my car for two weeks. I was told that my vehicle checked out okay via a diagnostic and mechanics review. I drove my S4 for two days and while driving, I received an indicator warning that read, gearbox malfunction reverse not available, you can still drive. I then noticed that the car began to violently buck when I accelerated. The car surged forward while driving in traffic which was alarming to both my 10yr old daughter and I. other cars had to drive around us and one vehicle almost hit my car in the rear. I continued to drive at a limited speed and immediately, the TPMS warning indicator lit up and the car lost speed. The car would barely move at 10 mph and I limped back to a relatives underground parking garage. Once I parked I could not get the car to reverse out of the parking space. I called Audi and they stated that I would have to tow the vehicle to the nearest Audi service center. The vehicle was towed to Audi and I am waiting to hear the results of their findings. I have already invested over $1,750 in vehicle repairs (thermostat and rear brakes/rotors). I do not want to continue to invest money into this vehicle pit. Audi needs to recall these faulty parts (thermostat and mechatronic) and stand behind their product. I've seen numerous complaints in forums and on this site referencing these same issues.

- Augusta, GA, USA

problem #3

Jun 192014

S4 6-cyl

  • 49,000 miles
I currently drive a 2011 Audi S4 dsg automatic vehicle. The car bucks intermittently when going from stop to 1st-2nd-3rd gear or vice versa. It usually occurs in slow traffic and when the car/transmission has been on for awhile. The car was taken to Audi for repair and the software and adaptability was updated. This helped smooth out the shifts but the car still continued to buck at times (especially in dynamic mode), the car was taken back to Audi again, but the technicians did not find any problems when driving the car. The problem seems to be a faulty mechatronic unit which is known to fail in early 2010-2011 S4's. multiple people have gone through the same problems until this unit was replaced. Audi of America has been contacted and did not offer any solution at this time.

- Edgewater, NJ, USA

problem #2

Jan 072014

S4 6-cyl

  • 37,500 miles
While traveling at approximately 40 mph, a warning message came up do the dashboard saying "gearbox malfunction, reverse gear not available, you can still drive". at the same time, the TPMS warning indicator came on. The car began to loose speed and wouldn't respond to the throttle, after a few seconds it would surge forward, and then loose speed again. This repeated a few times, until I came to a stop at an intersection. At the intersection, I turned off the ignition and restarted the car. The car behaved normally for about 25 minutes of driving. Then on the freeway at about 65 mph the problem recurred. I was able to limp to the nearest Audi dealership, where the car is now being evaluated. I'm very concerned about this issue, because at times I was unable to maintain the same speed as the flow of traffic and an accident could have occurred.

- Thousand Oaks, CA, USA

problem #1

Oct 092012

S4 6-cyl

  • 8,860 miles
This issue concerns my Audi 2011 S4, a car that I took delivery on in April, 2011. I have had numerous problems with the car since the delivery, however, it is a safety concern that has caused this specific filing. The problem seems to be with the dsg transmission. On occasion, the car will struggle and "buck" in low gears at a very slow speed (or froma complete stop) upon acceleration. This does not happen often but it has happened several times since taking delivery. I have tried addressing the problem with Audi coral springs in the past but because I cannot duplicate the problem, they are unable to help. Consequently, I have not been able to always drive the car in the manner that I would like to. However, on October 9, 2012, the problem happened again, only this time, it occurred while attempting to merge into traffic. I was in a merge lane, traveling approx 3-5 mph and when the opportunity arose, I accelerated into the traffic. At that precise moment, the car bucked violently (as it has done in the past) and I had to lift off the throttle to correct the issue. Let me express that I in no way am attempting to cause problems for Audi. I am only concerned for my safety. Its quite conceivable that when my car has this trouble while merging into traffic that I could get hit from behind as I must immediately lift off the accelerator to resolve the issue.

- Coconut Creek, FL, USA

Not what you are looking for?