If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

8.8

pretty bad
Typical Repair Cost:
$238.00
Average Mileage:
113,058 miles
Total Complaints:
12 complaints

Most Common Solutions:

  1. not sure (9 reports)
  2. computer replaced (1 reports)
  3. oxygen sensor (1 reports)
  4. wash the crank position sensor (1 reports)
1994 Buick LeSabre engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 1994 Buick LeSabre:

Unsubscribe any time. We don't sell/share your email.

1994 Buick LeSabre Owner Comments

problem #12

Sep 132013

LeSabre N/A 3.8L

  • Automatic transmission
  • 28,348 miles

A D V E R T I S E M E N T S

It's a pain in the ass to spend money on a car,and no mechanics knows what wrong with a car. This car has very little miles on it,and still cuts off on the freeway. I am fed up!

- , Hartsdale, NYC, USA

problem #11

Apr 012012

LeSabre 3.8L

  • Automatic transmission
  • 161,000 miles

My 1994 Buick Lesabre has developed problem that it decide it will quit running at the most inconvenient times. First the check engine light comes on intermittently, had the code read out that said the problem was with the EGR valve. replaced but no help. Lately the engine quits mostly just after slowing down to make a left turn. Of course the power steering and the brakes are almost useless at this time, making hard to control the car where it is going. About 95% of the time placing the car in "N" and turning the key on will start the engine. On other occasions the car has to stopped and put in "P" to get it started. In both cases the engine starts with no problem. I have seen and heard that this problem doesn't seem to have a fix. If anybody out there knows what the "H" is going on please comment on this problem. Thanks

Update from Aug 16, 2012: My 1994 Buick Lesabre has developed problem that it decide it will quit running at the most inconvenient times. First the check engine light comes on intermittently, had the code read out it indicated the problem was with the EGR valve. replaced but no help. Lately the engine quits mostly just after slowing down to make a left turn. Of course the power steering and the brakes are almost useless at this time, making it hard to control the car. About 95% of the time placing the car in "N" and turning the key on will start the engine. On other occasions the car has to be stopped and put in "P" to get it started. In both cases the engine starts with no problem. I have seen and heard that this problem doesn't seem to have a fix. If anybody out there knows what the "H" is going on please comment on this problem. Thanks

- , Minneapolis, Minn, USA

problem #10

Jan 011989

LeSabre

  • Automatic transmission
  • 94,000 miles

Car either refuses to start or will stop when driving.

- , Greesboro, C, USA

problem #9

Dec 082011

LeSabre Limited 3.8L

  • Automatic transmission
  • 99,850 miles

A D V E R T I S E M E N T S

You could get rear ended be cause of it just dying at any speed. I was very careful when I drove the care .

- , Farmington, MN, USA

problem #8

Aug 012010

LeSabre V6

  • Automatic transmission
  • 102,551 miles

Seems that alot of people have the same issue and not even the Buick dealership knows what the heck is going on.. Who designed this engine and component set up? Why on earth can't this issue get resolved? I think we need to get a petition started to make Buick find the answer to this problem.. Who's with me LOL

- , Mesquite, TX, USA

problem #7

Sep 142009

LeSabre

  • Automatic transmission
  • 95,000 miles

I have a 94 Buick LeSabre with about 95,000 miles. I have had the problem of the check engine light coming on and the car running rough/stalling for about 6 months. The car has been to the mechanic 3 times and I have spent $500 and the problem is still not fixed. And what the worst part about it is the mechanic had the car for a month the last time I gave it to him. He SAYS he replaced the crank sensor, cam sensor, coil pack, engine wiring harness. The car will run good for a few days and then act up again. I really like the car and aside from this problem is a good car with low miles for the year. I am even considering selling it but want to at least fix it first, especially since I already spent $500 on the problem. Any Help would be greatly appreciated.

- , Commack, NY, USA

problem #6

Feb 162009

LeSabre

  • Automatic transmission
  • 94,000 miles

A D V E R T I S E M E N T S

the car dies while driving and now it wont even start it is just in the garage to be fixed.

i just want to know what is wrong and how i can fix it. i love this car and i have done all i can think of,no one seems to now what the problem is. not even a certified gm mechanic.

- , Palo Alto, CA, USA

problem #5

Jul 032009

LeSabre Custom 3.8L

  • Automatic transmission
  • 95,000 miles

I replaced the coils, plugs, wires, & fuel filter. I was ready to replace the crank position sensor. But I washed the sensor and the problem is gone - car runs better than ever. I wish I knew to do this first.

- , Portland, OR, USA

problem #4

Jan 082007

(reported on)

LeSabre Custom V6

  • Automatic transmission
  • 155,000 miles

OK heres the deal... sometimes my car drives very good, no stalling. Other times my car will stall while driving, sitting even going 70 down the highway it will stall. When it stalls while driving the dash lights come on, and it seems to not be getting gas. Sometimes it will start right back up, other times it will not start until i have left it alone for a long time. I have replaced the coil pack and the ignitoin control module. Nothign has helped and im unsure that to do next. The diagnostic test i had done on it sadi the ingine control module was bad, but, WRONG!!!!

Just today it stalled on me and i could get it to start a few times but it would not get any gas so it stalled out again..... any ideas????

PLEASE HELP!!!

- , Cinciannti, OH, USA

problem #3

Aug 212006

(reported on)

LeSabre Limited

  • 247,650 miles

I was at a red light and the car turned off by itself no warning or shaking, but it will turn on right away. The mechanic said it could be the oxygen censor which is $20.00 or the cover where the spark plugs are connected which would cost $170.00 for the piece plus labor. I know i have a lot of miles on the car. I've had this car for 7 years and this is the bigest problem I ever had with this car. I'm going to fix what the mechanic said and i will let you guys know it that's the solution. If anybody knows what the solution please let us know.

- , Chicago, IL, USA

problem #2

Mar 012006

(reported on)

LeSabre

  • 73,000 miles

I am at the end of my rope with this damn car!!!! When I am driving down the road, my car will stall out with no warning. I have to pull over and wait a few minutes before even attempting to fire the engine up. If anyone has any idea on how to solve these problems PLEASE contact me using the send comment link! Thank you for your help and stay away from the Buick LeSabre!! (Unless you want to buy mine - real cheap)

- , Comstock Park, MI, USA

problem #1

Jul 182005

(reported on)

LeSabre

  • Automatic transmission
  • 111,295 miles

while i am driving the engine just shuts off, no warning and never at a consitent time.. just shuts off and then i have to pull over, put car in park, turn key off and then restart. it always starts. I have had it scanned and they say they can't find the problem. Fuel pressue checked and it is ok, changed fuel filter, put injector cleaner, new gas cap. Nothing helps

Update from Sep 4, 2010: I no longer have the car, but it is still running well. What I found to be the problem was the computer brain, also it started using so much gas. However I think that was due to the person putting the wrong computer in it. They put a park ave instead of lesabre. Anyway, after much hassle and expense, I got the right computer but also had to put a new fuel filter in it. But after that, I had no more problems. Maybe this will help anyone who has the problem that I did.

- , Hewitt, TX, USA

Not what you are looking for?