Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Typical Repair Cost:
No data
Average Mileage:
74,928 miles
Total Complaints:
2 complaints

Most Common Solutions:

  1. not sure (2 reports)
1993 Cadillac DeVille engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 1993 Cadillac DeVille:

Unsubscribe any time. We don't sell/share your email.

1993 Cadillac DeVille Owner Comments

problem #2

Feb 232005

(reported on)


  • 74,856 miles


I have the same problem, engine really runs bad, backfires, runs rough, bad idle. Mechanic has had car for three weeks and still hasn't found solution. He's replaced fuel injectors, fuel pump, sensors, computer chips and still has the same problem. An answer for this would be appreciated.

- , Beaver, PA, USA

problem #1

Oct 052003

(reported on)

DeVille Sedan

  • 75,000 miles

My car is having a problem that at this point no mechanic can figure out. It's a '93 DeVille with 75000 miles the car has been running great for the past year now all of a sudden the car is back firing, hesitating and idling rough. The car runs good when first started but after about 10 minutes its starts missing and idling rough. Everything was checked on this car and it all checks out fine. Also when I use the fan or the headlights the car seems to idle even rougher and lose power. when I turn these things off the engine power picks back up. The plugs, wires, computer, fuel filter, voltage reg., ignition system, exhuast system, vaccuum lines, sensors, alternator, battery, battery cables, grounds, intake manifold gasket throttle body, all have been checked and check out fine anyone have any suggestions? It would be a great help to find out what is causing these problems. Thanks

- , Rahway, NJ, USA

Not what you are looking for?