Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Print this page

1.7

hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
94,892 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2007 Chevrolet Avalanche drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2007 Chevrolet Avalanche:

Unsubscribe any time. We don't sell/share your email.

2007 Chevrolet Avalanche Owner Comments

problem #11

Nov 152016

Avalanche

  • 88,000 miles

A D V E R T I S E M E N T S

The truck would not move; feels as if the truck locked up while driving and came to an abrupt stop.

- Lugoff, SC, USA

problem #10

Oct 012014

Avalanche 4WD 8-cyl

  • 149,000 miles
When the vehicle shifts from 1st gear to 2nd gear around 17mph there is a loud clunk, and it sounds like the transmission is having trouble. It doesn't shift smoothly. After looking online this is a common issue for the Avalanche. Chevrolet knowingly put in a transmission that doesn't effectively do it's job. The curb weight of a Avalanche is 6000lbs and my uncle owns the same truck, which has eaten 2 transmissions so far with the same mileage.

- Appleton, WI, USA

problem #9

Feb 062014

Avalanche

  • 207,990 miles
When light comes on engine runs rough and shifts hard. When light goes off it runs fine.

- Pine Knpt, KY, USA

problem #8

Feb 182013

Avalanche 8-cyl

  • 62,456 miles

A D V E R T I S E M E N T S

So I was sitting at a red light, everything was cool.. and when I started to accelerate the truck almost felt like we got rear-ended. Then when I tried to accelerate it felt like it had slipped into neutral. Drive is completely dead, when I put it into drive, I get nothing. So I put it in 1st, and it worked, it went into gear. Then when I started to accelerate it made this horrible scratching/grinding/whining sound. So I can accelerate slowly and switch to 2nd, slowly, and accelerate slowly and switch to 3rd. 3rd feels good when I accelerate but then if I step on it, it slips out of 3rd back to that neutral feeling. If I try to accelerate quickly in 1st and 2nd I get that horrible sound and grinding feel. it is so many people having this same problem over and over. Some say the dealer charge them over $2800 plus to repair others say some dealers fixed the part in the trans called the forward sprag gear and everything was ok. Its crazy that so many people with the same problem. 95 percent of the trucks despite the mileage ( 30, 000 to 93, 000) on her truck did this right after the warranty was up. My truck 07 with only 62, xxx on it trans has now done the same thing as everyone else truck. Someone should force GM to recall these transmission and fix them. Word is they used the same transmission that's in mid size cars and light duty trucks and if so everybody will have issues with a full size truck and a light duty transmission!

- Memphis, TN, USA

problem #7

Jan 212013

Avalanche 8-cyl

  • 78,267 miles
I am a soldier with 17yrs of active duty service and I was home over the weekend for the mlk weekend with my family. I leave Monday morning about 0900am to return back to my home station and my truck was driving fine, I stopped at a red light to make a left turn and when the light turned green I accelerated to about 5-10mph then there was a clunking noise and my vehicle would not accelerate anymore it would just send the rpms up so I drifted off the road and put my vehicle in park because I just had my vehicle serviced. I checked all my fluids and they all were fine so I put my vehicle in reverse worked fine, selected drive and it wouldn't move, selected 3rd gear wouldn't move, selected 2nd gear truck would move, and selected 1st the truck would move. There I was with my wife and my 2 daughters and mother-N-law on the side of the road in nc, luckily we didn't get that far from my in-laws home and they called a local shop that towed my vehicle back to her home. I have always wanted an Avalanche but I get on the computer and I start reading about other people who have had the same problem and that is shocking, and to happen under a 100K miles. This is not my 1st Chevy vehicle I have owned as well, I have owned a Chevy trailblazer ltz that the four wheeled drive went out on that I purchase for my wife, so I traded that in for the 07 trailblazer ss that my wife really loved and that vehicle ended having an electrical fire from the wiring harness and my vehicle sat down at the dealership for almost a month until I notified them that something has to happen in which they let me trade that vehicle in for a Honda Accord in which I haven't had any issues out of that my wife is currently driving. In my reading last night when I finally made it back home after borrowing a car from my nephew that just happens to be another Honda Accord and I see all these stories posted horrible.

- Apg, MD, USA

Search CarComplaints.com for these popular complaint phrases...

problem #6

Jun 182008

Avalanche 8-cyl

  • 36,000 miles
Cracked dashboard on passenger side where airbag is fitted. Upper lefthand side of airbag. Traction control/stabilitrac system: Service indicator warnings activate, switches from 2 wheel drive to 4 wheel drive high even though selector is in 2wd mode. The first occurrence of this was at 70K miles, then again at 90K. Then again at 97K the transmission was damaged and needed to be replaced. Again at 101K miles the ringgear in the rear axel was destroyed. Rear axel was replaced. Fifth time for those counting, 116K miles service stabilitrac and service traction control warnings, switching from 2wd to 4WD high while moving, while parked, selector in 2wd position with someone at the wheel or cab empty. Evaporative emission control warning. Check engine light on, code comes back to eec. Indicating a leak in the return line. The first time this was replaced at 70K miles, this is the second time. And no it is not the gas cap being loose or needing replaced. The first time there was "water in the connector" (yeah sure).

- Morristown, TN, USA

problem #5

Apr 092012

Avalanche 8-cyl

  • 57,100 miles

A D V E R T I S E M E N T S

Transmission failure with loss of drive, 3, and reverse gears. 2nd and 1st were slipping badly when returned to dealer. Vehicle has approximately 57,100 miles and has never towed or pulled anything. Vehicle is 2wd ltz model.

- Birmingham, AL, USA

problem #4

Mar 072012

Avalanche 4WD 8-cyl

  • 120,000 miles
Car stalled unexpectedly on freeway exit for no apparent reason with loss of power steering and all functions. Had to coast to a stop and luckily no other cars were behind us. Additionally, car fuel tank valve does not stop gas when fueling and causes gas to surge out of tank when fueled and onto vehicle. Reported this problem to Dodge and they said this VIN no. Wasn't covered by recall.

- San Antonio, TX, USA

problem #3

Feb 062012

Avalanche 8-cyl

  • 68,000 miles
Transmission failed on acceleration from stop. Brought to Chevrolet dealer who told me "the 1st and 2nd gear came apart internally" and that a complete rebuild was necessary. No prior indications of transmission problems (I.e. slipping, noise, etc...). will cost me over $3000 to repair. Searching on line, I found several other owners complaining about the same problem with less that 90000 miles on their vehicles.

- Haymarket, VA, USA

problem #2

Nov 182011

Avalanche

  • 117,000 miles
Transmission failure, no warning signs. Vehicle felt like it popped out of gear. Truck does nothing in drive, only moves in reverse, 1st, and still does major slipping. Online research has informed me that this is a common issue among this type of truck.

- Ft. Sam Houston, TX, USA

problem #1

Dec 312009

Avalanche

  • 60,000 miles
In Apr 2009 I took my 2007 Chevy Avalanche in for servicing. The "check engine" light was on and I had recall #0848 performed. This recall was to install a wire harness (heated washer fluid module shortcircuit). The catalytic converter and an 02 sensor was replaced. Approximately Aug/Sept I had an odor in the vehicle (smelled like dirty feet or the interior carpet was wet for some time, without proper ventilation to dry. However, I thought that was odd as I was unable to locate any leaks inside the cab of the vehicle.) on or about Oct 2nd, I was driving on the freeway and the "check engine" light came on and a message to turn off the engine which I did. After being towed to the dealership, I was told the engine had lost oil pressure and a sensor was replaced. Immediately after the work was performed the smell went away but that same evening I was driving and the windshield wipers started going, fluid spraying, while in the off position. I had to turn the vehicle off to get it to stop. I immediately notified the dealer, since this has happened 2 or 3 times. The end of Dec I took my vehicle in to the dealership for the intermittent wiper/fluid problem and I thought the transmission was slipping. They couldn't find an issue with the transmission and their diagnosis for the wiper unit was that the module was bad and needed to be replaced. They referred to bulletin #4298, dated 02/26/07, and part #1910885. It is my belief that all the failed sensors/parts are related to the recall and I am hoping the investigation to the recall is still open/on-going. Fyi: Within the first year of purchasing the vehicle my battery needed to be replaced after being inspected at the dealership. If I remember correctly there were several occasions I was unable to start the vehicle. There should be records on file at the dealership pertaining to this issue. Lastly, I do have the part that was replaced as a result of the oil pressure sensor.

- Concord, CA, USA

Not what you are looking for?