Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Print this page Notes: The 2006 Equinox is plagued by a heating problem, as in the heater only blows cold air.

The reported cause of this problem is a small door, known as the air temperature blend door, which allows air to flow past the heater core. This door has a plastic connecting shaft to an electric motor and the shaft is prone to breaking after a few years. The problem has a typical repair cost of over $800.

The 2006 Equinox also has a number of reported problems ranging from the key getting stuck in the ignition, to failing speed sensors, and trouble starting the engine. All in all, this car sounds like one worth avoiding.


really awful
Crashes / Fires:
1 / 2
Injuries / Deaths:
1 / 0
Average Mileage:
151,577 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2006 Chevrolet Equinox electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2006 Chevrolet Equinox:

Unsubscribe any time. We don't sell/share your email.

2006 Chevrolet Equinox Owner Comments (Page 6 of 6)

« Read the previous 20 complaints

problem #16

Aug 312010


  • 42,000 miles


Chevrolet passlock system is intended to keep one's car from being stolen but the widespread issues with this system are a danger to its drivers. This system has left me stranded several times because it hinders the engine from starting.

- Birmingham, AL, USA

problem #15

May 272010


  • 9,010,900 miles
Truck lost speed without warning while driving in traffic. Engine cuts off while driving. Truck can be working one minute and you park and come back and nothing it would start and have to be tow and this has happen to me three times in the last 5 months. The elec system always have something wrong with it. Running at 55 mph and a semi-tractor trailer behind you with your three small grand children in the back and the truck just lost it speed with no warning is a frightening thing to happening. I have replaced the battery, the started, and now the lower cooler fan is out the elec. System just keep breaking down back to back and I hardly even drive it only to doctor appointments and to do my shopping.

- Niagara Falls, NY, USA

problem #14

Jun 042010


  • 56,000 miles
2006 Chevy Equinox would not start yesterday morning. Put a brand new battery in it, it started then when I got to the store and came out tried to start it, it would not start! finally got it to start after I lifted the hood and banged on a couple of things. Drove it to dealership and parked it, was told to drive truck around to service department and guess what? it would not start. They charged $230 to "fix" it. Was supposedly poor terminal fit at starter solenoid causing excessive heat at starter relay. Got my truck home, decided to go get something to eat and truck would not start again! :(

- Memphis, TN, USA

problem #13

Mar 182010


  • 77,809 miles


Heater in my wifes equnax just quit working while was driving it windshield iced over and foged up she had to pull over rite away tobefore she wrecked

- Hudson , IN, USA

problem #12

Dec 242009


  • 30,000 miles
Bought my 2006 Equinox lt AWD and two months later I was out of town took my car to the car wash and came out of it and my car went into limp mode. Tried to restart it and the same thing happened I tried to drive but could not go any more than 20 mph parked the car and had it towed to a NY dealership. They told me the car was running lean codes came up got it to start at the end of the day and I was on my way. Brought it back to my original dealer and they could not find a problem. Changed a gas pedal, fuel pump. About 7 months later pulling out of my driveway and my car just stalled brought it in could not diagnose the problem. Another couple of months later out of town in a major intersection in the rain with a full car my car died no power pulled over luckily and turned the key and it started up again. At another point in time I noticed that under the dash board on the passenger side water was coming in when there was a heavy rainfall. I too reported this an no answer. I also had problems with starting my car I would either have a hard start or it would stick so they replaced the alternator at my cost. It is so frustrating talking to the mechanics they make you think you are losing your mind but now reading these problems I think I might have damage to my computer. Oh yeah here is one more problem I have the light on my heat knob is out and they tell me in order to fix the problem I have to purchase a whole new compartment there is no fuse or light the whole area needs to get pulled out and replaced labor plus part $600 no thanks.

- Middlebury, CT, USA

problem #11

Jan 112010


  • 42,000 miles
On Jan. 11, 2010 I started my car to let it warm up before leaving for work. I let the car run for about 10 minutes. Drove the 20 minute drive to work, and when I got downtown, the car shut down and all of the warning lights on the dashboard came on. Was able to coast to side of street and stop car. Restarted car and put into drive. All warning lights still on, and don't have any power. Was able to coax car to go three blocks to parking lot, and called dealer who came and got the car. After checking, I was told that water had leaked down the right front passenger side of the window, freezing, thawing and backing up which got to the wiring and burnt it out. Really glad that I wasn't on the interstate that morning.

- Cincinnati, OH, USA

problem #10

Mar 152009


  • 55,000 miles


I purchased a 2006 Equinox-Chevrolet almost 3 yrs already. I had a very dangerous experience twice w/the car, I was on the highway and the car all of a sudden slowed down completely and would no accelerate at all. I have taken it to the mechanic and he said that is a problem this particular model car has from factory.I have read Equinox complaint--recalls and read several that encountered the same problem. I believe this is a really big safety issue for a car to turn off/slow down while driving 70 mph--there should be a recall on this vehicle for this problem that can result in a fatal accident. Please advise me what I can do in this matter. I now afraid to drive and I'm always traveling with my grandkids. Please help!!!!!!!!!thank you for your support.

- Lakeworth, FL, USA

problem #9

Mar 172009


  • 64,000 miles
My 2006 Equinox has been shutting itself off while driving it. I was driving on the interstate doing 70 mph and without notice, the engine shut off completely. How I managed to coast from the fast lane to the right shoulder without causing a wreck, god only knows. It has done the same thing on 3 other occasions. I was simply running errands in my neighborhood and the engine just shuts off. No warning lights come on. The engine light does not stay on either. After waiting a minute, the car restarts and can be driven. But I have no idea when this will happen again. I have had it in the shop 2 times so for repairs and they can't find anything wrong. (going back for number 3 today.) no computer codes appear to be diagnosed. This is a very dangerous situation. I can't be driving a car and it just decides to shut down on its own. I have kids and can't be putting their life in danger or even the other motorist. I have been researching on other car sites and found 6 other instances of this within the last year. I think Chevrolet needs to look into this asap before someone gets killed.

- O'fallon, MO, USA

problem #8

Sep 122006


  • miles
September 12, 2006 vehicle into the garage because the previous evening while driving the vehicle, smoke and a burning smell was coming out from inside the steering column. At this visit I was told that since the vehicle currently wasn't experiencing the problem there was nothing they could do. The vehicle was checked and no problem was found. January 18, 2008 vehicle was taken in because the key was sticking in the ignition causing the engine to rev and then the engine would shut off completely. The technician could not get the vehicle to duplicate the problem. Ignition cylinder was cleaned and lubed. April 24, 2008 vehicle taken into the garage for ignition sticking and then vehicle shutting off. Again, cylinder was cleaned and lubed. May 1, 2008 vehicle taken into garage again same problem. Technician noted that they found nothing wrong, but the ignition cylinder was replaced and a new key was cut. After picking the vehicle up, the problem still continued. September 11, 2008 vehicle taken back with identical problem of the key sticking in the ignition, revving the engine and then the engine shutting off. Cylinder was cleaned and lubed. October 24, 2008 vehicle back into the garage with the same problem. At this time they said they could find nothing wrong and asked if they could keep it over the weekend or return the vehicle on the morning of Monday, October 27, 2008 and let them continue to look at it. On October 27, 2008 the vehicle was dropped off. Technician could not get the vehicle to replicate the problem and the vehicle remained at the garage until October 30, 2008 at which time they again told me that they could not find anything wrong with the vehicle and I needed to come pick it up. The above described problem has been on-going since the issue in September 2006. It occurs sporadically and does not seem to have any connection to the weather, the time of day, etc.

- Harrisburg, PA, USA

problem #7

Sep 252008


  • 25,700 miles
Vehicle fire. Cell phone charger was plugged into the front auxiliary power outlet. 2-3 minutes later smoke was noticed, and fire erupted from the center console where the power outlet is located. Vehicle was immediately pulled off the road and phone charger was unplugged, burning the tip of one finger. Vehicle was exited and 911 was called. Fire dept. Arrived and extinguished the fire. Phone charger and phone are intact and were not burned or damaged in any way, I in fact was still using them in our other vehicle until requested not to, by my insurance company, and to hold them for further investigation. After the fire, the fuse for the power outlet was checked and had blown out. Don't know yet what caused the fire. It certainly appears the wiring shorted out? vehicle was a total loss.

- Kenmore, NY, USA

problem #6

May 152007

Equinox 6-cyl

  • 17,703 miles


Everytime that I take my car in for a quick car wash or if it rains really hard (in Florida it does)... water leaks through the lights in the ceiling, the back hatch, and through the floor boards. My check engine light comes on and the dealer tells me that it is water corrosion from the water leaking through the electrical wiring harness. This causes my car to run, even though I have my pedal to the floor, very slow. I can't go past 10mph. I am afraid of electrical fire. I can hardly turn a corner... I am afraid of a car accident. My car is only 2 years old now... 4/2008 and this has happened a 3rd time. My battery has already had to be replaced and my radio replaced twice because of the "cd changer error". now I can only imagine, with all of the water that keeps coming in, what condition my car will be in a few months from now. Electrical problems, bad smell, corroding floor boards and who knows what else.

- Brandon, FL, USA

problem #5

Dec 022006


  • miles
I took my 06' Chevy. Equinox lt into the shop two months after I purchased the vehicle. I had drove my car down the street and when I got ready to come home. I put the car in reverse and it didn't move all. I had my car towed to todey Chevrolet of oxnard, ca and about 3 days later they had called me to tell me that they had to replace the whole computer in my car. That there had been water leaking on the side psgr. Door. The leak was so extreme that all the wiring leading to the computer was rusted. I had my car returned to me after about 2 weeks. Water still leaks in my car but, not as severely.

- Port Hueneme, CA, USA

problem #4

Feb 062007

Equinox 6-cyl

  • Automatic transmission
  • 2,177 miles
Tuesday Feb 6th went to license branch in South bend in. Was inside for approximately an hour and a half. Walking to the Equinox, used the unlock button. Lights flashed, doors unlocked. Got inside vehicle and had no power. Vehicle would not turn over, doors would not lock or unlock. Absolutely no power. There were no lights that had come on in the vehicle to indicate a low battery or any other warning condition prior. I called ligonier dealership where I purchased vehicle and was told to call a local dealership. Gate Chevrolet of South bend came and got the vehicle started with a booster, but said they had no idea what would have caused it or what the problem was. Vehicle had 2177 miles on it. I drove home, pulled in the garage, turned the vehicle off, tried to restart and had no power to the vehicle at all. Not even enough to turn on the dome light when I opened the door.

- Goshen, IN, USA

problem #3

Jun 122006


  • Automatic transmission
  • miles
- the contact stated that while driving in the rain vehicle lost power. This has happened several times within the last 6 months. The contact took the vehicle to the dealership to be serviced and they have not been able to diagnosis the failure.

- Milford , CT, USA

problem #2

Jul 032006

Equinox 6-cyl

  • Automatic transmission
  • 50 miles
Bought new 2006 Equinox with three original miles. 1) right rear seat belt locked up, ratchet tighter and would not release until removed and fully retracted. Six occurrences, three times to dealer who could not duplicate. 2) left rear seat belt locked up, ratchet tighter and would not release until removed and fully retracted. Four occurrences, three times to dealer who could not duplicate. 3) engine falters when in reverse. Three occurrences, dealer has not looked at this issue. 4) instrument cluster / gauges not working. Three occurrences, two times to dealer who could not duplicate. 5) engine will not start. Six occurrences, one time to dealer who could not duplicate. 6) engine will hesitate to start / extended crank. Five occurrences, one time to dealer who reprogrammed PCM but issue still exists. 7) ignition switch grinding or will not turn. Daily occurrences, one time to dealer, issue still exists. 8) no onstar data communication. One occurrence, one time to dealer who could not duplicate. 9) onstar unable to detect service light in instrument cluster. Issue not brought to dealer at this time. 10) engine coolant extremely low within 5000 original miles. Issue not brought to dealer at this time. 11) engine coolant brown and foaming. Issue not brought to dealer at this time. 12) alarm system deactivated itself, interior and exterior lights on, doors were still locked. Issue not brought to dealer at this time.

- Mount Angel, OR, USA

problem #1

Jul 142006

Equinox 6-cyl

  • Automatic transmission
  • 3,400 miles
On Friday July 14, 2006 my wife came out of work at around 4:00 pm on a very hot day and attempted to start her Equinox & when it started, the power steering was not engaged. I left in the middle of a game of golf and went to her aid. When I got there and started the car, the steering worked fine. We left it a the dealer for the next week where they could not reproduce the problem even though they did recover an error code indicating something failed in the ignition. They replaced the ignition. This problem again occurred on Friday Sept. 18, 2006 at approximately 4:00 pm on another very hot day. I called to get it towed & when they arrived approximately 2 hrs later, the problem again was not apparent. I had it towed once more to the dealer and informed them that I felt it was related to a very hot interior. They had it the entire next week and again found no problems, however, they replaced all of the electronics in the steering column that had to do with the electric power steering. Sunday Sept 17, 2006 after having the car 2 days, it froze up twice again while sitting in my driveway. All problems occurred on hot days where the car was closed up. The dealer currently has the car again and is telling me that he sees no problem. I am wondering why I bought the vehicle & why my car company is appearing to be of little or no help.

- Macungie, PA, USA

Not what you are looking for?