Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Print this page


pretty bad
Typical Repair Cost:
Average Mileage:
110,168 miles
Total Complaints:
25 complaints

Most Common Solutions:

  1. not sure (22 reports)
  2. blown fusible link (1 reports)
  3. brain of car erased (1 reports)
  4. replaced ignition (1 reports)
2004 Chevrolet Impala electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2004 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

2004 Chevrolet Impala Owner Comments (Page 2 of 2)

« Read the previous 20 complaints

problem #5

Oct 202009

Impala LX V6

  • Automatic transmission
  • 65,000 miles


Car suddenly won't start, even since the starter was replaced. That didn't fix it! So, what next, the switch? This has happened about 12 times already! Car was just purchased about 6 months ago(used car). We can drive around making stops then all of a sudden it stops starting up. Usually after 30-45 minutes it will finally start like it should have to begin with. Whats up with this freaking car?

- , Belton, SC, USA

problem #4

Mar 192009

Impala V6

  • Automatic transmission
  • 72,296 miles

I'm fed up and sick and tired on this on going problem with my car. I've been stranded 4 times within the last couple of months. My car will intermittently won't start. I turn the key and the engine won't start. There is no security lights, and the radio, lights, and horn fine. After letting it sit for about 45 mins to an hour, turn the switch and it starts. The dealership inspected the starter connections and battery terminals with no avail. The next time this occurred they did a complete electrical test and it showed no readings. Now they tell me there is nothing more they can do to re-create the problem. They have my car overnight and said it starts each time. They said they need to see the vehicle in its failed state before they can suggest or fix the problem. It's a unpredictable problem. I don't know when its going to happen again and if it does, by the time I have it towed to the dealership the problem with have then corrected itself. I am ANGRY. The last time this happened to me I was in the mall parking lot alone in the dark and I am a female. I purchased this car as a means of it being reliable and dependable to me and its not. I can't drive anywhere for fear that my car won't start again.

After reading all the other complaints, I will ask the dealership about the Passlock system concern. How do I contact GM about my complaint? Is there a recall for this problem?

- , N Charleston, SC, USA

problem #3

Jan 052009

Impala LS

  • Automatic transmission
  • 83,189 miles

Car won't start after putting key in ignition!! I then hit lock button , the car started right up!! Call Chevy they states this will be estimated about $400 to $1000

- , Gary, IN, USA

problem #2

Nov 192008

Impala 3.2L V6

  • Automatic transmission
  • 56,000 miles

I hate with vengeance that the auto industry will not sell a "motor manual" for this car. I hate the fact that they want 200.00 for a code reader (when a 1985 Lincoln cost 45.00 for the same) They are rip off bastards. And to top it off, the impala has a trouble code setting that makes it run sh*tty until you fix it. Another rip off system. If and when I get it fixed, I will forever hate Chevy and buy foreign trucks and cars. I am sure that Chevy does not care - but reputation is part of business and their reputation sucks. F them.

- , Sacramento, CA, USA

problem #1

Jul 282006

(reported on)


  • 65,000 miles

Sometime when i go to start the car it won't do anything, no noise at all. After i try for a while it does finally start, so far anyway. I have only had the car for about 3 months, but long enough for the warranty to expire.

- , Mchenry, MD, USA

Not what you are looking for?