Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Print this page

2.0

hardly worth mentioning
Crashes / Fires:
0 / 1
Injuries / Deaths:
0 / 0
Average Mileage:
79,122 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2009 Chevrolet Impala drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2009 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

2009 Chevrolet Impala Owner Comments (Page 1 of 3)

problem #51

Jul 252015

Impala

  • miles

A D V E R T I S E M E N T S

The car has erratic shifting. It seems as if the gears get stuck before they release especially when slowing down then taking off, like if you do a rolling stop or slow down at a traffic light but don't stop fully before accelerating again. It does not do it everytime you drive though. There is also a clicking coming from behind the dash. The actuator for air has gone bad.

- Floyd, VA, USA

problem #50

Jun 042016

Impala

  • 134,000 miles
Car is currently at 134K miles and just gave me a "reduced power engine", "check traction control", and a check engine light. I googled around and came across a lot of Chevy Impala around the same year (07-10) are having the same problem. It seems to be something with the "accelerator pedal positioner pedal sensor. Also reading into it, it claims that this problem can cause the car to suddenly stop from 60mph all the way down to 20 or zero. This is extremely dangerous and needs to be looked into before someone is hurt or killed.

- Avondale, AZ, USA

problem #49

Nov 052015

Impala

  • 121,000 miles
The contact owns a 2009 Chevrolet Impala. While starting the vehicle, the interlock failed and it was unable to shift gears from drive to park. The shifter failed to respond. The vehicle was not diagnosed or repaired. The manufacturer was made aware of the failure. The failure mileage was 121,000.

- Eastpointe, MI, USA

problem #48

Aug 032015

Impala

  • 156,830 miles

A D V E R T I S E M E N T S

The contact owns a 2009 Chevrolet Impala. The contact stated while driving 70 mph, suddenly the vehicle independently decelerated and the traction control light illuminated. The contact stated the vehicle also intermittently failed to accelerate when idled. The vehicle was not diagnosed or repaired. The manufacturer was not made aware of the failure. The failure mileage was 156,830.

- Crystal Springs, MS, USA

problem #47

Oct 012014

Impala

  • miles
The contact owns a 2009 Chevrolet Impala. While driving at 35 mph, the vehicle lost power and jerked. In addition, the service stability traction and power reduced was displayed across the message board. The failure recurred on numerous occasions. The vehicle was taken to a dealer who was unable to diagnose or repair the vehicle. The manufacturer was not notified of the failure. The failure mileage was unknown. The VIN was unavailable.

- Rolling Prairie, IN, USA

Search CarComplaints.com for these popular complaint phrases...

problem #46

Sep 152011

Impala

  • 49,000 miles
Traction control light, and reduced engine power light came on. Lost power to the engine and had to stop. Turned the ignition off. Waited 10 minutes and started the car. Ran fine until I got home. This happened a few times before I took the car in. Found out it was an accelerator pedal position (app) sensor.

- Northfield, MN, USA

problem #45

Apr 022015

Impala

  • 62,000 miles

A D V E R T I S E M E N T S

Driving on interstate vehicle suddenly lost all power and would not accelerate & quickly decelerated with any prior warning. 18 wheeler almost rear ended me. Instrument panel displayed "engine power reduced", "service traction control, " "service stabilitrak", and "check engine light." Finally exited interstate safely and shut down engine thinking it was going to blow up and after 2-3 tries to restart messages disappeared and vehicle seemed to be ok. Took vehicle to mechanic & found codes evidencing the loss of communication between the tac and or the app units causing vehicle to go into limp mode but could not get the condition to reoccur. Mechanic had to remove codes to permit to duplicate problem, could not duplicate and told me to wait until reoccurred. While looking for repair shop was scared it would happen again received letter from GM stating if the above condition had occurred they would fix. Called GM dealer mentioned letter they refused to repair unless the messages were present on panel, refused to look at the vehicle. Called GM customer service referencing letter, explained GM dealer refused to repair. Was told by angela issue was safety related problem but GM would not admit to safety issue. GM agreed to pay for one hour of diagnostic time to determine if vehicle qualified for repair, dealer was unable to duplicate problem, refused to repair. Called GM and was told no repair would be made even though the problem had occurred as stated in the letter and to wait until situation occured again then not to start engine and tow to GM dealer. Was told GM would not pay for tow or inconvenience and if they could see codes they might repair problem. This is definitely a safety issue since when this occurs the vehicle loses all power and basically shuts down and will not accelerate beyond 5 mph if at all. Leo nelson 937-554-9778 noslenlsn@gmail.com

- Riverside, OH, USA

problem #44

Jun 172015

Impala

  • 100,000 miles
Reduced engine power, car cuts off while driving. Chevy is aware of defect and refuses to recall

- Bunnell, FL, USA

problem #43

May 312015

Impala

  • 97,000 miles
The contact owns a 2009 Chevrolet Impala. When driving up an incline at various speeds, the vehicle would independently lose power or fail to accelerate. The vehicle was not diagnosed. The manufacturer was made aware of the failure. The vehicle was not repaired. The failure mileage was 97,000.

- San Francisco, CA, USA

problem #42

Jan 302015

Impala

  • 115,484 miles
I bought this car used in 2012. This car had periodic electrical issues and a CO2 sensor failure, but there were no issues comparable to a total transmission failure. Earlier in the winter of 2015, I noticed that the transmission would not shift up into fourth gear on the freeway until after ten minutes of driving. One day in ann arbor, mi, I was accelerating out of a turn when the RPM meter started revving to 6,000 and the engine lost power. After restarting the Impala, the car went a few hundred feet to red light and died at the intersection. I eventually was able to drop this vehicle off at an automotive repair shop following a long trip full of transmission failures and start-ups. The mechanic later stated that the transmission would need to be rebuilt. The repair cost was over $1,600 and the transmission still possesses the same problems that existed prior to this event.

- Livonia, MI, USA

problem #41

Apr 182015

Impala

  • 74,000 miles

A D V E R T I S E M E N T S

On 18 Apr 2015, my 2009 Chevrolet Impala experienced complete and total failure of the transmission. Since the warranty is 5 years/100,000 miles, I was not eligible for repair due to being 8 months beyond the warranty period. This despite the fact that the vehicle only had 74,000 miles on it at the time.

- Water Valley, MS, USA

problem #40

Feb 232015

Impala

  • 303,303 miles
While driving onto a highway when I reach 56 miles per hour my vehicle lost power and slow down the brakes locked and the electrical system went haywire. The locks started locking and unlocking while the vehicle was in motion. The lights started flickering on and off and the car started shaking rapidly and the brakes locked up. Once I started the vehicle back up and the ignition switch seemed to be stuck and the air bag light displayed on the dashboard. When I turn off the vehicle and try to remove the key the key will not come out so I have to put it into neutral and back into park a few times before it will release the key. Since this has occurred I hear a knocking sound in my glove box when the door is open and closed and sometime hours after ill hear the noise and the electric will flicker.

- Los Angeles , CA, USA

problem #39

Nov 152014

Impala

  • 85,000 miles
The contact owns a 2009 Chevrolet Impala. The contact stated that while at a complete stop, the transmission would go into a hard transition of gears very slowly before shifting into a normal gear. The vehicle was taken to a dealer. The technician was not able to duplicate the failure. The vehicle was not repaired. The manufacturer was not notified of the failure. The approximate failure mileage was 85,000.

- Lexington, KY, USA

problem #38

Feb 182015

Impala 6-cyl

  • 112,000 miles
I have been having the service engine light come intermittently along with the service traction control light. I have had a technician look at this for me and advised that the throttle control sensor (accelerator pedal) is going in and out. The accelerator pedal is connected to a sensor that drives the throttle on the engine. When this happens intermittently the vehicle looses engine power and traction control.

- Flushing, MI, USA

problem #37

Jan 282015

Impala 6-cyl

  • 98,780 miles
Driving to work and the service traction control light went on then engine power reduced and throttle error and the car would not accelerate and powered down. I was at red light so I turned the car off and turned it back on the car would not accelerate so I turned it off again and waiting put my flashers on, waited a few more minutes and the car finally started to move. I took to the dealership because it's a powertrain issue and I have 100K powertrain warranty and the dealership said it's not powertrain and wanted $778 to repair, I called Chevy after seeing the forums only this is a known issue thousands of people with the same complaint and Chevy said they are going to work with the dealership. I have to be back at work Monday and drive through a very rough neighborhood I do not want to breakdown in that neighborhood.

- Clementon, NJ, USA

problem #36

Sep 012014

Impala

  • miles
The contact owns a 2009 Chevrolet Impala. The contact stated that it took several attempts to shift the gear out of park. The vehicle was inoperable. The failure occured on numerous occassions. The vehicle was not diagnosed or repaired. The manufacturer was notified of the failure. The failure mileage was unavailable.

- Westland, MI, USA

problem #35

Oct 312014

Impala 6-cyl

  • 90,680 miles
Car states reduced engine power stalling to about 10mph very dangerous. Many complaints about this issue.

- Attalla, AL, USA

problem #34

Oct 132014

Impala 6-cyl

  • 111,005 miles
My engine power reduced light came on alone with the traction light.

- Mansfield, OH, USA

problem #33

Oct 062014

Impala

  • 92,600 miles
The contact owns a 2009 Chevrolet Impala. The contact stated that the vehicle was not able to change gears from park to reverse. The vehicle was towed to an authorized dealer who diagnosed that the wires and cable needed to be replaced. The vehicle was repaired. The manufacturer was notified of the failure. The approximate failure mileage was 92,600.

- Macon, GA, USA

problem #32

Sep 252014

Impala

  • miles
The contact owns a 2009 Chevrolet Impala. The contact stated that while making a right hand turn, the vehicle stalled without warning. Also, the contact mentioned that when the vehicle was restarted, the transmission would only shift into reverse. The vehicle was taken to the dealer. The technician diagnosed that the transmission sensor needed to be replaced. The vehicle had not been repaired. The manufacturer was not notified of the issue. The failure mileage was unavailable.

- Jackonville , FL, USA

Read the next 20 complaints »

Not what you are looking for?