Print this page

3.6

definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
35,182 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2014 Chevrolet Impala brakes problems

brakes problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2014 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

2014 Chevrolet Impala Owner Comments

problem #11

Dec 212016

Impala

  • 50,000 miles

A D V E R T I S E M E N T S

On 12/21/16 while merging onto interstate 10 in tucson, AZ, the vehicle was going approximately 65 mph when a "engine power reduced" sign popped up, the vehicle slowed down to 30 mph without warning and shifting down through all gears nearly red lining the rpms and causing an rear-end collision. Was able to move the vehicle off the freeway and took it into local auto-zone for testing. The test came back as a "throttle sensor malfunction". the vehicle now doesn't feel safe to drive, and will not accelerate over 45 mph without shaking and feeling like the transmission is going to give out. Called the local Chevy dealership and was told the cost was going to vary between $400-1,000 with a $100 test fee up front. I've also read numerous similar issues online from people driving Chevrolet Impala from 2006-2016. The car feel very unsafe to drive and I feel it could be a death trap as there is no control over when the vehicle will choose to decelerate without warning. There has been no mechanical issues before this incident, and the vehicle has been through numerous mechanical maintenance up-keeps that were recommended by service managers.

- Marana, AZ, USA

problem #10

Nov 252016

Impala

  • 50,000 miles
While turning right and backing up or turning right into a parking space at low speed the stabilitrac/ traction control activates and stops the driver side front wheel for a moment, and then releases and a grinding/rubbing noise is heard coming from the drivers side front wheel when this problem happens and is a random problem that happens more frequently, when it is cold and damp.

- Gladwin, MI, USA

problem #9

Oct 042016

Impala

  • 89,000 miles
At about 85,000 miles I am getting a grinding noise from the left front side. Dealer said it was bearings, which I had replaced at a private garage. Now the sound is back after only a thousand miles or so. Typically, it happens at low speed, and mostly when turning left.

- Union, MI, USA

problem #8

Oct 202016

Impala

  • 30,000 miles

A D V E R T I S E M E N T S

My Impala 2014 suddenly says 'service stabilitrak' in the display and the engine power drastically reduces. I have see this in forums that is a common issue with GM cars and it happened to me couple of times. This is a very dangerous issue when happens at freeways or any faster traffic routes.

- Snoqualmie, WA, USA

problem #7

Oct 062016

Impala

  • 28,697 miles
While driving and accelerating to get on the highway the electronic stability control "stabilitract" light popped up on the dash screen and reduced the engine's power, reducing my speed to a maximum of 30 mph when trying to accelerate to the posted 55 mph speed limit. I was traveling in a straight line when the "stabilitract" & "engine power being reduced" information popped up. The car would not go over 30 mph. This caused me to have to pull over and nearly caused an accident due to the slow nature of the vehicle, even with the emergency flashers on. This is several incidents with this particular car, having electronic failure. The worst of it was when the collision sensor was affected by a leak in the car after having to have the windshield replaced due to the rear view mirror falling off. That incident caused the car to slam on it's breaks due an electrical error. This car has been in the shop for numerous electrical issues. Chevrolet has refused to do anything but the bare minimum to get the car back on the road obviously not fixing the root of the problem, as this is once again an electrical issue. Not safe to drive if the electronics are going to continue to fail.

- Marysville, WA, USA

problem #6

Apr 272016

Impala

  • 32,900 miles
4/27 approx 5:20pm @ 70mph, "loss of engine power" and some stabilty warning came on. Check engine light and traction light lit, was in center lane, thankfully got to the left berm. Car would not accelerate. Turned off, touched brake a couple times, sat a few mins, restarted, ck engine light still on, but engine power warning not on, was able to get into moving traffic and took to dealier 4/27 apprx 7pm, with GM rental given to me. As of 1:12pm, no call yet, not sure what the issue is, but could have been fatal!!!! bad, bad bad!!! took a pic, blurry though, frightening! told dealer of sudden surges, but intake rep said it would all be related and didnt write it down.

- Columbus, OH, USA

problem #5

Jan 282016

Impala

  • 23,500 miles

A D V E R T I S E M E N T S

Water was leaking down from over head dome light and from door jam, all the main electrical safety controls are housed where the light is in the roof. Called dealership was told first available date to get the car in for repairs is February 22nd. On my drive home from work the collision control came on started flashing the red lights on the dash and slammed on the brakes, like the was a vehicle in front of me has come to a dead stop, except there was no vehicle in front of me, the road was open. I was getting off the highway when this occurred, while driving in a straight line. When home and the car was turned off I'm getting errors saying key fob isn't in the car, and the electronic parking brake needs to be serviced. The car is inoperable at this point. Even if it does start again is a safety hazard at best and has to be towed to the dealership for repairs. It cannot be driven in the electrical state it's in.

- Marysville, WA, USA

problem #4

May 292015

Impala

  • 40,230 miles
While turning vehicle to the right or left, whirring noise occurs coming from front suspension. Notable power loss when accelerating to the right or left into oncoming traffic creating a dangerous situation for occupant and oncoming traffic. When this incident occurs, the traction control light luminates on the dash.

- Westbrook, ME, USA

problem #3

May 102015

Impala

  • 21,148 miles
While making a right hand turn at slow speed the automobile felt like the transmission downshifted and then a message came up in the dic telling me to service the "stabilitrak", service traction control, and the ABS lamp illuminated. After have the automobile sat for approximately an hour all of the above messages were no longer visible. I brought the car to the dealership on May 14, 2015 to have it checked out but they could not find any problems. The same problems have occurred approximately 4-8 times now with the information staying on in the dic for various lengths of times.

- Syracuse, NY, USA

problem #2

Sep 022014

Impala 6-cyl

  • 18,756 miles
I was going to work and on the way a message saying my traction control needed to be checked came on. Also, today as I was going to town another message came on saying my parking assist needed to be checked.

- Pine Bluff, AR, USA

problem #1

Jul 252013

Impala 6-cyl

  • 2,770 miles
At 70 mph vehicle slowed on its own. Vehicle information center read "stabilitrak and engine power is reduced". got yellow traction control system light on the instrument panel with a "malfunction indicator light" below the speedometer.engine running rough at ashland, va exit.engine was shut down then restarted with same warnings as before.approximately 45 mins later restarted to have a local Chevrolet dealer look at the car. On restart, all warnings and indicator lights except for the "malfunction indicator light" were out and engine ran normally.dealer guessed that it was probably a "glitch" and it was probably ok to drive.the 800 or so miles to sarasota were without problems. On 8/5/2013 took car to local dealer approximately 3 miles from my home. On entering the dealer's parking lot at approximately 10 mph the problem reappeared I.e. "engine power reduced with stabilitrak" with warning lights as before. This is a safety issue as it can happen at any time!!

- Sarasota, FL, USA

Not what you are looking for?