If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

7.3

pretty bad
Typical Repair Cost:
$533.00
Average Mileage:
98,676 miles
Total Complaints:
11 complaints

Most Common Solutions:

  1. not sure (7 reports)
  2. have code read.usually it is a speed sensor &/or hub (2 reports)
  3. replace rear speed sensor (1 reports)
  4. replaced all 4 sensors and hub assemblies (1 reports)
2001 Chevrolet Monte Carlo brakes problems

brakes problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Chevrolet Monte Carlo:

Unsubscribe any time. We don't sell/share your email.

2001 Chevrolet Monte Carlo Owner Comments

problem #11

Feb 142012

Monte Carlo SS 3.8L

  • Automatic transmission
  • 81,000 miles

A D V E R T I S E M E N T S

Every-time I start my car the traction control light goes off saying it is no longer on and the ABS system lights up as well, and, both stay on the entire time the vehicle is on. It is very inconvenient. I also am hearing this awful noise like a grinding as this is happening...

- , Uniontown, PA, USA

problem #10

Jan 182012

Monte Carlo SS 3.6L V6

  • Automatic transmission
  • 187,000 miles

Everytime I start my car the traction contraol light goes off saying it is no longer on and the ABS system lights up as well and both stay on the entire time the vehicle is on. It is very inconvenient.

- , Caldwell, ID, USA

problem #9

Mar 012011

Monte Carlo LS 3.2L V6

  • Automatic transmission
  • 162,467 miles

my service traction light come on and the car make right turn the car make small noise

- , Fredericksburg, Virginia, USA

problem #8

Feb 272011

Monte Carlo 3.8L

  • Automatic transmission
  • 120,000 miles

A D V E R T I S E M E N T S

this is a great way to fine a solution to fix a problem

- , Chattanooga, TN, USA

problem #7

Mar 022010

Monte Carlo LS 3.4L 3400 V6

  • Automatic transmission
  • 108,500 miles

Not sure what's going on but one day, I was heading to work and I hear this chime ring a couple of times and l look down at the dash and see the traction control light on saying that the Traction is Off, Service Traction Control on and the ABS light on. It was on steady for a few days and then I noticed when I washed the car it seemed to disappear for a few. Not sure if there is salt in the sensor or what's going on. I do plan to look into it also. If I figure out what it is, I will post as always.

Update from Jun 14, 2010: Ok, so I figured out what was wrong...Sorry it took a few to get back here. Anyway, the rear hub assembly and speed sensor was totally seized up and froze!! It was so rusty! I cleaned up the hub assembly and replaced the speed sensor. Cleaned up the other side too and while I was at it, checked the rear brakes. No more issues there. The lights have disappeared. Parts aren't what will hurt ya so much its the labor. Find a good garage to do it unless you really want to pay the large dealership to do it! It'll cost ya a pretty penny to do it that way....close to 800 depending on if it's one of the assemblies or both. Also, there is code that the abs sets off, it can be read but usually only dealerships have it. Not sure if Autozone has the tool to read it. That might be able for you to determine the problem before attempting work.

Update from Jun 14, 2010: .

- , Cleveland, OH, USA

problem #6

Jun 052007

Monte Carlo LS 3.8L

  • Automatic transmission
  • 70,000 miles

if this is the best GM can build then we are in real trouble because my last 3 GM cars have been junk. I don't say that lightly, my father retired from GM and I have been a pro American car guy my whole life, but now I am starting to change my mind. I want quality for my money and all the GM cars are now made in Canada and Mexico anyways so my next car could end up being from a foreign manufacturer.

- , Tampa, FL, USA

problem #5

Jul 052007

(reported on)

Monte Carlo LS 3.8L

  • Automatic transmission
  • 77,793 miles

A D V E R T I S E M E N T S

everytime i want to drive my traction control light comes on and then the abs light comes on. my car is under warranty but my dealership tells me there is nothing wrong so they don't fix it. if nothing is wrong why does it do it?

- , Tampa, FL, USA

problem #4

Aug 262007

(reported on)

Monte Carlo SS 3.8L V6

  • Automatic transmission
  • 56,672 miles

abs light on also trac off is on. Service traction system in message center. Had this fixed by replacing hub asembly with speed sensor at 56,000 miles at a cost of $500. Now at 58,000 miles it is doing it again. I suppose it is the left rear speed sensor this time for another $500.

- , Rushville, IL, USA

problem #3

Dec 262006

(reported on)

Monte Carlo LS 3.2L V6

  • Automatic transmission
  • 40,000 miles

ABS service traction system lights comes on and stays on. Every time I have had brake pads or rotors changed this seems to reset the traction system. 1 day later the warning light... SERVICE TRACTION SYSTEM comes back on and stays on until my next brake pad service. no one seems to know how to fix it.

- , McHenry, IL, USA

problem #2

Apr 022006

(reported on)

Monte Carlo SS

  • 93,000 miles

traction control system is always kicking on for no reason

- , Benton, KY, USA

problem #1

Feb 022006

(reported on)

Monte Carlo SS

  • 89,000 miles

service traction system and abs lights on and makes a noise when i take off

- , Indianola, Mississippi, USA

Not what you are looking for?