Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

2.0

hardly worth mentioning
Crashes / Fires:
0 / 6
Injuries / Deaths:
0 / 0
Average Mileage:
80,689 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2009 Chevrolet Silverado 1500 Hybrid electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2009 Chevrolet Silverado 1500 Hybrid:

Unsubscribe any time. We don't sell/share your email.

2009 Chevrolet Silverado 1500 Hybrid Owner Comments (Page 1 of 2)

problem #32

Sep 072016

Silverado 1500 Hybrid

  • 105,000 miles

A D V E R T I S E M E N T S

The truck was sitting parked in the driveway and my neighbor noticed that the lights and wipers came on (truck was not on, no keys were in it, nobody was in it or near it!). smoke then began to billow out from under the hood and a fire started. My neighbor was able to disconnect the battery and put out the fire. I had the truck towed to a garage where they told me that the fuse panel caught on fire. They called GM and was told there was no recall for the part. Dealing with insurance now.

- Fitchburg, MA, USA

problem #31

Mar 022016

Silverado 1500 Hybrid

  • miles
So about 4 months ago I replaced the battery truck was running fine till about month three. I was driving my truck and all of a sudden all the electrical started freaking out on me. I popped the hood and pushed the negative wire for the battery down and it stopped for a good two months so today (June 7th, 2016)I was on my way to autozone to have them check the battery for me and on my way over to them truck thre a temper tantrum and started with the freaking out then I was almost there and it just completely shut off on me in the middle of traffic I was luckly in the turning lane to turn into the autozone. It also fid it when I was coming over the mountain freaking out with the electrical. Then just completly came to a stop at the intersection as I was turning left almost got hit by another Silverado 2500 that was right behind me. But every once in a while it'll be okay then all of a sudden just start up again.

- El Paso, TX, USA

problem #30

May 312016

Silverado 1500 Hybrid

  • 171,500 miles
While traveling 70 mph on the interstate everything goes crazy at once: Doors lock and unlock, engine cuts and goes back on, stabilitrak light comes on and goes off, transmission kicks out of gear and then downshifts sending the engine to over 5,000 RPM, radio goes off and on off and on. This event lasts for about 5 to 7 seconds then everything goes back to normal. The problem has occurred intermittently and may not happen again for several months. This problem sounds very similar to NHTSA id #10871399. It is an extremely scary event and when in traffic going 70 and the vehicle downshifts and the speed drops to 50 like you slammed on the brakes, but the brakes have not been touched. It almost caused me to be hit this morning. I purchased the vehicle in February 2014 with 114,000 miles, this first happened in 2014 with approx. 118,000 miles. The vehicle currently has 171,500.

- Burleson, TX, USA

problem #29

Jun 172015

Silverado 1500 Hybrid

  • 48,000 miles

A D V E R T I S E M E N T S

The vehicle first started having electrical troubles when we were traveling down the interstate. The door locks were cycling rapidly, the gauges were bouncing all over the dials, we lost power, the lights on the dash were flashing, and the transmission stopped working, and we were coasting - on an interstate. We pulled over and shut it off for a few moments, started it up and took off again, with no trouble. Got home and I looked it up on the internet, and found many similar/identical stories. We took it to the dealership and they said they could find nothing wrong. They charged us $200, and the problem seemed fixed, for a whole two months, just like everyone else said in their posts. It has done it at least 7 times over the past year, and we have resorted to pushing in the fuses, which wiggle loose - and it seems to fix it, albeit temporarily. Until today. It started happening on the interstate again, and we pulled over, opened the hood, took off the cover, and pushed down the fuses, but none were loose. It acted up about 3 more times on the way back home, and we had to turn around to get the truck in the driveway before it just died altogether. We missed an appointment with a customer (we do construction) because of it. It's not safe to drive - we're worried about getting into an accident because of the loss of power. GM says they're sympathetic, but that doesn't fix it. We don't need sympathy, we need results! they also say they've not heard of the problem - bull----. they know of the problem, they just don't want to do anything about it. Thus far, I don't think anyone has been killed, so the bean counters aren't rattled yet. So far, no lawsuits that I know of - they get to ride off into the sunset with our money and all we get is a junk truck that you can't rely upon even though it only has 58,000 miles.

- Colorado Springs, CO, USA

problem #28

Apr 152013

Silverado 1500 Hybrid

  • 45,000 miles
Mega fuse after purchasing my vehicle, I started having electrical problems with the instruments and headlights going haywire. I had to pull over and when I put my truck in park the engine would die. I would have to pull on the negative battery cable to fix the problem. After changing out the factory mega fuse the issue went away. Ball bearing issue: The ball bearing on the front driver side has gone out twice in over a one year period. I use my vehicle for normal transportation work/home. I am having to have the bearing changed again. This is a safety issue.

- Georgetown, TN, USA

problem #27

Apr 042016

Silverado 1500 Hybrid

  • 117,828 miles
I have had to replace the fuse block twice in this truck the most recent time was 04/04/2016 the first cost was $600 and the most recent cost was $474.90

- Millerburg, MI, USA

problem #26

Oct 062014

Silverado 1500 Hybrid

  • 70,000 miles

A D V E R T I S E M E N T S

The contact owns a 2009 Chevrolet Silverado. The contact stated that while driving at 65 mph, the door ajar warning chimed before the power doors locked and unlocked independently, the gauges fluctuated and the instrument panel illuminated. In addition, the vehicle failed to accelerate when the accelerator pedal was depressed. The failure recurred intermittently. The vehicle was taken to an independent mechanic where it was diagnosed but the cause of the failure was not determined. The vehicle was not repaired. The manufacturer was made aware of the failure. The approximate failure mileage was 70,000.

- San Antonio, TX, USA

problem #25

Mar 172014

Silverado 1500 Hybrid

  • 88,986 miles
While driving the stabilitrak light came on and then the ABS light. It stayed on, so I took it to a mechanic who determined it was the brake switch and he replaced it. It has been fine until recently, when it came on again and my brake lights were sticking on, so I replaced the brake switch again. So, far it's stayed off. My concern is that my truck my start having the same issues as our other GM vehicle, which also involves the stabilitrak/traction control/reduced power lights coming on. Reduced power is dangerous while driving, especially on the interstate in heavy traffic. I have read GM forums and have found that this problem has been happening as far back as 6 years, and GM still has not figured out how to fix it.

- Mapleton, IL, USA

problem #24

Apr 142015

Silverado 1500 Hybrid 8-cyl

  • 72,000 miles
Wife drove truck to the store it was raining hard this day. Came out and truck was dead. Jumped the truck and took it home.looked at the battery. Still had factory battery. Replaced the battery. Next morning the truck was dead. Jumped the new battery truck started. Turned truck off /could hear something running in the fuel tank. Found out that there were problems with the fuel module above the spare tire. Called the dealership for the third time. Creg smith auto group. Galion Ohio 44833. Could not get the service manager on the phone. Left him a voice mail. Never returned my call. Next day called for service manager. They could not find him in the building. Told a man on the other end of the phone everything that was going on. Something was draining my battery and something was running.24/7. man told me he would call me back. Never did. Left for dealership with the truck. Truck stopped on me in middle of the road had it towed home. Never made it to the dealership. I am very upset with everything now. I turned the key and the truck stuck on was still trying to start after I turned key off.. was afraid of the fuel system and electrical system together..one spark could blow me up. Now truck will not start at all. Please help me. I was told by dealer that I had to come to a dealer.all parts had to be reprogrammed for the truck. I have no money ! only owe 2,400 and truck is paid off please help me.

- Mansfield , OH, USA

problem #23

Jan 182015

Silverado 1500 Hybrid

  • 930,000 miles
Locks started locking/unlocking. Gear indicator was going from drive to park. Heat came on by itself and fan went from high to low. Speedometer went from 70mph to 55 mph with loss of engine power. Headlights were flashing on and off. After pulling off I-75 and getting to a safe stopping area the truck would not start after turning the engine off. The engine compartment felt extremely hot: Especially the battery. After 10 minutes, the truck was able to start and continue the rest of the trip. After doing some internet research, this problem is well documented on various Chevy forums and car message boards. Replacing the mega fuse and battery cables appears to solve the majority of the issues as it did in my case. The defective mega fuse and battery cables caused the excessive voltage through the cables, causing extreme heat which resulted in scorch marks on the terminal ends of the battery cables and the insulation of the cables changing color as well as the above issues. I am very grateful that an electrical fire didn't happen which I believe could have easily been the case.

- Fruitport , MI, USA

problem #22

Jan 162015

Silverado 1500 Hybrid 4WD 8-cyl

  • 131,000 miles

A D V E R T I S E M E N T S

I was driving in heavy traffic and used my left turn signal all of the lights is the truck started flashing and the doors unlocked and locked them selves. Then two miles later still in heavy traffic I flashed my lights at a truck to let him know he could safely enter my lane at which point the truck cut completely off going 35 mph in heavy traffic. This is very unsafe and I am lucky that no one was following to close.

- Shiloh , GA, USA

problem #21

Feb 032014

Silverado 1500 Hybrid 4WD 8-cyl

  • miles
2009 Chevrolet truck began to reduce power and check the engine light came on and started surging. The consumer stated it seemed at times, the vehicle was going to stall, but instead it would surge up to 30 mph. It jerked, then it would go. The check engine light went out. The vehicle was taken to the dealer, where the foot pedal application sensor was replaced. On January 3, 2014, while driving on the freeway, the check engine light illuminated again and power to the vehicle, was significantly reduced, the check engine light went out again. The dealer found high resistance in the application sensor circuits and replaced a faulty sensor circuit.

- Wickenburg, AZ, USA

problem #20

Nov 172014

Silverado 1500 Hybrid 4WD 8-cyl

  • 45,000 miles
I was driving my 2009 Chevrolet Silverado one morning on my way to school(luckily I wasn't to far from home when the incident occurred) when the vehicle lost power and the dash showed the check engine light, service stabilititrak, and service traction control. When the incident occurred I was in the middle of the road when my vehicle began to decelerate and eventually was not able to go past 45 mph. I pulled over and my vehicle and parked, shut off the engine, and then started it back up only to show the same icons on the dash. After turning around and slowly returning to my house I shut the vehicle off and had to take my wife's car to work. Under other circumstances this could have gone extremely bad and an accident may have occurred. This seems to be a common trend on the internet and forums and needs to be addressed by GM!

- Burnet, TX, USA

problem #19

Jan 212014

Silverado 1500 Hybrid 4WD 8-cyl

  • 34,189 miles
The first incident was in January 2014 while traveling on the highway at 55 mph the door locks started to cycle rapidly, the gauges all went to zero, the airbag rediness light came on and a service stabilitrac message appeared. The next day the vehicle would not start, after moving the positive battery terminal cover to try and jump the battery all the lights came on and the vehicle started without needing to be jumped. The vehicle was taken to the dealer and they checked everything and found nothing wrong. No codes were stored. They inspected the under hood fuse block and the battery pin tension, both were good. The vehicle has run fine with no problems until November 2014, now it has started doing the exact same thing as it was doing in January. I will be contacting my local Chevrolet dealer and the Chevrolet regional manager again. Also it seems very unusual that the dealer and the regional manager have never heard of this problem. The Chevrolet forums are full of people having the same issues, also there is a technical service bulletin addressing the problem.

- North Bend , OH, USA

problem #18

Oct 132014

Silverado 1500 Hybrid 4WD 8-cyl

  • 73,500 miles
Went out to truck to move it and noticed wipers up on windshield, tried to start it and only check engine light came on, looked under hood to find an electrical burning smell coming from fuse box. Disassembled fuse box to find it was melted and found evidence of combustion, wiring harness connector X2 pin N5 was melted and connector X5 pins G1 H1,2,3,4 K 4,5,6 and J 2,3,4 had melted this is all the damage that I found.

- Columbia Station, OH, USA

problem #17

Aug 282014

Silverado 1500 Hybrid

  • 56,300 miles
The contact owns 2009 Chevrolet Silverado 1500. The contact stated upon walking to the vehicle, the center high mount stop lamps illuminated independently. The contact attempted to start the engine and the vehicle failed to start. The contact then towed the vehicle to the dealer. The technician stated that the under hood fuse block had shorted out and two wiring connectors for the wiring harness had burned inside the block. As a result, the fuse block needed to be replaced. The vehicle was repaired. The manufacturer was not notified of the failure. The approximate failure mileage was 56,300.

- Nicholasville, KY, USA

problem #16

Aug 152012

Silverado 1500 Hybrid 8-cyl

  • 75,000 miles
Key comes out of the ignition while truck is running.

- Picture Rocks, PA, USA

problem #15

Apr 172014

Silverado 1500 Hybrid 8-cyl

  • 62,000 miles
Several times while driving at various speeds the stability control warning light would flash, the door locks would cycle and the gauges would stop working. After a few seconds the warning light would go off and the truck would return to normal. I took the vehicle to the dealer and I was informed that both battery cables had high resistance and needed to be replaced. It is ridiculous that battery cables need to be replaced at 62000 miles. The service adviser made a comment that this was a common problem but it usually happens while the vehicle is still under warranty.

- Bellevue, NE, USA

problem #14

May 012014

Silverado 1500 Hybrid 8-cyl

  • 63,000 miles
Used the truck and parked the truck with no problems. Then the truck sat for 1day and had heavy rain storms come through the area. Then went to use the truck and when I went to start it up the truck would not turn over dead and had a strong smell plastic burning with the cargo light staying on.check the circuit board under the hood and found that some of the fuses had melted.no other problem with the truck until now.

- Islip Terrace, NY, USA

problem #13

Nov 162013

Silverado 1500 Hybrid 8-cyl

  • 27,860 miles
Driving on I10 heading to houston, the entire truck completely shut down, and then turned back on, this again happened 02/2014....the whole truck shut down, thank god the wheels did not lock up or we would have been killed both times. It is at the dealers...freedom Chevy san antonio tx....something is bad on the truck...like playing with a light switch...the dash, every instrument shut off both times, now I am worried that it will happen again, and I can not afford another truck. I thought that the 1st time was just a fluke, but when it did it again, I know now something is not right and is very dangerous for me and my little girl...please reply if a human really reads this.

- San Antonio, TX, USA

Read the next 12 complaints »

Not what you are looking for?