If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

Print this page

7.7

pretty bad
Typical Repair Cost:
$40.00
Average Mileage:
145,871 miles
Total Complaints:
7 complaints

Most Common Solutions:

  1. not sure (6 reports)
  2. replaced battery (1 reports)
2003 Chevrolet Suburban electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Chevrolet Suburban:

Unsubscribe any time. We don't sell/share your email.

2003 Chevrolet Suburban Owner Comments

problem #7

Jun 012013

Suburban 1500 LT 5.3L Mfi

  • Automatic transmission
  • 221,300 miles

A D V E R T I S E M E N T S

Took my suburban into dealer , they had it for a week. Cost $150.00 for nothing . they couldn't get it to do what i was talking about. On my 2 mile drive home i hit a bump and car died for a split second and reduced power warning light came up and performance is so bad i have to pull over shut car down and remove battery cable to reset system . After fiddling with positive cable for a while i was able to turn it over . This morning, July 18th, ignition clicked and reduced engine power sign came up. Had to fiddle with + battery cable again. This is getting worse. Anybody out there have any suggestions? Frustrated Fred

- , Castro Valley, CA, USA

problem #6

Jul 182013

Suburban 1500 LT 5.3L Mfi

  • Automatic transmission
  • 230,000 miles

why cant anybody figure out what replacement part is needed to fix this ongoing problem . Hit a bump and car dies than goes again . Its got to be a computer glitch . HELP!!!

- , Castro Valley, CA, USA

problem #5

Jun 302011

Suburban Z71 5.3L V8

  • Automatic transmission
  • 119,800 miles

ARRG !, this couldn’t have happened at a more inconvenient time, right in the middle of traffic. I barely was able to get it back home, called a Wrecker and had it taken to a Chevy Dealer. They said it was a Wiring Harness Short, and are replacing that Harness. I haven’t gotten it back yet, and will attempt to edit/continue this comment, to name part exactly and it’s number. And, report if this really fixed the problem.

Update from Nov 6, 2011: This is a followup of a previous complaint for "Reduced Engine Power" message. I took it to the Dealer, and paid $670.00 to have it fixed. That didn't happen, and yesterday when I cranked it up, same message on display.

Going back to Dealer today, and telling them the same thing...

"FIX THIS THING WHERE THIS DOESN'T HAPPEN AGAIN" !!!!!

- , Houston, TX, USA

problem #4

Sep 232009

Suburban LT 327 Vortec

  • Automatic transmission
  • 145,000 miles

A D V E R T I S E M E N T S

Overall the suburban is a very nice ride but the steering does get annoying and some of the lights come on when they shouldn't. There are a few bugs but if chevy could line them out I would give the suburban a 8 out of 10.

- , Coweta, OK, USA

problem #3

Aug 112007

Suburban LS 2500 6.0lV8

  • Automatic transmission
  • 70,000 miles

the engine reduced power has come on at least 7 times have replaced the throttle position sensor once the throttle body twice and the throttle actuator once and the reduced power came on again athe the code reader says the the throttle body and throttle actuator are bad again this has happened since the end of july this year

- , Linthicum, MD, USA

problem #2

Jun 152009

Suburban LS 5.3L V8

  • Automatic transmission
  • 130,000 miles

Car runs great until "REDUCED ENGINE POWER" message comes on.Code shows PCM to TAC serial data issue. Also rough road causes service brake system message and ABS and Brake light to come on.

Update from Aug 15, 2009: The ground wire on the back of the block was broken and barely making contact. I put on a new lug and presto problem solved.

- , Orange, TX, USA

problem #1

Apr 012009

Suburban 1500 V8

  • Automatic transmission
  • 105,000 miles

The truck runs great EXCEPT you never know when this problem will occur. I can be on a busy freeway and all the sudden lose power and not be able to go more than 15-20 mph. Very scary! The mechanic cannot seem to pinpoint the cause. Supposedly, he has checked all the wiring. It is very sporadic. I can go through a whole tank of gas with no problems and then there it goes....

Sometimes when I go over a RR track or bump, my ABS light and brake light comes on and my doors unlock, but I do not lose power.

- , Dallas, TX, USA

Not what you are looking for?