Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Print this page


definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
42,346 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2011 Chevrolet Suburban engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2011 Chevrolet Suburban:

Unsubscribe any time. We don't sell/share your email.

2011 Chevrolet Suburban Owner Comments

problem #6

Aug 192015


  • 36,000 miles


Excessive oil consumption which GM refuses to fix under warranty.

- Staten Island, NY, USA

problem #5

May 262015


  • 90,396 miles
Engine idling low, hesitant at low speeds. Changed gas, no change in how the truck was running. Engine light came on, took to dealership. Replaced spark plug that was misfiring due to oil contamination. Cleaned fuel injectors and throttle body, replaced valve cover to prevent this from occurring a third time (has happened twice already and in the last nine months). Total repair $1173. Not covered by warranty.

- Frankfort, IL, USA

problem #4

Aug 112014


  • 60,190 miles
Engine was idling low and hesitating at low speeds, then engine started running rally rough. Service engine light came on, changed gas in vehicle, problem continued. Engine running really rough and service stabilitrack light came on. Took truck to dealership and was told the first spark plug was fouled due to oil contamination and that engine and fuel injectors and throttle body needed cleaning. This cost $475 and was not covered by warranty.

- Frankfort, IL, USA

problem #3

Jul 012014

Suburban 4WD 8-cyl

  • 66,490 miles


While driving on the highway I was using the cruise control and the car began to increase in speed without my control. It went from 65 to 90 in a few seconds and I had to slam on the breaks to get it to stop. This has happened several times. Also we can never let the gas get lower then a quarter of a tank or the car just shuts down like its empty. Sometimes the engine will just rev up for no reason and other times it doesn't accelerate properly. You can push the gas and it feels like the speed is delayed but then will catch up.

- Normal, IL, USA

problem #2

Nov 142011


  • 1,000 miles
The accelerator hesitates when pressed. The car does not move and will then accelerate rapidly when at a stop and trying to accelerate through intersections. Dealer could not duplicate for repairs. Recurring issue. Also has a popping or clunking noise in back passenger side. Dealer has duplicated but not repaired.

- Saginaw, MN, USA

problem #1

Dec 282011

Suburban 4WD 8-cyl

  • miles
2011 Chevrolet Suburban 1500. Attorney representing consumer writes in regards to serious structural and safety issues concerning the vehicle. The consumer stated water was leaking inside the vehicle. According to the invoice, the dealer found the water leak coming from the body seam below the dash along the firewall. The passenger and driver front seats made a chattering noise. The dealer greased the tracks. The engine was not running correctly. The dealer replaced the throttle position sensor. Also, the front windshield wipers were inoperative, as well as the rear windshield wiper. The dealer found no power open circuit at the connector and allegedly repaired the wiring to the wiper harness.

- Garden City, NY, USA

Not what you are looking for?