If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

Print this page

6.3

fairly significant
Typical Repair Cost:
No data
Average Mileage:
58,460 miles
Total Complaints:
7 complaints

Most Common Solutions:

  1. not sure (6 reports)
  2. local dealership said this is a $275 sensor? (1 reports)
Get free help with your lemon!
close ad
2007 Chevrolet Tahoe electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2007 Chevrolet Tahoe:

Unsubscribe any time. We don't sell/share your email.

2007 Chevrolet Tahoe Owner Comments

problem #7

Mar 012011

Tahoe LT 5.31

  • Automatic transmission
  • 65,000 miles

A D V E R T I S E M E N T S

This light goes off at the slightest turn or a piece of gravel. The engine light isn't coming on and it isn't accompanied with any steering or transmission problems. Just a general noisy PITA that disables traction control and stabilitrak. The Chevrolet dealer said that it was a $275 sensor but when I attempted to locate and buy it else were I was told there is no "sensor" for this.

- , Ardmore, OK, USA

problem #6

Dec 142011

Tahoe

  • Automatic transmission
  • 111,000 miles

I am so disgusted with this Tahoe of mine. Since December 2011 I've been having problems with the stabilitrak being off. For the first time just on yesterday it completely shut down in traffic on me. I had to be pushed to the side of the road by some really nice people. I tried re starting but got nothing. After letting it sit for 5 minutes it started back up as if nothing was wrong. I consider this to be a danger and the Chevrolet company needs to recall these vehicles immediately before someone is seriously hurt. At my wits end and don't know what to do. Please help if anyone hears me out there.

- , Summerville, SC, USA

problem #5

Dec 152010

Tahoe LT 5.7L V8

  • Automatic transmission
  • 60,014 miles

I am experiencing problems with my 2007 Tahoe.ln mid December, the "stabilitrak off" light came on and all of the gauges went all the way to the left and the doors locked. When I parked the vehicle, it would take a while before it would restart. Took the vehicle to Ryan Chevrolet on Thursday, Dec 16, 2010 and they couldn't find the problem. They kept it all day. It happened again two days later and one of the service personnel told me that they were busy and to bring it in the next morning. Mortified, I had my husband follow me 35 miles to another store, Courtesy Chrevrolet in Ruston, La. The mechanic told my husband and me that there were several damaged wires in the wiring harness beneath the dash.

That cost me about $300 to repair those wires. Two days later, the same thing happened again!! "Stabilitrak off "light came on and all gauges shifted to the left. I had it towed back to Courtesy two days later and the same mechanic told my husband that he found two more loose wires. This is the next day and I am afraid to drive the darn thing!!!

- , Monroe, LA, USA

problem #4

Feb 222010

Tahoe LT2 5.3L

  • Automatic transmission
  • 38,000 miles

A D V E R T I S E M E N T S

the stabilitrac light came on only a week after I bought this truck used GM certified. Also every time the fuel gets to 1/8 of a tank the truck acts as if it is running out of gas! Stuttering and no power. Both problems happen in conjunction with each other. I also have a 2007 Silverado and the same thing is happening and they can't figure it out!!

- , San Diego, CA, USA

problem #3

Nov 162009

Tahoe LT2 5.3L V8

  • Automatic transmission
  • 35,503 miles

This problem just started this week, and the dealer advised that it was not a big deal or a hazard to continue to drive the vehicle. However, since the initial light starting coming on, the vehicle is now showing a check engine light. I am planning on taking the vehicle to the dealer this coming Monday, so we will have to wait and see what comes of the problem.

- , Raleigh, North Carolina, Reunion

problem #2

Mar 182009

Tahoe LTZ V8

  • Automatic transmission
  • 50,000 miles

Man I've experienced this problem more than once!! The first time it happened the "stabilitrak off" light came on, traction control off, my speedometer and gauges went haywire, the locks started tripping, and once I pulled over and cut the truck off...the truck wouldn't start. Also I couldn't get my back lift gate to open. I took it to a dealership who kept it a week and found nothing wrong with it. I got it back for the weekend and the damn thing started doing it again. I took it back again and they kept it for a few days and still no answer.

A few months later it happened again! This time my check engine light and my ABS light came on along with all the other crazy warnings (Stabilitrak off/Traction control, etc.). What the hell is wrong with my truck?!!!

I hadn't had it a year before the first situation, and I've had it maybe 18 months now and have experience it 4 times already!!!

- , Raleigh, NC, USA

problem #1

Jan 302009

Tahoe

  • Automatic transmission
  • 49,703 miles

I started to receive "Service Stabilitrak / Traction Control" indicators back in Jan of 09.

Soon after that, the engine light would come on. I took it in, the adviser said the engine light was due to the gas cap not being tightened properly. Are you kidding me? I'm a grown woman that has put enough gas in her car to last a lifetime! But whatever, it went away.

Not more than 2 days later, they were both back ok. Eventually, I started to feel this awful jerking as the gears would change.

Took the car back in (4 times) and this has still not changed. Well, I guess something did change. The "Service Stabilitrak" light is no longer on.....it now says "Stabilitrak Off" and "Traction Control Off" AND the engine light is blinking.

It's in the shop now--again. And this may just have to be the last time before I start demanding a replacement. This is getting ridiculous...

- , Austin, TX, USA

Not what you are looking for?