Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

10.0

really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
38,014 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2012 Chrysler 300 engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2012 Chrysler 300:

Unsubscribe any time. We don't sell/share your email.

2012 Chrysler 300 Owner Comments

problem #11

Apr 152016

300

  • 81,999 miles

A D V E R T I S E M E N T S

The contact owns a 2012 Chrysler 300. The contact stated that while driving at 40 mph, the A/C fluctuated. The speedometer malfunctioned with a rapid increase and decrease of the speedometer stick. Furthermore, the vehicle would not accelerate when the accelerator pedal was depressed and the vehicle stalled. The vehicle was towed to a dealer. The manufacturer was not made aware of the failed. The failure mileage was 81,999.

- Mirimar, FL, USA

problem #10

May 192016

300

  • 7,300 miles
Has started visiting a friend in the hospital comma park the car in a parking garage and engage the parking brake. The car was stationary not moving and when I return and disengage the parking brake I noticed my ABS and traction control lights are on. I have another issue which I discovered today May 19th 2016 is that when entering the vehicle and starting it everything was normal as I progressed down the road I noticed something a little off and it not wanting to accelerate the RPM seem to be a little jumpy and I check the oil pressure which was really high I turned around immediately and parked the car back at my house. The oil pressure would jump maybe 30 to 40 psi but only reaching 20 miles an hour. I am unaware of what is causing these issues and only discovered it as I was making a turn out of my driveway. I am also unsure of the date that the ABS and traction control lights came on but I can say it was before the events on May 19th 2016. My vehicle was purchased February 14th of last year.

- Magnolia, TX, USA

problem #9

Apr 222016

300

  • 65,000 miles
While on highway, my radio turned off and vehicle went into battery saving mode. As I proceeded to exit the highway, the interior and exterior lights started to flicker. I went to autozone and the car barely made it there. The car smelled like if something was burning under the hood. One of the attendants checked my battery and said the battery was drained, I had them recharge it. I had to get the car towed since the car was inoperable. I picked up the battery this morning and turned the car on, and all the electrical system started to flicker so I just turned of the car. I read in to the vehicles recalls and I noticed that recall #P6O is exactly what my car was doing last night. I called Chrysler today and they refuse to fix it due to my car not being affected by this recall but it obviously has been. Is there anything that I can do to make my car part of this recall" if so what steps can I take to make this happen" this is a safety issue that could of caused an accident and or multiple accidents since I was on the highway when this issue started, if not for my quick thinking the car could of stalled in the middle of the highway. I should also mention that while the electrical system began to fail it was extremely difficult to brake. On another note, the air bag light turns on and off all the time. I am afraid if we have an accident that the air bags won't deploy.

- Laredo, TX, USA

problem #8

Jul 152015

300

  • 56,000 miles

A D V E R T I S E M E N T S

I have experienced my electronic stability control indicator light come on and the malfunctioning indicator light both come. The vehicle loses speed and will not go in park or shut off. The fuses in the fuse box become extremely hot. Had diagnostic done and was told it was the rear speed wheel speed sensor. Part was replaced and vehicle is doing the same thing.

- Pinebluff, AR, USA

problem #7

Jun 232015

300

  • 84,500 miles
The car began to stall, losing power at around 20mph. The first indication of something being wrong was the failing of radio, A/C and dimmed lights. The car began to jerk, shake, eventually coming to a complete stop. It was preventing shifting from drive gear to park gear. After a few moments, it allowed shifting to park and turned off. Initially thought the battery failed, so replaced it. Later discovered the alternator was cooked. Then determined the issue was related to a recall on the alternator.

- Peachtree City, GA, USA

problem #6

May 152015

300

  • miles
2012 Chrysler 300. Consumer writes in regards to vehicle defective speed sensors, brakes and acceleration issues. The consumer stated the ABS light illuminated. The consumer was informed the parts would need to be ordered. The consumer stated as he approached a stop sign, he applied the brake to slow down. However, the brakes faded and the vehicle accelerated into the median. He hit the sign posted at the media. There was damage to the grill, bumper and under carriage. On May 13, 2015, the consumer took the vehicle to the dealer, where a diagnosis revealed a defective rear speed sensor. Updated 10/27/15. The consumer stated earlier in the year, the right front speed sensor was defective and replaced.

- Clermont, FL, USA

problem #5

Dec 092014

300 6-cyl

  • Automatic transmission
  • 39,000 miles

A D V E R T I S E M E N T S

The contact owns a 2012 Chrysler 300. While driving at 50 mph, the electronic throttle control warning light illuminated and the vehicle lost power. The vehicle was not diagnosed or repaired. The failure recurred on numerous occasions. The manufacturer was not notified of the failure. The failure mileage was 39,000. Updated 4/27/15 the consumer stated the etc light illuminated. Updated 04/30/15

- Joppa, MD, USA

problem #4

Oct 192014

300 6-cyl

  • 43,695 miles
I was entering the freeway and at about 45 mph the car just stalled dropping speed to about 15 mph so I released the gas pedal and started to gain speed when I was going to merge onto the first lane at about 50 mph the car stalled again stopping the traffic behind me. I almost drove off the freeway to avoid the cars behind me. Thats the scariest but like a month ago it did the same thing at a stop light it just wouldn't respond when I tried to take off so I had to turn it off and start it again.

- Pomona, CA, USA

problem #3

Nov 282013

300

  • 38,150 miles
I came to a stop at a four way intersection. I accelerated to turn at about 5mph instead of the car turning the steering locked up for about 1-2 seconds. Then drove normal until I got to my destination which was a few minutes away & turned the car off. I got off the car & went into the store. Went I finished shopping I returned to the car & tried to start it up. It would not start & steering wheel & brakes were locked. The power steering light, stability control & brake lights would blink & say service engine. About an hour into this I tried to turn the car on. It turned on but the steering wheel was barley turnable I tried to move it a few inches. For the wrecker service personal once I moved it the cars steering was back to normal & working. I plan on taking it to the Dodge dealership tomorrow morning.I just really hope this does not happen again while driving at a high speed.

- Sealy, TX, USA

problem #2

Jun 222012

300

  • 10 miles
The contact owns a 2012 Chrysler 300. While driving approximately 3 mph, the accelerator pedal was depressed and there was an eight second delayed response. The failure recurred ten times while driving at low speeds. The vehicle was taken to an authorized dealer twice and the brake pedal sensor was replaced. The dealer also inspected the brake pedal wiring in which there was no defect. The failure recurred after the repair. The manufacturer was not notified of the problem. The approximate failure mileage was 10.

- Orange, CA, USA

problem #1

Nov 122012

300

  • 2,500 miles
When switching from the accelerator pedal to the brake pedal my foot hits the plastic surface on the upper part of the foot well. This can delay the time it takes to hit the brakes. I removed the Chrysler issue floor mat to resolve the problem. This would be a safety issue with people with shoe size over 11.

- Alpharetta, GA, USA

Not what you are looking for?