8.2

pretty bad
Typical Repair Cost:
$250.00
Average Mileage:
88,844 miles
Total Complaints:
9 complaints

Most Common Solutions:

  1. not sure (6 reports)
  2. dealer replaced plugs & wires multiple times, still a problem (2 reports)
  3. replace the engine (1 reports)
2004 Chrysler PT Cruiser engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2004 Chrysler PT Cruiser:

Unsubscribe any time. We don't sell/share your email.

2004 Chrysler PT Cruiser Owner Comments

problem #9

Mar 012017

PT Cruiser

  • Automatic transmission
  • 170,000 miles

A D V E R T I S E M E N T S

Turned car on yesterday, and check engine light was on. Took it to advance auto for computer testing, was told it was spark plugs and wires, only problem is 3 months ago I changed the plugs and wires myself; need to take care to repair shop to test ignition coil. This car has been nothing but trouble.

- , Hopkins, SC, US

problem #8

Apr 152015

PT Cruiser GT 4L

  • Automatic transmission
  • 77,000 miles

I bought a car from Sovereign Automotive and Financial LLC of Hollywood, FL after seeing it on Car Gurus. I was lied to repeatedly from their ad on. This car was sold to them by other mechanic because it was facing its 4th head gasket repair or needed a new engine altogether. It had Check Engine Light on that wouldn't shut off. These creeps said it was just a sensor problem. They'd bought it knowing it was basically salvage quality. It overheated constantly until it finally conked out. Repair person said not worth repairing cuz needs whole new engine.

- , Sanford, NC, USA

problem #7

Sep 092015

PT Cruiser

  • Automatic transmission
  • 156,308 miles

check engine lite comes on runs rough and stalls

Bought a 2004 PT cruiser last year ran great for first month and then coming home from beach I made a heavy braking left turn and engine stalled . I started PT cruiser back up and check engine light , traction control light and this PT cruiser is not equipped with traction control , parking brake light and ABS and all stay on now. Half way home from beach PT starts bucking and stalls,started the engine again ran smooth and check engine light goes off,a few miles more and check engine light back on PT begins to bucking and running rough and now my speedometer is reading 20mph less than what I'am going. The next day I do the key dance and get the codes po420 , 032 and 038 I replace o2 sensors and gas cap and cleared codes a month later same problem.This has been a vicious cycle for the last 9 month , it seems to be a deep rooted problem that a lot of PT cruiser owners have but no solutions. If anyone knows what the problem is please , please help I'am at my wits end and can't afford another car.

- , Casselberry, FL, USA

problem #6

Jul 012016

PT Cruiser

  • Automatic transmission
  • 65,000 miles

A D V E R T I S E M E N T S

My mothers car a pt cruser was cutting and the engine light was coming on Took the car to the Chrysler dealer the mechanic stated it was a ignition coil blew relay cost over 600.00. mechanic called back stated it was still running ruff so he stated it was the computer system in the car cost over 700.00 dollars more total cost 1135.25 stated car was fixed. My Mother drove the car home car stopped again in traffic . engine light came on same problem Mechanic stated it was idle air control valve was the problem cost 192.99 more total cost. 1328.24 Drove car off lot toward home car cut off engine light on again same problem. Had car towed to a Different mechanic shop found the real problem so of course I am Disputing this 1328.24 the problem was never fixed by the Chrysler dealer mechanic.

- , Acworth, GA, USA

problem #5

Dec 012015

PT Cruiser Tour Ed 4 cyl

  • Automatic transmission
  • 130,000 miles

This problem occurred last year and I replaced the camshaft sensor and problem was fixed. This year, 2015, problem came back, was told again camshaft sensor, replaced it from dealer parts. Problem went away for a week then came back. Took it to a mechanic that specializes in PT Cruisers. He checked wiring, timing belt and sensor, said it was a programming issue only dealer can fix. Took it to dealer, they kept car for two days and didn't find anything. Engine light came on a day later.

What I notice below half full, light will come on, after fill-up, a day later light will come back on.

- , Romulus, MI, USA

problem #4

Apr 012013

PT Cruiser

  • Automatic transmission
  • 68,000 miles

i DID NOT KNOW WHY THE ENGINE LIGHT CAME ON OR WHY THE CAR RUNS SO ROUGH. i TOOK IT BACK TO THE DEALER AND MODULES WERE REPLACED. THE LIGHT CONTINUES TO COME ON. I MUST PAY FOR IT NOW THAT THE WARRANTY IS OUT. YOU GET RIPPED OFF WHEN THEY DON'T TAKE CARE OF THIS PROBLEM FROM THE BEGINNING.

- , Decatur, GA, USA

problem #3

Jul 092008

PT Cruiser

  • Automatic transmission
  • 86,290 miles

A D V E R T I S E M E N T S

the engine light would come on and stay on, had it to the dealership and they replaced wires and whatever the light went out and within 3 days the light was back on again took it back and they told me that it was not hurting anything that if I could just let it stay on that it would most likely go out on its own, which it did and now it comes on and stays on for a few days and then its off and then back on again but I always check my fluids the belts to make sure everything is ok. This is a real pain when your driving and all of a sudden the light comes on you think is there a real problem now better check everything to make sure so you wheel into a garage and have it looked at. pain pain and more pain in the bum

- , Harrow, Ontario, Canada

problem #2

Jun 302007

(reported on)

PT Cruiser Limited 3.2L

  • Automatic transmission
  • 44,000 miles

car stall or runs rough when idling and running the air conditioner. any suggestions would be appreciated.

- , Moab, UT, USA

problem #1

May 162004

(reported on)

PT Cruiser

  • 3,000 miles

After owning the car for one month, the car was running real rough. The engine light came on and the car was towed to the dealership. They replaced one spark plug and one spark plug wire. The following weekend, it did the same thing. This time, the dealership changed out all of the wires and plugs (Nov 03, Dec 03). Recently (April 04), it ran real rough again and the engine light came on again. AGAIN, the wires and plugs have been replaced. Do have a lemon on my hands? To me, the car still runs rough at idle and at 45mph. The mechanic said that since the engine is small, the car idles rough. Has anyone else reported this problem?

- , Marlton, NJ, USA

Not what you are looking for?