Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
2 / 8
Injuries / Deaths:
1 / 0
Average Mileage:
75,203 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2008 Dodge Avenger electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2008 Dodge Avenger Owner Comments (Page 5 of 8)

« Read the previous 20 complaints

problem #78

Dec 172013


  • 130,000 miles


Was driving down the highway and noticed a delayed response when pushing down on the accelerator, moments later I was unable to accelerator and the car's electronic throttle control light appeared, the car was unable to go more then 15mph. Took the car to a service station where they ran a diagnostic test and no defaults were found.

- Roeland Park, KS, USA

problem #77

Nov 302013

Avenger 4-cyl

  • 132,500 miles
Vehicle started having issues starting and then it would start and run fine and then die.I was contacted and noticed that the fuel pump was not coming on and then would all the sudden come on andthen quit so I removed the rear seat and unplugged the wire harness and could see where it had been burned and looked at the top of the pump where the harness plugs in and could see and smell gas.I removed the fuel pump and you could see where one of the wire harnesses inside the fuel tank on the fuel pump had burned a hole all the way the whole process of this no fuse ever blew to shut power off and was told there is no fuse by someone at the Dodge dealer.I proceeded to look on the internet and found numerous accounts of this same issue and nobody has reported it the changed there fuel pump but that does not fix the issue. If there is no fuse to blow somebody is going to get hurt and if there is a fuse why are they not blowing.

- Webb, AL, USA

problem #76

Nov 102013


  • 89,000 miles
Was going down interstate, went through tollbooth, around 55mph the etc light came on and the gas pedal no longer accelerated the car. Vehicle speed rapidly dropped and I had to pull over to avoid an accident. Turned vehicle off, restarted it and drove another 50 feet before the same thing happened. Turned the vehicle off a second time and restarted. Haven't had the problem since yesterday. However after researching this issue, the etc unit on the 2008 Dodge Avenger is an extremely faulty unit and this happens to a lot of people. Typical repair is around $800. This needs to be a recallable item. I had my daughter in the car and we were nearly rear ended due to the speed drop on a three lane highway. I will be reporting this to Chrysler as well.

- Biddeford, ME, USA

problem #75

Aug 012011


  • 65,000 miles


Problem 1) the air bag lights would come on intermittently. Problem 2) the engine stalls intermittently, especially on rainy days. Problem 3) the front speakers sounded cracked or damaged and then over a short period of time the left speaker quit and the right speaker is majorly distorted. I might add this is not due to over cranking the stereo. This is due to cheap/inadequate quality speakers used.

- Laurel, DE, USA

problem #74

Sep 062013


  • 76,000 miles
While driving on a busy highway at 55 mph, the etc light came on in addition to several other lights and the vehicle seemed to lose all power to include turn signal and acceleration almost causing a huge accident. I pulled over to the side of the road and tried turning the vehicle off and then back on and it would not start. Thinking it was the battery I called someone to get a ride and jumper cables and left the vehicle on the side of the highway for about an hour or two. When I returned to jump the vehicle the vehicle started with only the check engine light on. I proceeded to drive the vehicle home and it accelerated fine until I hit 50+ mph and lost all power and acceleration again so I pulled onto the shoulder of the onramp. While on the shoulder of the onramp, I continued to coast to avoid getting accidentally hit due to the location. The vehicle continued to coast at about 20 mph all the way to my house which was about 7 miles away. During this time I had no acceleration or power and multiple lights were illuminated. After the vehicle sat over night in my driveway, I went out to investigate the problem and it will not start again. I called the manufacturer of the vehicle and they stated that there are no recalls pertaining to the issue that I am having nor is it covered by any warranty and they suggested them towing it to the dealership for a diagnosis which I really do not have the funds for either at this point. After reading multiple complaints about the exact vehicle type and issue, I found this site.

- Jacksonville, NC, USA

problem #73

Jul 182012


  • 70,000 miles
I went to roll my driver side window down and it fell off the track down into the door. My mechanic said the motor was broken and repaired it. A year later today my passenger side window did the exact same thing. I wondered if it could possibly be a defect in the factory motor or it is just a coincidence and if all my windows are going to do this eventually.

- Pace, FL, USA

problem #72

Jul 122013


  • 144,000 miles


I got in my car after work and noticed that my headlights automatically came on, I don't have the daytime running lights. I tried to turn them off on the control switch, nothing happened. I didn't figure out that my turn signals didn't work till I had a line of semi trucks behind me and I was needing to turn into my driveway, I live in ky so we have a lot of big trucks on the road hauling coal and gravel. I had to pass my driveway up cause I thought I was going to get hit in the rear end ( which I usually have a 5 yr old in the back seat) and had to go faster to get way ahead of the trucks so I could get pulled off the road to turn to go back home. When I get home I keep trying to get the headlight off, so I try all the controls, that's when I find out I have no wipers either. So I have no high beams with my headlights, no turn signals and no wipers, so therefore I can't drive this car to work which makes the payments on the car. Called the dealer they told me it could be of 2 things, either the controls on the steering column, which I don't see how both could go out at the same time since its 2 different controls or its either my temp which cost $600 plus labor. I don't think I'll be buying another Dodge produce, I'll stick with Chevy or GMC. They need to do a recall before they get someone seriously hurt by getting rear ended or get caught out in a rain storm!

- Shelby Gap, KY, USA

problem #71

Jul 172013


  • 126,121 miles
Upon exiting my vehicle I shut my door hitting the key lock on my key chain and realized that my door would not shut causing me to tie a rope to a piece inside the car to keep the door shut.

- Cincinnati, OH, USA

problem #70

Jul 012013


  • 72,000 miles
The contact owns a 2008 Dodge Avenger. The contact stated that while traveling 55 mph, the vehicle suddenly lost acceleration power. The vehicle was not repaired. The manufacturer was contacted about the failure and informed the contact that the vehicle was not included in NHTSA campaign number 08V152000 (electrical system). The failure mileage was 72,000.

- Louisville, KY, USA

problem #69

Jun 292013

Avenger 6-cyl

  • 121,680 miles
While driving 60 mph using cruise control, electronic throttle control indicator light blinks and engine loses power. However, difficulty in breaking and bringing to complete stop due to high RPM idle. After turning off and restarting engine, light is off and engine runs fine. Incident has occurred three times, 6/29/13, 7/2/13, 7/7/13.

- Oshkosh, WI, USA

problem #68

Jun 012011


  • 65,000 miles


Rpms dip low and the engine revs up daily. Car dies at stop lights or when making slow turns about monthly but getting more and more frequent.

- Frisco, TX, USA

problem #67

Jun 062013


  • 76,778 miles
Turn signals, dome light, windshield wipers, and running lights would not operate. Started working again the next morning. Hopefully they will not stop working during a rain storm or on a dark road. Seems this would warrant a safety recall immediately. This could be extremely dangerous!

- Anniston, AL, USA

problem #66

May 152013


  • 124,000 miles
Once electronic throttle control indicator light comes on, it is difficult to maintain consistent speed. I also have no control over my temperature gauges. Airbag light, check engine light comes on together with this as well.

- Tracy, CA, USA

problem #65

Apr 292013

Avenger 4-cyl

  • 75,000 miles
Electronic throttle control light came on and stayed flashing could not go over approx 15-25 mph. Pulled over shut car off and restarted and worked fine for the 5 min drive I had to complete after it happened. 9 hours later while driving the throttle control light came on again with loss of power intermittently then stayed off for 5 min drive I had to complete.

- Billings, MT, USA

problem #64

May 152009

Avenger 4-cyl

  • 1,000 miles
The contact owns a 2008 Dodge Avenger. The contact stated that while driving approximately 65 mph, the vehicle decelerated independently. The failure recurred constantly whenever it rained. Additionally, the front driver's side window and mirror would not operate. The manufacturer was made aware of the failure. The vehicle was not repaired. The approximate failure mileage was 1,000.

- Zanesville, OH, USA

problem #63

Apr 202013


  • 100,000 miles
While driving down the road my electronic throttle light started flashing my car would not go above 25 mph I called the dealership they stated their is nothing they can do except call me a tow truck to tow it into their dealership which is twenty miles away. They need to recall this issue.

- Portland, TX, USA

problem #62

Mar 012013

Avenger 6-cyl

  • 55,000 miles
The contact owns a 2008 Dodge Avenger. The contact stated that while driving approximately 45 mph, the malfunction error warning message illuminated on the instrument panel as the vehicle stalled. The vehicle was towed to the contacts home where it was inspected by an independent mechanic. The mechanic stated that the failure was electrical. The contact referenced NHTSA campaign number: 08V152000 (electrical system) but was advised by the manufacturer that the VIN was not included in the recall. The vehicle was not repaired. The approximate failure mileage was 55,000.

- Apple Valley, MN, USA

problem #61

Nov 152012


  • 90,000 miles
I have had multiple problems with my throttle body and losing power in my car. All my attempts to fix it have failed. Now my car will only get up to about ten mph. With the lighting bolt flashing on my dash board. I have talked to mechanics at a Dodge dealership and the say they haven't heard of this problem and that is a flat out lie. They just keep trying to fix this and that and it does not work. This part needs to be recalled before someone is killed and Dodge trying to cover up what hundreds have complained about is not fair to us as consumers spending hundreds of dollars out of pocket and there is only temporary fixes.

- Napoleon, OH, USA

problem #60

Feb 242012

Avenger 4-cyl

  • miles
Ever since I purchased my 2008 Dodge Avenger I have been burdened with a multitude of issues. My car stalled while I was sitting at a red light, no just died. Tire pressure light was always on. Vehicle launches/ jerks forward when cruising at a speed of 45 or below. (and this all happened with my first year of owning the car in 2008) in 2011 gear stick got stuck in the park position..I can go on but section is for airbags, which did not deploy during an accident I had last year, 2012. I slipped on black ice, which sent my car into a tail spin resulting me hitting...actually bouncing off of the guard rail a few times. Prior to the 2012 accident I have had instances where the airbag lights would randomly turn on, indicating a problem..then shutting off by itself. I would schedule appointments with the dealership, but by the time the appointment date arrives, the airbag light would magically disappear! I called Dodge customer service today, as the airbag indicator is back on again..I was told by the representative that there is nothing that they can do for me. She basically told me that I'm fresh out of luck, even though there is a recall, and I am experiencing the exact airbag issue as described in the recall, own the exact make, model and year vehicle. She said my VIN is not included in the recall, so there is nothing Dodge can do. I think the entire 2008 Dodge Avenger fleets are lemons and it is about time Dodge own up to their mistakes, they have no regard for their customers safety. When you are not stalling on the highways and byways, you are left stranded because you can not shift your gear out of park...oh and the airbag issue...its crucial, but unfortunalely Dodge does not think so.

- Raynham, MA, USA

problem #59

Mar 192013


  • 75,865 miles
Electronic throttle control light came on at a low speed with a total loss of power. Diagnostic code indicated loss of power to the throttle body. Could not locate the source of the problem. Since then have experienced several more times at higher speeds sometimes with a loss of power sometimes no loss of power. Throttle body cleaned, sensors replaced, still continue to have issues. Have not had any diagnostic codes come up in the recent events. Today the etc light came on at 65mph and went off, then continued to come on and off several times over 15 miles at highway speeds. Once I was able to stop tried to pull codes and there were none, the system checked out with no problems indicated. Through research I have found to be a common problem with Dodge etc even after owners have the throttle body replaced.

- Waxahachie, TX, USA

Read the next 20 complaints »

Not what you are looking for?