Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
57,837 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2010 Dodge Avenger drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2010 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2010 Dodge Avenger Owner Comments

problem #11

Nov 292015


  • miles


Vehicle is stuck in park on the gear shift used troubleshooting with the pink thing in the console to shift gears however the dashboard is reporting that the car is in neutral the car will not drive anywhere from research we have found that this is an ongoing Dodge problem not necessarily with the 2010 but with all the other Dodge. Stuck on the side of the road not able to go anywhere as car is stuck in park and showing neutral we were able to shift the car from park to other gears still reported in neutral

- Debary, FL, USA

problem #10

Jul 012015


  • 92,000 miles
While driving at about 35 miles per hour, I lost speed down to about 15 miles per hour. I had to stop, turn off the engine and restart. The issue did not reoccur, but there have been a few more times when the acceleration has decreased and then just started again and I took off faster than I wanted to go.

- Fuquay Varina, NC, USA

problem #9

May 072015


  • 94,000 miles
The contact owns a 2010 Dodge Avenger. The contact stated that while driving at approximately 40 mph, the etc warning light illuminated and the accelerator pedal was depressed but the vehicle did not accelerate over 15 mph. The vehicle was taken to a dealer where it was not diagnosed or repaired. The manufacturer was made aware of the failure. The approximate failure mileage was 94,000.

- Dolgeville, NY, USA

problem #8

Apr 102014

Avenger 4-cyl

  • 60,000 miles


Car would start and run for a bout 3sec the etc light and check engine light would come on. Sometimes it would start right back up other times it took multiple starts to stay running...sometimes it didn't do it at all and would run and start fine for weeks. Took the car to an independent shop. They couldn't get any codes off the car and couldn't duplicate the problem. Car was repaired with new spark plugs, new air filter, and a throttle body cleaning. Problem persisted the same day it was "fixed". drove the car for a about 2-3weeks with the same problem intermittently then while driving about 40mph the car lost rpms although the peddle was being pressed and car eventually stalled and shut off leaving the ABS and power steering inop so the car was difficult to turn and stop and almost resulted in an accident. The car was moved to a parking lot and left off for about 10mins. Tried starting it but it would start and stall and idle rough before it stalled out the check engine light with the etc light came were on. Took about 10mins and about 7 tries to get the car running and the car was dropped off at a repair shop. Looks like a common problem within the throttle body with the throttle positions sensor with 2008-2010 model. This needs to be recalled!!!

- Annapolis, MD, USA

problem #7

Mar 032014

Avenger 6-cyl

  • 39,150 miles
Car was having trouble starting but would always go, then one day needed to have it jumped since battery died. Assumed it needed a new battery. Next day driving on the highway when car started accelerating sluggishly was struggling to reach 60mph and rpms were about 7-800 higher than when normally at that speed. Called local Dodge dealership to schedule repair and the service tech stated that they had numerous problems with throttle body. After checking this websites complaints and recalls section I see dozens of similar complaints where the throttle body was the core issue. There should be a recall since failures are nearly identical with this model.

- Chilliwack, WA, USA

problem #6

Mar 042014


  • 95,760 miles
The electronic throttle light came on and the car would not go over 15 miles per hour. I pulled over, turned the car off and it restarted. The light eventually went off and kept coming back on with the car not being able to accelerate over 15 mph. I took it to the Dodge dealership today and they stated that the throttle body needs to be replaced. The cost of the part alone is $257 which is on back order. There are over 1200 on back order at this time. They also checked to see if this part would be included in the 100,000 mile powertrain warranty which it is not. This is part of the powertrain and should be included in the warranty through Dodge. There should also be a recall on this part. Evidently there are more people with the same problem since there are 1200 on back order.

- Rockholds, KY, USA

problem #5

Aug 262013

Avenger 4-cyl

  • 46,221 miles


I just began having this problem and I am very concerned. There is not a recall yet, however I am hoping with taking the time to report my concerns and problems there will soon be a recall. After about 45 minutes to an hr of driving my vehicle there becomes a clunking noise on the left front end of my car. You can feel the noise/malfunction in the left lower part of the steering wheel while driving. Steering feels shaky and unstable. My vehicle is maintained monthly at the same place each month. The longer you drive the louder the clunking sound. After, realizing this problem was not going away and could become very serious I took it to my local Dodge dealership and was told that there is not a recall issued for this problem and it would cost me about $600 D/T also telling me warranty would not cover it. After, extensive research I have learned that Chrysler themselves have placed a concern in regards to this problem, however are not issuing a recall for this problem and that this is only a problem with vehicles manufactured before 7/2010 which mine was manufactured 8/2010 and I am having this current problem. I am very scared that if this does not get recalled and fixed there are going to be bigger problems than just complaints. I have read several incident reports placed with NHTSA with the same exact problems. With that said why is there nothing being done about this and why should I pay $600+ to get this fixed when this is clearly a Chrysler/Dodge issue and conveniently warranty will not cover this particular malfunction. I have 2 young children and if something happens to us while driving my car after numerous reports have been placed there will be problems bigger than a recall. I am very disappointed in Chrysler/Dodge and not sure that I would buy another Dodge vehicle after this.

- 308 Denton Court, TX, USA

problem #4

Jul 152013

Avenger 6-cyl

  • 68,000 miles
After driving the vehicle for 30-45 a clunking noise begins in the left front, which gets louder the longer the vehicle is driven during one driving period. After parking the vehicle long enough for it to cool down, the problems starts again. Took vehicle to mechanic who said was common problem but need to take to dealer for correct diagnosis - after 3 days the dealer determine rack & pinion needed replaced. I bought this car new & drive 90-95% of the time on the highway. Also, when braking the car shimmies and shifts. They state this is not included in the power train warranty. My previous vehicle was a 2008 Dodge with 110,000 miles on it at trade-in, I drove more in-town driving with it & it never needed any kind of repair.

- Barnsdall, OK, USA

problem #3

Jun 182013


  • 35,000 miles
When raining, the vehicle tends to want to "slip out" of gear. It could be at a stoplight or even while I am driving; it feels like when driving a manual car and you're about to stall it, that is how the transmission/gears feel. I have been driving down the road going approx. 30 mph, it was raining; the RPM's will stay where they are at, but the mph will fluctuate almost as if it is about to stall. However, I have an automatic car. I have been told by several people to take the car in, and have called cutter Dodge (pearl city, hi) about my warranty, but they don't seem to care too much about my car. Not sure if others are having this issue, but my car is still a "puppy", only has 35,000!! this incident has happened any time it rains, not just on the date given.

- Ewa Beach, HI, USA

problem #2

Sep 102012


  • 61,080 miles
Driving approximately 30 mph the vehicle stalled briefly and when the gas pedal was pushed did not accelerate. Immediately following the lack of acceleration the electrical indicator light appeared. The car was driven approximately one (1) mile and parked at no time did the vehicle accelerate to a speed higher than 15 mph and the indicator light continued to be present. Once the car was parked a call was made to a local Dodge dealership and an appointment made to immediately take the vehicle in for a diagnosis. The vehicle was driven approximately 10 miles to the dealership at no time did the electrical indicator light appear and the vehicle accelerated without incident. Upon examination of the vehicle it was determined that the issue was with the throttle body which was repaired. This was the second incident in which the throttle body was replaced approximately six (6) months earlier the vehicle experienced the same issue... while driving 35 mph the vehicle lost power and refused to accelerate the vehicle was towed into the dealership and upon examination it was determined that the throttle body needed to be replaced. Please note that both times the vehicle was taken to the same dealership for repair.

- Englewood , CO, USA

problem #1

Aug 242011

Avenger 4-cyl

  • 45,000 miles
Vehicle fails to react when gas pedal pressed from a stop or just after vehicle is started, occurs at random and intermittently, dealership recommended switching out throttle body/throttle position sensor.

- Holly Ridge , NC, USA

Not what you are looking for?