Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
43,289 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2011 Dodge Avenger electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2011 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2011 Dodge Avenger Owner Comments

problem #12

Apr 102016


  • 100,000 miles


The contact owns a 2011 Dodge Avenger. While driving approximately 20 mph, the vehicle decelerated without warning. The contact pulled to the side of the road, turned off, and restarted the vehicle. The contact stated that the failure recurred while in traffic. The vehicle was taken to an independent mechanic who diagnosed that the electronic throttle assembly needed to be replaced. The vehicle was taken to another independent mechanic for an estimate. The manufacturer was not made aware of the failure. The failure mileage was 100,000.

- Dover, DE, USA

problem #11

Mar 052015


  • 79,000 miles
The contact owns a 2011 Dodge Avenger. The contact stated that the service engine warning light illuminated and the vehicle stalled. The failure occurred on several occasions. The vehicle was taken to a dealer, who diagnosed that the battery and the alternator assembly needed to be replaced. The vehicle was not repaired. The manufacturer was notified of the failure. The approximate failure mileage was 79,000.

- Clarkston, GA, USA

problem #10

Dec 242014


  • 25,600 miles
I bought a 2011 Dodge Avenger mainstreet three years ago. At 13K miles my car started giving me problems with the electronic throttle control. The car basically loses power with no warning. I have taken the car to my local Dodge dealer 5 times since February 2013 due to this problem and on two occasions they said they replaced the etc. Recently the car was giving me problems again with the etc where the car would lose power with no warning. I took it to an independent dealer less than two weeks ago and got the etc replaced and installed. Yesterday my car gave the same problems where the car would lose power. I know there is an investigation into the tipm of Chrysler vehicles and I have no doubt that the problems with my car are related to the tipm. If it was just the etc my car would be good but keep in mind the part was replaced three times and the car gives me the same issues. I need advocacy for this issue. I fear my car may be a lemon.

- Bronx, NY, USA

problem #9

Sep 152014


  • 35,000 miles


During 2013 my car would give me problems starting in cold weather. To remedy this I would turn on the lights before turning on the vehicle. It worked. I brought it to the dealership while I had warranty for a check up and they told they spotted no problem codes and the car was fine. September 15 2014 it began to get chilly again. As I was driving, going uphill, the lightning bolt came back on and my car dropped to 20 mph immediately. I referred to the car manual and found this is called a etc issue, electronic throttle control. I've brought this attention to dealership while my warranty was still on the car, and even tho I stated the issue was there, it wasn't attended to because no problem codes came up. My local mechanic ran a diagnostic test and still no codes come up. Aside from this, there is a heavy knocking noise when my air conditioner is turned on for some time. Idk what this issue is but again I had brought it up while I was under warranty and nothing was done.

- Union City, NJ, USA

problem #8

Aug 232014

Avenger 4-cyl

  • 48,000 miles
I was driving Aug 23 along in a street when the car just stalled, I immediately put the gear in park then start the engine again it worked.. then Aug 25 I was backing up from my work drive wayin the morning when it dies again.. there were no engine light or battery light in the dashboard then it wont start... I waited like 5mins to start it again then it worked again...then it happened again the car stalled again while im driving home same day... then Aug 28 past 415pm when I was about to leave to do some errands the car was parked on the street it didn't start I called triple a thinking it needs a jump start... after 15 mins the car starts again... then Aug 29 the car stalled again along the street sunset and wilton it just dies again I re start it so afraid for my safety and the safety of others on what this car defects are.. I decided to went to midas same day Aug 29 and have my car diagnosed... the mgr told me battery results are ok.. the starter test is normal...the charging system test is normal advised me to take it to the dealer... I took it to the downtown la dealer they don't accept walk ins the service writer told me they need to have the car in the service shop for 3 days to run a test it will cost me $100 something... I cant afford it... im a low income employee.. I cant afford to have my car in the shop for 3 days...he told me the cost might run from $200 to $1,000 depends on the in a difficult situation right now...we had this car since May 2013 at 37,000 miles from a rent enterprise dealership im not negligent or abuse this car in any way I always have it oil has 48,000 plus miles now... when I look up in the internet I read some related complaints about Dodge Avenger they also have the same problem the car just dies stalled....very unsafe in the streets I don't want something happened to me while im in the fwy.

- Los Angeles, CA, USA

problem #7

Feb 212014

Avenger 6-cyl

  • miles
2011 Dodge Avenger. Consumer writes in regards to vehicle stopped at red light then proceeded into intersection and vehicle shut off without warning. The dealer was unable to find a problem.

- Sarasota, FL, USA

problem #6

Feb 012014


  • 64,000 miles


The contact owns a 2011 Dodge Avenger. The contact stated that all of the power windows were malfunctioning. When he opened the windows he was unable to close them. In addition, the contact mentioned that the ABS, air bag, engine, battery warning lamps illuminated the contact stated that he was unable to shift gears. The vehicle was not taken to the dealer for diagnostic testing. The manufacturer was made aware of the failure but did not offered any assistance since the vehicle was not included in recall NHTSA campaign number: 13V282000 (air bags, electrical system ). the vehicle was not repaired. The failure mileage was 64,000 and the current mileage was 66,171.

- Summerfield, FL, USA

problem #5

Oct 252013


  • 57,656 miles
The contact owns a 2011 Dodge Avenger. The contact stated that while driving approximately 45 mph, the air bag warning indicator illuminated. The failure recurred on a separate occasion. There was recall related to the failure under NHTSA campaign id number 13V282000 (air bags, electrical system) however, the VIN was not included and the vehicle had not been repaired. The contact also mentioned that the instrument cluster lights suddenly dimmed and the interior lights and both turn signals failed to operate properly. The manufacturer was notified of the problem. The approximate failure mileage was 57,656.

- Garland, TX, USA

problem #4

Dec 292013


  • 70,000 miles
I was driving my 2011 Avenger, and whenever I would go over 2000 RPM my electronic throttle control light would come on. Then it would turn off, then it would come back on if I went over 2000 RPM, and then my throttle light would start blinking and my traction control light would come on. I couldn't go over 10 mph, unless I pulled over and turned my car off, and turned it back on. I took it the shop, and they told me I need to replace my throttle control since it's bad.

- Coon Rapids, MN, USA

problem #3

Aug 302012

Avenger 6-cyl

  • 39,800 miles
There is a sizable water leak entering the trunk lid inner panels, originating from the lack of a proper seal around the third high brake lite assembly( chmsl). The problem has been reported to Chrysler since the 2008 model year of the Avenger, stratus, sebring and PT CRUISER. They are currently using the same trunk lid and light assy, and the problems persist. Chrysler has admitted knowledge of the problem and assigned a tsb # 23-016-12 in this service bulletin it states the corrective measure for dealers is to remove 2 rubber drain plugs, and nothing else. So the water still enters between the outer and inner trunk lid assy, exits through the latch assy, and now the removed drain plugs also. Unfortunately, the simple fix Chrysler has assigned is a hazard for 2 reasons. 1/ water is in contact with power terminals on the trunk lid latch assy, 2/ water is not completely removed, and residual plus water coming out of latch assy sits and stagnates, and promotes the growth of mold spores. I have contacted Chrysler, there is an open case history, and they choose to do nothing. I informed them I would take this action.

- Tomball, TX, USA

problem #2

Feb 012012


  • 300 miles
The car has a tremendous delay when you press the gas pedal from any speed. This has almost caused me a few accidents already when crossing intersections that have no traffic signals. The vehicle finally reacts after a second or two of having pressed the gas pedal but the pedal is pressed so far by me already that it ends up accelerating incredibly abruptly that is also dangerous. Seems to be a computer issue because the horn also has the same 1-2 second delay before it finally beeps after you press the horn pad on the steering wheel. Also when you go to turn the car on it suffers from a 1-2 second delay before the starter begins to crank the engine over. Its like the computer is soooo slow to react to commands by the driver and this is dangerous when it affects the gas pedal acceleration reaction time and the horn pad reaction time. Please address this since I own this vehicle and will end up selling it if the dealer cant repair this excessive computer reaction issue. When I spoke to a dealer about this they said it was normal to have this long reaction time and it was done by Chrysler for "safety reasons" which made no sense to me that taking away driver control over acceleration is advantageous or "safe" in any way, shape or form.. it has created and put me in dangerous situations already since I don't feel I have control of the acceleration of the car since it does not accelerate immediately when you press the gas pedal. The same applies to the horn delay after you hit the horn pad on the steering wheel, what "safety reason" could that justify this car has to get these issues resolved to prevent future accidents due to these problems. Please look into these complaints.

- Huntington Station, NY, USA

problem #1

May 142011

Avenger 6-cyl

  • 115 miles
Vehicle made a mechanical clicking noise at low speed due to electric module failure.

- Vallejo, CA, USA

Not what you are looking for?