Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: Consumer Reports road tests has noted deficiencies in the 2012 Avenger with regard to engine noise, acceleration, braking, handling, transmission, fuel economy, driving position and rear visibility. But at least it has a cool marketing campaign ... right?


really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
20,818 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2012 Dodge Avenger steering problems

steering problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2012 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2012 Dodge Avenger Owner Comments

problem #10

Aug 172015


  • miles


Bought a brand new 2012 Avenger SE with a 3.6L. The car has shaken violently at speeds above 45 mph. It has been to the dealer under warranty 6 times for the issue, and no faults we're found. The car is past it's warranty, and the dealer now wants an arm and a leg to diagnose the issue. The vibration is only getting worse and worse. The front suspension has been checked numerous times, and everything seems fine, the rear struts we're just replaced, which helped the vibration under 60 mph, however it still vibrates. Car went to the dealer with 8000 miles on it due to passenger side window issues, where the dealer once again found nothing wrong. Left the dealership, and the check engine light came on for an O2 sensor. The wires had been pinched so bad, that it needed to be replaced as well. We have been through 6 sets of tires in 4 years. Car currently has 90,000 miles on it, and vibration gets worse every day.

- Fort Hood, TX, USA

problem #9

Apr 052016

Avenger 4-cyl

  • 35,000 miles
Car has only 50,000 miles and have had to replace rack and pinion seven months ago. Now the clock spring is bad in steering resulting in borrowed time for air bag. So, if we do not replace this for the cost of $500, my air bag will not deploy in the event of an accident, resulting in possible death. This issue needs to be looked at as soon as possible with Dodge Avengers (2012). There should be no reason my steering wheel should have this many issues starting at 35,000 miles and still continuing. If an air bag does not deploy upon impact and myself, or my child, or someone dies as a result of the faulty clock spring and air bags, it will not be a very good situation. This issue needs to be looked at immediately. My car is currently at the Dodge auto shop and I purchased an extended warranty from mastertech when I purchased the vehicle, but apparently, my warranty does not cover air bags. This is something I feel that needs to be covered on all warranties, people's lives are worth covering. Please look into this safety issue with my car, and others as soon as possible. Thank you.

- Killeen, TX, USA

problem #8

Nov 272015


  • 54,320 miles
While driving on the interstate doing about 65mph at 5am, I disengaged the cruise control on my vehicle, my car all the sudden turned off and lost complete power, including steering, brakes, and acceleration. The key was still in the on position. This is a major safety hazard! had I not been able to coast and engage the emergency break, I would have crashed and most likely suffered serious bodily injuries or death. This is the third time this has happened to me and I have read this has happened to others already as well. The entire electrical system failed because my engine turned off as well as the dashboard completely went dark to include headlights, turn signals, and the hazard lights. My vehicle has stopped in motion all the sudden for no apparent reason two times in one week. I made an appointment with the dealership to get the vehicle diagnosed but I am still afraid to drive to the dealership because it may happen again while driving either on the highway, interstate, or on any street. I am not 100% certain what caused the vehicle to turn off while in motion 3 times already in one week but it has created a major safety hazard for myself and other motorist on the highway/interstate. I believe it has something to do with the electrical system or engine because the lost of complete power is what occurs each time.

- Interlachen, FL, USA

problem #7

Nov 012012


  • 25,000 miles


The contact owns a 2012 Dodge Avenger. The contact stated that the vehicle would vibrate excessively when traveling over road bumps. The contact also mentioned that the under carriage was loose and partially detaching from the vehicle. The vehicle was taken to a dealer, who stated that the failure was unknown. The manufacturer was notified. The failure mileage was 25,000. The VIN was not available. The consumer stated there was a constant vibration coming from the vehicle. The dealer did not know, how to fix the problem. Updated 09/15/14

- Le Roy, IL, USA

problem #6

Jun 242013

Avenger 6-cyl

  • 13,400 miles
In late June got a flat tire. When I went to put on the spare noticed both rear tires had worn thru the steel on the inside shoulder. Took to a local dealership and they told me must be the alignment. Car was just under the 1 year anniversary date but just over the mileage for the warranty. I had to pay for an alignment and new tires. Alignment showed three of the wheels in spec and the fourth.03 degrees out of spec which the dealer said wasn't enough out to cause that bad of wear on the tires. Contacted Chrysler but no help. Went to Oregon in November and got just North of where I was going and stopped for a break and noticed both rear tires were wearing on the inside shoulders like before. Took to dealership another alignment and set of tires that I had to pay for. Alignment was out and had to have camber kits installed to get alignment fixed. Once again no help from Chrysler yet. On my way home from Oregon went thru a snow storm, not a lot of snow mostly blowing snow across road. Couldn't go over 32 mph because the rear of the car was swaying so bad. Could hardly keep car on road. Took in to local dealership and they said they need to do another alignment at my cost. Contacted Chrysler once again no help. First set of tires 13400 miles, second set 21400 miles now on third. Waiting for 12/9/13 to get car into shop.

- Sheridan, WY, USA

problem #5

May 102013

Avenger 4-cyl

  • 25,987 miles
Vehicle was purchased new on January 28,2012. The vehicles tires wore very fast and the front tires had to be replaced within 15,000 miles. On May 6,2013, both tie rods had to be replaced at 25,000 miles. The vehicle is at 30,000 miles and will have to go back to the shop due to strange noise while steering.

- Fresno, CA, USA

problem #4

Apr 232013


  • 32,000 miles


Vehicle was purchased new on January 28, 2012. The tires went completely bald by 12,000 miles. On May 28,2013 at 33,000 miles, both tie rods had to be replaced. The front brake rotors were wrapped and had to be replaced. The tires will wear very fast and poses a safety hazard.

- Fresno, CA, USA

problem #3

Jan 152013


  • 16,892 miles
Vehicle was purchased new on May 29,2012, vehicle was one of three Avengers purchased. The other two have had the same problems. On November 28, 2012 at 12,940 miles both front tires worn completely down. On January 15,2013, at 16,892 miles the entire rack and pinion had to be replaced. On January 30, 2013 at 17,365 miles, two sensors had to be replaced. On January 30, 2013 at 17,365, both front ties went bald and had to be replaced. On April 30, 2013 at 25,597 miles, both lower tie rods had to be replaced. On June 21,2013 at 29,526 miles the entire engine went out and has yet to be replaced.

- Fresno, CA, USA

problem #2

Dec 272012


  • miles
I was on my way to work and cautiously preceded around the curvy road with my steering wheel held to the right. When I ended the curve and tried to turn my steering wheel back too the right it wouldn't turn back to the left. This caused me to crash head on into a tree. The air bags were deployed.

- Charlotte, NC, USA

problem #1

Nov 272012

Avenger 6-cyl

  • 5,586 miles
The power steering fluid is leaking, the resevoir was completely empty and I had all the fluid all under the my car and the steering wheel is almost impossible to turn.. I live five to 10 miles from the dealership, so I went to gene's Dodge of fairbanks on 11/27/2012 at 5:30 pm Alaska time. One of the mechanic came to look at my car and when I started to he knew just by the sound it was to power steering resevoir was completely empty and noticed that there was also a leak. I made an appointment for 12/06/2012 and was top off with atf+4. the next day I went to work no issues, it wasn't 3pm on 11/28/2012, my car was making the same noise and when I checked and saw that my power steering was out of fluid again so when I refilled it it took a whole quart. I called the dealership right away and took the car to them and got a rental covered under my warranty. The next day on 11/29/2012 I pick up my car and was told that the power steering hight pressure hose cracked and was replaced and that this is a common problem and that is why they keep the part in stock also that they will see me before winter is over. On 11/30/2012 from 9am I am to work a 24hr shift and so I drove to work no issues, however, between 9am on 6pm all my fulid from my power steering tank was gone and so I put some more fliud in because the steering wheel locked up and would not turn. As I went to turn the wheel to get the fluid flowing I retuned to hood to close it and as I was putting the cap back on the tank I heard the noise again as if the tank was enpty and as I look the poweering tank was empty and all the fluid was on the ground, any reasons why this may have happened other then it was -30 to -35 degrees over the night?

- Fort Wainwright, AK, USA

Not what you are looking for?