Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

6.6

fairly significant
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
10,275 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2013 Dodge Avenger accessories - exterior problems

accessories - exterior problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2013 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2013 Dodge Avenger Owner Comments

problem #4

Aug 082015

Avenger

  • 18,000 miles

A D V E R T I S E M E N T S

Wipers come on with left or right turn

- Shelton, WA, USA

problem #3

Jan 212015

Avenger

  • 8,600 miles
The contact owns a 2013 Dodge Avenger. The contact stated that while driving at approximately 45 mph, the windshield wipers seized independently. The failure recurred twice. The vehicle was not diagnosed or repaired. The manufacturer was not made aware of the failure. The failure mileage was 8,600.

- Eastbernabst, KY, USA

problem #2

Jul 012013

Avenger 6-cyl

  • 7,500 miles
I bought the 2013 Dodge Avenger in Jan. 2013. March 2013 came and my windshield wipers would start wiping do to the over cast and shadows. When I took it to Dodge they told me there was nothing they can do because it wasn't happening then in front of them. Then at 7500 miles in July 2013 my brakes started making loud noises. At first it was only when I backed up then come August it was all the time. After 5 visits of scuffing the roaders up they said if it happened again they said they would replace everything in the brake system cause there was a large amount of complaints in the 300 models, darts, and Avengers. First trip to the service department they said they replaced the whole brake system... brakes, roaders, and pads...(they stated their was scares in the roaders and it shouldn't of been that way with only 7500 miles) to the front and rear. They also stated they left my account open incase that didn't work. However that was a lie they only did the rear and that same day the front was so bad I couldn't drive it. 3 days later they got it back in to the service department and did the whole front system of the brakes. That worked for 1 week and I'm really mad. I have called 17 times left voicemails for the dealer ship manager and service department. My brakes now are sticking and still loud as ever. They still have not returned my call. I only have 18000. Miles on this car. I would like to have it fixed. This is not only me having this issue. Help us be safe recall for fix the problem please.

- Cadlwell, ID, USA

problem #1

Nov 212013

Avenger 6-cyl

  • 7,000 miles
Purchased car 7/11/2013: (the 7,000 miles is a guesstimate) 11/21/2013 while in wv for my mothers funeral, parked in gas station, car running, in park, L/R turn signals started flashing independently then the flashers started going off, stopped by themselves. This has continued, took to dealership, they couldn't find any codes, all connections looked ok. Started keeping a log of milage when this happens, starting on 1/4/2014 mileage 10,254 and has continued to current date 4/30/2014. This may happen only once but then again it may happen several times within the same milage. Can not count the times it happens while car is parked in the driveway with keys in the house and no one touching them. I believe it's the cluster in the steering column. Also, I could not get my wipers to spray/wipe until I turned the turn signals on. Has anyone else had this happen?

- Aurora, IL, USA

Not what you are looking for?