Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
1 / 0
Average Mileage:
40,030 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2013 Dodge Avenger engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2013 Dodge Avenger:

Unsubscribe any time. We don't sell/share your email.

2013 Dodge Avenger Owner Comments

problem #10

Sep 122016


  • 80,512 miles


The contact owns a 2013 Dodge Avenger. While the vehicle was stationary, the driver side air bag indicator remained illuminated. In addition, the vehicle accelerated on its own and stalled without warning on numerous occasions. The battery indicator illuminated without warning and the vehicle stalled on another occasion. The vehicle was not repaired. The manufacturer was made aware of the failures. The failure mileage was 80,512.

- Shreveport, LA, USA

problem #9

Sep 092016


  • 49,000 miles
About 3 weeks ago, I was driving down the highway and the etc light came on for a split second, the car wouldn't accelerate, than the light shut off and drove fine. For the next few day's it did it once or twice on the highway when I would go up hills. The last day I drove it before taking it to a mechanic it did it again, only this time the light didn't shut off and I had to pull over on the highway. I shut the car off and it started, there was no light on so I began to drive. About 10 miles down the highway, the light turned on again and the car wouldn't go over 60mph. I got it to a mechanic shop. They did a diagnostic test and couldn't tell me what exactly was wrong with it. They said they cleaned the throttle body but it didn't help and suggested that I take it to the dealer ship. I called the manufacturer to see if there was a recall and to see about a warranty. They said that I still had power train warranty and should take it to the dealer so they could do adiagnostic test. After telling them what the other machines did they said it probably was the throttle body but it's not under power train warranty. They manufacturer said they would get back to me about who's going to cover the cost.

- Casper, WY, USA

problem #8

Apr 212016


  • 72,300 miles
The contact owns a 2013 Dodge Avenger. While diving 25 mph, the electronic throttle control warning light illuminated and the vehicle sputtered and lost power. The vehicle was pulled over to the side of the road and shut off. The vehicle was restarted; however, the failure recurred. The vehicle was not taken to a dealer. The manufacturer was not notified of the failure. The failure mileage was 72,300.

- Albion, IN, USA

problem #7

Mar 292016


  • 68,891 miles


The contact owns a 2013 Dodge Avenger. The contact stated that while driving at approximately 45 mph, the vehicle hesitated when the accelerator pedal was depressed. The vehicle was taken to an independent mechanic and the diagnosis was that the emissions control preventive system failed and needed replacement. The vehicle was not repaired. The contact also stated that the vehicle was taken a week earlier to an Chrysler dealer for the same failure. The manufacturer was not notified of the failure. The approximate failure mileage was 68,891.

- Lakeland, FL, USA

problem #6

May 252015


  • 39,000 miles
My vehicles stalls while driving on the highway and its an automatic. I keep my regular maintenance on it. This has almost caused 3 different accidents on multiple occasions. When I stop my car almost acts as though it wants to shut off. In order to pick speed back up I midst floor it to even get moving anywhere. This is very unsafe seeing as though I have a 2 yr old. Something must be done. I'm insuring a car that has had recalls for this very same issues and now Dodge tells me they'd have to charge me $115 for a diagnostics test.

- Jacksonville, FL, USA

problem #5

Aug 232014

Avenger 4-cyl

  • 20,350 miles
While in park the vehicle was started and the engine/transmission (?) kicked back. When the vehicle was put in drive it would only go about 10 mph but the RPM's were at 4000. It has done this about 6 times since I purchased it 11/2013.

- Round Rock, TX, USA

problem #4

Jul 142014


  • 23,000 miles


I recently reported my vehicle accelerating on its own up to the speed of 82 mph also thinking that this was a weird occurrence that would not happen again. I was wrong. While driving 40 mpg getting ready to enter a turn my car again started accelerating on its own, foot off the gas was not going down hill or any other reason to pick up speed. Also on this same day I started my car and my headlights came on as they should, I noticed my high beams on thinking they were left on from the last time I drove my car I turned them off. Driving down the road the high beams all of a sudden came in. I turned them off thinking it was strange. Again 2 more times on my way home the high beams automatically came on by themselves. I believe there are some major computer issues with this vehicle but again I am sure of Chrysler response ahead of time. Called Chrysler they just say well if you take it to a dealer maybe they can see if there are any codes. Prior to this my sensor had gone bad, lights not working all kinds of things and the dealer was not able to find out what was wrong because there were no codes. Took to new dealer they used common sense and not waited for only codes to come up and found the sensor was dead. This vehicle is an accident waiting to happen!

- Alexander, ME, USA

problem #3

Jul 072014


  • 23,052 miles
Previously had issue with transmission, valve body replaced and now having same issues as before it was repaired approx. 15,000 miles ago. On July 7th I was passing a vehicle in a passing lane, once I got passed the vehicle and on top of a hill I released my foot from the accelerator only to have my car continue to accelerate to the speed of 82 mph. On its own. My cruise was not on so this could not be the problem. I have never used the cruise and would never have it set over 82 mph even if that could be an issue as I have been asked. Extremely scary situation but the brakes did engage when applied and I was able to slow to a safer speed (with my knees knocking in fear!) I have not had this checked yet knowing that the answer from Chrysler and the dealer will be "we are unable to duplicate" or "your car is just learning how you drive" (granted I have been driving it since it was brand new). I am extremely nervous to drive this vehicle or have my children or anyone in this vehicle with me.

- Alexander, ME, USA

problem #2

Apr 092014

Avenger 6-cyl

  • 11,000 miles
I was driving down a back road coming up to a severe curve the car started accelerating on its own. The gas pedal was not pushed al the way down but the engine continued to speed up. As I came up to the curve I could not maintain the car on the road and it flipped four times and landed in a swamp area in about 2 feet or three feet of water.

- Oshkosh, WI, USA

problem #1

Feb 042014

Avenger 6-cyl

  • 13,200 miles
I was accelerating to 30 mph with traction system on than my car started to slow down had high RPM but speed was decreasing almost had a guy rear end me bc of the speed accelerated fine than just dropped this is the 2nd time this happened to me within a week.

- Waterford, MI, USA

Not what you are looking for?