If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

6.1

fairly significant
Typical Repair Cost:
$214.00
Average Mileage:
100,585 miles
Total Complaints:
16 complaints

Most Common Solutions:

  1. not sure (13 reports)
  2. have the rear speed sensor replaced (1 reports)
  3. replace rear vehicle speed sensor on differential (1 reports)
  4. speedometer reads no bus comm (1 reports)
1999 Dodge Durango electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 1999 Dodge Durango:

Unsubscribe any time. We don't sell/share your email.

1999 Dodge Durango Owner Comments

problem #16

Sep 202013

Durango SE 5.2L

  • Automatic transmission
  • 123,860 miles

A D V E R T I S E M E N T S

Fixed Problem!! I am a 5 X Master ASE Tech And Own a Dyno Shop where we work on a lot of customer vehicles that other shops have failed to repair. This Is a vehicle that was brought into me for diagnosis and repair, complaint was, Chk Eng Light On, ABS light on, speedometer erratic at times, and occasionally, stalling. Our Diagnosis found ECM to be defective, it was replaced and corrected the problem.

Part was purchased as a re-manufactured unit, it had obvious signs of the repair as it looked like the rebuilder had cut the side of the ECM open, then replaced a defective capacitor I assume, then the cut out part was epoxied back on. Then it was flashed to the most current update. I Might also note that we also see a lot of these vehicles coming in for ERRATIC OR NO SPEEDOMETER and we replace the Speed sensor located on top of the rear axle. If the sensor appears like it has been rubbed against or is cracked IT IS HIGHLY ADVISED TO..Have the rear axle cover removed and inspected for excessive metal on metal on the magnet inside, and check the pinion /rig gear for backlash. What we have been finding is that the spider gears have worn out causing the metal in the fluid to ruin the bearings causing the ring to strike the speed sensor. The correct repair is Replace ALL bearings /seals and spider gears, worst case the ring and pinion will need replacement.

In my shop we take extra time to steam clean the housing when apart to remove all metal in the housing and we epoxy another magnet in the housing for extra protection, and we only use Timken Bearings, NO CHINESE!! They are junk!! This repair is not cheap but is the only way to repair for multiple speedometer sensor failures. I suggest this work should be done at a shop that specializes in setting up rear axles/ gears.

Hope this sheds some light on these subjects for Durango owners. Good Luck! Royal T

- , White City, OR, USA

problem #15

Mar 142012

Durango LX 5.4L

  • Automatic transmission
  • 200,000 miles

I hate that all the mechanics around where I live can not figure out what is a matter with this darn vehicle. I have taken it 3 different places, and nothing.

- , Boswell, PA, USA

problem #14

Aug 152009

Durango LT 5.2L V8

  • Automatic transmission
  • 110,495 miles

The family was heading to Minnesotta to see an uncle, Almost to Chicago and the lights left on bell ding about three times .....the ABS, seat belt, air bag, check engine, door ajar ....ALL the dashlights came on then the gauges stop working along with the speedometer quit and I notices the odometer read "no bus", I had no idead what that meant. The truck was running ok but I kept wondering if we were going to make it or not. Then all of a sudden the dinging happened again and everything started working again....

We took it to a Dodge dealer in Ely, Minn. and he told us he would have to take the das out and send it back to the factory to have fixed.....That is why it still does it today....The truck runs fine but you have to put up with the light show and no speedometer just about everytime you drive it and I drive it everyday now with 118,000 miles........

- , Parma, OH, USA

problem #13

Jan 012007

Durango

  • Automatic transmission
  • 71,000 miles

A D V E R T I S E M E N T S

The lights have been on forever. We have taken it in several times to see what's going on and none of the mechanics that we have gone to have been able to turn them off. ANNOYING~

- , Salt Lake City, UT, USA

problem #12

May 212007

(reported on)

Durango 5.2

  • Automatic transmission
  • 85,000 miles

Aug. 2005 ABS and brake light came on . did not know how to fix the problem. A few months later the speedometer would not register below 20mph. Then the check engine light came on. a diagnostic test revealed that it was the speed sensor. So we replaced the sensor in the trani ( did not know about the other one). The problem was not fixed. Nov.2006 I found this website and the info about the speed sensor on the rear differential. bought the sensor for about $50. Everything was fixed. Lights all off, speedometer working, it was great. Now 6 months later ABS and brake light just came on..... WTF!!!!

- , LAS VEGAS, NV, USA

problem #11

Oct 092006

(reported on)

Durango SLE

  • 120,000 miles

My local mechanic replaced the rear speed sensor, at least that problem is fixed

- , Penrose, CO, USA

problem #10

Oct 162006

(reported on)

Durango SLT

  • 112,000 miles

A D V E R T I S E M E N T S

no fix in sight, two dealers can't figure it out, so I E-mailed dodge directly and mentioned the problem along with the number of people complaining about it on this site, they responded with "we don't know what it could be, try and find a dealer who can fix it"Lots of help that is!!!

- , Rocky Point, NY, USA

problem #9

Apr 212006

(reported on)

Durango 4x4

  • 81,000 miles

ABS Light and Brake light came on, no check engine light on, which could help :(. Oil Pressure gauge drops to 0 when I stop and then bounces back up to normal. Speedometer also doesn't kick in until 15 MPH. I am going to probably change the speed sensor on the rear differential. I already had to change the one on the transmission so I know what problems that one causes. This really isn't causing any problems other than lights on. Vehicle is running good but this goofy electrical just had me change my alternator on suspicion and found belt was bad so changed it. When restringing the belt I noticed my tensioner spring was shot so I had to put a new one of them on and now something is really squeaking in there and I think it's the idler pulley. I am praying it's the idler pulley otherwise it's the damn water pump. I hate Dodge. They suck and they suck to work on too. I don't like my ford either. They all suck but at least Chevy makes their vehicles mechanic friendly.

- , Crest Hill, IL, USA

problem #8

Nov 142006

(reported on)

Durango 5.2L V8

  • Automatic transmission
  • 125,000 miles

I had the same problem. My ABS and brake lights were on and the speedometer did not register lower than 20mph. After scanning I noticed the rear differential speed sensor wasn't registering. I pinpoint tested it and sure enough it was dead. It is a sensor bolted to the top of the rear differential. Replacement is quick, easy, and costs about $24.00 for a new sensor. After that was replaced everything went back to normal.

- , Oxford, MI, USA

problem #7

Aug 202006

(reported on)

Durango SLT Plus

  • 25,000 miles

I'm having the same problems others are mentioning here. First abs brake light wouldn't go off. Mechanic swapped out the abs module and that wasn't the problem. Then speedometer & odometer just stopped working, now last night check engine is constantly on.. this has all happened this week. Has anybody resolved there issues with the same troubles and what was it... Thanks.

- , Brooklyn, NY, USA

problem #6

Aug 152006

(reported on)

Durango SLT

  • 189,000 miles

A D V E R T I S E M E N T S

First the ABS light and Brake light stayed on and the speedometer doesn't kick in until about 50 K/H (about 30 miles/hour) and now while I was driving down the side of a mountain the truck just stopped working. I'm uncomfortable thinking of going to the mountains again until this gets fixed.

- , Winnipeg, Manitoba, Canada

problem #5

Sep 112005

(reported on)

Durango

  • 80,000 miles

Im really just wondering what I might have to do to get this fixed. And what causes the damn lights to come on anyway Thanks.

- , Leland, NC, USA

problem #4

Jun 142005

(reported on)

Durango

  • 97,000 miles

Car has had a few minor problems, but now this. If anybody has any ideas on how to fix this let me know.

- , Pope AFB, NC, USA

problem #3

Jan 172005

(reported on)

Durango

  • 90,000 miles

There is no end to the problems with this vehicle!!!

- , Savage, MN, USA

problem #2

Oct 112004

(reported on)

Durango

  • 55,000 miles

My ABS Light and Brake light simultaneously came on and will not go off. With 10-15 miles, speedometer doesn't work....

- , Westminster, CA, USA

problem #1

Sep 262003

(reported on)

Durango

  • 45,000 miles

Abs lights, brake lights and check engine light come on. Also the speedometer does not work. Dealership has had it off and on for several months and can't figure it out. Have to return the car to me with out being able to fix it and have no suggestions!

- , Morgan Hill, CA, USA

Not what you are looking for?