Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

7.1

pretty bad
Typical Repair Cost:
$600.00
Average Mileage:
109,820 miles
Total Complaints:
11 complaints

Most Common Solutions:

  1. not sure (10 reports)
  2. replace the computer (1 reports)
2000 Dodge Ram 1500 electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2000 Dodge Ram 1500:

Unsubscribe any time. We don't sell/share your email.

2000 Dodge Ram 1500 Owner Comments

problem #11

Jun 012014

Ram 1500

  • Automatic transmission
  • 96,000 miles

A D V E R T I S E M E N T S

Ongoing electrical issues. It seems to be on some sort of miscellaneous rotate system. First the dashboard lights go out. Which is fine if you never drive after dark. Then the headlights go out. Again, fine if you never drive after dark AND you never get caught accidentally after dusk or never have to drive on a road where they require headlight use. These two issues alone caused me to stay housebound for months, limited to only driving when I knew I could leave and get back before dark. Then the ac went. Then the blower completely stopped working. I feel like I am driving a time bomb now.

- , Darlington, MD, USA

problem #10

Jun 042013

Ram 1500 Conversion 5.9L

  • Automatic transmission
  • 97,354 miles

This will be the FORTH computer this Dodge Conversion Van has gone thru and last as me as the owner !!!!

- , Phoenix, AZ, USA

problem #9

Nov 022010

Ram 1500 V8

  • Automatic transmission
  • 165,000 miles

if your instrument panel dies on your dodge ram, check your fuses (under the hood) I found a loose 10 amp fuse, re setted it and all instruments came back on line.

- , Prattsburgh, NY, USA

problem #8

Oct 032009

Ram 1500 1500 4x4 5.9L

  • Automatic transmission
  • 160,000 miles

A D V E R T I S E M E N T S

My truck dies while going down the road. It says "no bus". It used to start right back up or within a few minutes, now it takes 30 or 40 min before it will start. Someone told me it might be the ignition starter switch, replaced it...didn't fix it. Someone else told me to replace the gauge cluster & I also heard to maybe put some electrical grease on the connectors on the gauge cluster before I replaced it. Gonna go w/the electrical grease first and if that don't work going to replace the gauge cluster...If ya hear anything else let me know...I'm open to suggestions.

- , Graham, TX, USA

problem #7

Mar 042010

Ram 1500 5.2L

  • Manual transmission
  • 189,000 miles

bought this ram two weeks ago. runs great. changed oil pump... cloged...after puting the thing back together non of the gauge cluster will work.... checked it all. put it on two different scanners.. nothing. need help to figure it out

- , Dawsonville, GA, USA

problem #6

Nov 062009

Ram 1500

  • Automatic transmission
  • 55,000 miles

My instrument panel don't work whatsoever but yet my truck runs good.I need help, does anyone know what I need to do to fix this (I already brought somewhere and they don't know what is wrong, the computer test shows no issues and yes I checked and they checked the fuses).

- , Acushnet, MA, USA

problem #5

Sep 072009

Ram 1500 5.9L

  • Automatic transmission
  • 48,000 miles

A D V E R T I S E M E N T S

no bus on odometer screen no gauges work, all warning lights on

- , Oak Harbor, OH, USA

problem #4

Nov 152008

Ram 1500 Quad Cab 5.2L V8

  • Manual transmission
  • 110,000 miles

My instrument panel lights up but nothing on it works. Speedometer, tach, gas gauge, oil pressure, nothing. All the message lights are on. In the odometer/tripmeter window in says: no bus. Truck runs just fine mechanically.

- , Albany, OR, USA

problem #3

Jun 152006

Ram 1500 SLT V8 Metric 318

  • Automatic transmission
  • 77,671 miles

it has come and gone a few times now but i clean contacts or let it dry out and it works better

- , Durham, Ontario, Canada

problem #2

Aug 142008

Ram 1500 Laredo 5.0L V8

  • Automatic transmission
  • 75,000 miles

None of the gauges work, all idiot lights are on but vehicle runs normally.

- , Rockford, IL, USA

problem #1

Jul 122008

Ram 1500 5.8L V8

  • Automatic transmission
  • 135,000 miles

my instrument panel lights up but nothing on it works. Speedometer, tach, gas gauge, oil pressure, nothing. All the message lights are on. In the odometer/tripmeter window in says: no bus. I understood this site would help me get a handle on fixing it.

- , Guymon, OK, USA

Not what you are looking for?