If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

8.0

pretty bad
Typical Repair Cost:
$0.00
Average Mileage:
101,850 miles
Total Complaints:
11 complaints

Most Common Solutions:

  1. not sure (7 reports)
  2. shut engine off after a few minutes restart (3 reports)
  3. replace frayed thottle body wires (1 reports)
2004 Dodge Ram 1500 engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2004 Dodge Ram 1500:

Unsubscribe any time. We don't sell/share your email.

2004 Dodge Ram 1500 Owner Comments

problem #11

Feb 022014

Ram 1500 5.7L

  • Automatic transmission
  • 157,000 miles

A D V E R T I S E M E N T S

Hello Dodge Owners, I have a Dodge 1500 .7 liter Hemi that idles high when starting, runs rough at low speeds. Some times stops and cuts off at red lights, cuts off on the freeway, and loses power at speeds up to 70 mph. I have to put in N to restart before I get rear ended, replaced the Throttle Body about two years ago, now i am having the same problem. Is there anyone out there that can help?

- , Katy, TX, USA

problem #10

Nov 012012

Ram 1500 SLT 5.7L

  • Automatic transmission
  • 105,000 miles

click to see larger images

runs roughly/loss of power while driving runs roughly/loss of power while driving

My 2004 Dodge Ram 1500 SLT 5.7L Hemi lost throttle and ETC light (Electronic Throttle Control Light) was flashing while I was on the highway. When I pulled over I popped the hood and the engine was barely running RPM's were really low. So I hopped in and pressed the throttle and it wouldn't go past 1800 RPM's. Scared to shut down and have it not restart, I drove it back 3 exits Approx. (5 miles) on just the rough idle. Got it in the driveway and shut down, waited, and restarted and it still ran rough and ETC light was flashing. I shut it down for 30 minutes and restarted and everything was fine. Ran good for a few days and then one morning I went to start up and guess what it's back!!!! Shut down and restart...fine again.

This seems to be a common issue. I found lots of fixes online but none matched mine. So I found most answers point to inspecting the throttle body, so I did. When i pulled the resonator box off the throttle body I noticed 2 wires frayed and broken. It seems the wires were rubbing the resonator box and got destroyed.

The wires frayed BRN/YEL and BRN/RED shown in the photos are the set of (2) of the 6 wires going to the throttle body plug and after I cleaned the throttle body which was absolutely disgusting and sticky to the touch. Now I play the waiting game!!! YAY!!!

Just a reminder, disconnect Negative for a few minutes and then reconnect and leave ignition in Accessory for at least ten seconds for the computer to learn new electronics before starting.

Update from Apr 11, 2013: It's been a few months and 1000 miles and I haven't had any problems.

- , Novato, CA, USA

problem #9

Jul 202011

Ram 1500 SLT 5.7L

  • Automatic transmission
  • 116,000 miles

I saw a post where someone also noticed the ETC warning flashing and their engine stalled while driving . All I had to do was stop and restart a couple of minutes later. It's happened twice now in the last couple of months and I was wondering if anyone had figured out what the problem was.

- , huntsville, al, Pacific Islands (US)

problem #8

Jun 112011

Ram 1500 STL Hemi

  • Automatic transmission
  • 86,000 miles

A D V E R T I S E M E N T S

Well I guess I will join you sorry SOB's. My 2004 Dodge Ram with Hemi just started the losing power while driving thing. While drive the engine will die for a few seconds. However, when at idle, the engine will stall. No error codes. I will drive it into a wall at 80 mph to see if the air bag still works when the engine fails. That way when my family sues Dodge and get the 1.5 million I'm worth to them, Dodge will maybe think about doing something about it. Hey, I could lend the truck to my mother-in-law.

- , Windsor Locks, CT, USA

problem #7

Mar 142011

Ram 1500 LS 5.7L Hemi

  • Automatic transmission
  • 130,000 miles

Well i have a 2004 Dodge Ram 1500 with a 5.7L hemi.And i have been having nothing but problems with it.But what really pisses me off is i have a lightening bolt light that keeps coming on in my truck then my check engine light will come on as well.When the light comes on i loose all power to my truck. Its actually kind of scary when your doing 70 on the freeway and you loose all power and cant accelerate or slow down.The bad thing is i have 4 kids and almost been in 2 accidents bacause of this.I took it to 2 repair shops and they cant tell me why the light comes on nor how to fix it.What i dont understand is how dodge has a lightening bolt light on there trucks but not even a dealer knows what it is or how to get the problem fixed.

I dont know if anyone else has has this problem.But what i do want to know is who is going to get this taken care of or is it going to take someone getting killed and have a lawsuit on dodge for anyone to get this sh*t figured out.But i can guarantee this i will never ever buy another dodge truck.Thank you and have a great day.

- , Livingston, TX, USA

problem #6

Feb 062011

Ram 1500 SLT 5.7L Hemi

  • Automatic transmission
  • 60,000 miles

I've got a 2004 Dodge Rumblebee 5.7L Hemi 1500 1/2 ton, had no problems until 2 weeks ago. It was below zero temp. and as I was turning left I lost complete power! Talk about scary! Luckily no one was infront or behind me, I couldn't stop or keep turning so I just let it die. Threw er' in neutral and started it right back up immediately. Went straight to the dealer and since there was no code they can do nothing. A week later, same problem...what to do? I'm not about to start guessing and just fix things with no code... we all know that gets expensive quick. Some say EGR some say cylinder issue...if anyone has specifics let me know : )

- , Wyoming, MI, USA

problem #5

Feb 032011

Ram 1500 SLT 4.7L V8

  • Automatic transmission
  • 126,345 miles

A D V E R T I S E M E N T S

Was driving last night sitting at a red light my engine just shut off I started it back up and this awfully loud knocking started with it I pulled into a parking lot and shut it off, popped the hood and cranked it back up and it sounds like a rocker broke. This isn't the 1st time i have had problems. I had to replace the connecting rods, pistons and rings, and valves about a year ago after I lost all hp going down the interstate towed it back to the house pulled it apart and a piston had cracked all the way around and the rings were the only thing keeping it from grenading my motor. I took it to dodge and they told me that my flowmser exhaust system is what caused it and that it was gonna me 5k to get it fixed, so i bought everything out of pocket for 1300 and put everything back together ran great until now.

Update from Feb 12, 2011: we its nothing in the heads, everything is good so far, i think, but a freind of mine that works at dodge says that replacing the lash adjuster and valve springs when you have a rocker arm problem will fix that problem still tearing down the motor think i might have spun a bearing

- , Camden, AR, USA

problem #4

Jul 262010

Ram 1500 1500 SLT 5.7L Hemi V8

  • Automatic transmission
  • 123,000 miles

I was just driving down the freeway when the engine lost power. It would continue to run, but I could only go about 20 mph. There was a red lightning bolt flashing on the rh bottom of the instrument panel. I pulled over, shut the engine off. I waited about 5 minutes and restarted the engine. The truck started right up with no more problems. This has happened to me twice in the last 3 years.

- , Pocahontas, AR, USA

problem #3

May 072010

Ram 1500 5.7L Hemi

  • Automatic transmission
  • 75,000 miles

Just found this site and glad!! Bought my '04' Hemi in 06 and my Dodge has died, numerous times, no warning, at stop signs, freeway traffic stand-stills, red lights... Dealer ship (like so many have mentioned) claimed they couldn't replicate the problem. Well hello!! It is random, and unless they want to give me a loaner for over a week and they drive it MORE than 1 mile and down the road, then they will never be able to replicate it! No codes show up, and have been told it is everything from the throttle body needs to be replaced to bad gas.. getting to the point where I am about to go back to Chevy and be done with Dodge forever.

- , Friendswood, TX, USA

problem #2

Mar 022010

Ram 1500 4.7L V8

  • Automatic transmission
  • 81,000 miles

Just paid this truck off last year and now it's a pile of junk! Not worth the money required to invest in another motor. I'll buy another Ford next time. I have a Ford F150 inline 300 V6 which has been a workhorse and still running with 300,000 miles. My Ford still has the original motor, water pump, rear brakes. Why can't Dodge make a good product and stand by them instead of taking your money!

- , Jacksonville, AR, USA

problem #1

Feb 252010

Ram 1500 SLT Hemi 5.7L

  • Automatic transmission
  • 61,000 miles

the truck loses complete power - hard to steer and brakes are almost impossible to engage. The truck leaves me in dangerous situations and I am afraid to drive.

- , Ft Lauderdale, FL, USA

Not what you are looking for?