Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: Say what you will about the styling of the Ford Edge, but the bottom line is owners seem to love this vehicle. That is, of course, except in the case of it's dangerous, worrisome and unexplained issues with random engine stalling.

Our data suggests an early defect trend, as owners of the 2007-2008 models have started posting their accounts of what happens when you're driving down the road and the engine just stops. Some at high speed, some at low speed but always a random shutdown of the engine, electrical and power steering.

Time will tell if this becomes a widespread issue, but there's no drying the seriousness of the problem. With that in mind, we're flagging the Edge with our "Beware of the Clunker" rating until the situation improves.


really awful
Crashes / Fires:
2 / 2
Injuries / Deaths:
0 / 0
Average Mileage:
75,867 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2008 Ford Edge drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2008 Ford Edge Owner Comments (Page 3 of 9)

« Read the previous 20 complaints

problem #135

Oct 112015


  • 85,000 miles


Vehicle unexpectedly and randomly displays odo data error on instrument panel, mileage and speedometer don't function, vehicle loses all power and does not accelerate. This resets itself after turning car off, removing key, then restarting car. When are you going to force Ford to issue a recall, when someone dies? there are hundreds if not thousands with same complaints. Here's a sample...

- Union, NJ, USA

problem #134

Mar 152015


  • 95,000 miles
Sometimes the transmission will not drive the car after a stop or if changing from drive to reverse or reverse to drive. RPM will go very high and only move the car very slowly. At other times there will be a bad shift or a strange sound. This can happen any time, when first starting out for the day, after running for a time, after a long drive or after stopping for a turn, red light, stop sign or just slowing down. The dealer says there is nothing wrong. Also noise coming from the rear while in motion. I believe the sensors are intermittent as I had a similar problem with my Dodge Caravan which went away after I replaced the sensors myself because the repair station told me there was nothing wrong after 3 attempts to have the problem rectified. You are all supposed to be professional experts so fix the problem.

- Conyers, GA, USA

problem #133

Nov 052015


  • 60,234 miles
Stopped at red light- whe I tried to accelerate the car would not move- it was terrifying!! cars had to go around- was able after at least ten attempts to get the car to move to side of road. Waited and called family member for help. Was fortunately about 5 blocks form my home. Car continued to jerk forward and had to stop seevral times. It is now in my garage and awaiting a tow truck, this has been an ongoing issue with the vehicle not specifically not going but troubles with car suring repeatedly for no reason and had to replace battery 4 times and there was nothing I did to create this loss of battery. The dealership where it was fixed previously stated that " the car appears possessed". this is somehting that has apparently been a long term known issue with this vehicle. Why has it not been fully investigated. Please do something before someone is seriously hurt or worse.

- Van Nuys, CA, USA

problem #132

Nov 012015


  • 130,000 miles


The contact owns a 2008 Ford Edge. While driving approximately 20 mph, the contact experienced difficulty shifting and the vehicle hesitated to accelerate. The failure happened without warning. The vehicle was taken to an independent mechanic where it could not be diagnosed. The vehicle was not repaired. The manufacturer was made aware of the failure. The failure mileage was 130,000. The VIN was not provided.

- Worcester, MA, USA

problem #131

Oct 012015


  • 81,000 miles
I bought this 08 Ford Edge sel AWD with 74000 miles. Ive had it less than a year and had the following problems. * stalling. * loud clunking in reverse and jumps into gear. * front driverside and passenger side window pillars are big blind spot. Very dangerous almost hit pedestrians. * vehicle rolls back on small inclines. Almost rolled into vehicle behind me. Very dangerous. * vehicle struggles in reverse up small inclines. * driverside headlight was out for a month cause car needed software update. Truck stalled again today this time I turned off and on wouldn't go in reverse instead drove forward almost hitting parked car... still have popping noise in front end clunking noise in reverse sometimes again.. im starting to get nervous cuz my daughter was in the car with me. - emailed to Ford service center rep. Oct. 1st. Ford mechanics say there is nothing wrong with vehicle yet it has stalled 4X and has problems in reverse. Car has been in the shop 6X for same issue. Im tired of bringing it back and forth.

- Bronx, NY, USA

problem #130

Oct 072015


  • 85,000 miles
I was driving out of town for a work meeting with an employee. Only going approx 45-50 mph, all the sudden the speedometer drops to 0 along with the mileage on my car(just dashes), then the airbag light came on and a wrench light came on then few minutes later the tire pressure light. We were coming up on a red light so I slowed down and stopped. When the light turned green I pressed my gas pedal and the car went no where. I slowly moved to the side of the road and shut my car off. I was hoping to make it to the gas station 2 miles up the road. I waited a few minutes turned my car back on a very odd noise happened the speedometer was back on and the lights were gone, I went to put the car in D and the odd noise again, pushed the gas to accelerate and nothing. Currently my car is on the side of the road waiting a tow 1 hour away from home. I'm lucky my children were not with me when this occurred, it could have been very dangerous. This was my first experience with this, not only dangerous but very embarrassing with an employee in my car as well.

- Martinsburg, WV, USA

problem #129

Jan 012015


  • 70,000 miles


I have a 2008 Ford Edge, I have been noticing over the past few months that at random times the car will lurch forward when accelerating as if it suddenly received a burst of speed. One day I was at a stop light and I took my foot off the brake so that I could drive and the car wouldn't move and when I pressed harder on the accelerator there was a loud bang noise that sounded like the car suddenly clicked into drive. It has been happening more and more often where it lags and sticks and lurches forward when it finally wants to go. Today, it had serious issues where I was trying to accelerate and the car was instead slowing down and lurching forward with the sound of the engine straining and making noise. I had to pull over because the cars behind me had to go around me. I was extremely nervous that the car would stall in the middle of the road or cause an accident. When I pulled over and turned the car off and then turned it back on the problem seemed to lessen I only drove at a low speed to avoid an accident. I have two children and this car is unsafe to drive. I will take it to the dealership asap. It also rolls backward on an incline. Ford needs to do a recall on this vehicle because I have done some online research today and see that many many people have experienced the same problems. This is an extremely dangerous issue and needs to be addressed.

- Redwood City, CA, USA

problem #128

Aug 032015


  • 69,068 miles
Vehicle began leaking lubricant from the power take-off unit onto the exhaust pipe ahead of the catalytic converter creating a potential fire hazard. Dealership required replacing the ptu at a cost of $1845.40.

- Oconomowoc, WI, USA

problem #127

Aug 142015


  • 126,000 miles
Most recent 8/14/2015, pulled out into traffic and the car lost power, but the engine was still running. RPM's will go up, but the car will not move. Reverse works. Took it to auto zone, no codes will come up. When I bought it off the lot (9 months ago) it was working just fine and has been going down ever since. Since last November (11/2014) when I bought the car, when driving the cars speedometer will drop down to zero and a wrench light will come on with a few other lights and act like it is stuck in a high gear. After tuning the car completely off (key out of ignition and door opening and closing) and checking fluids I started the car back up and heard a loud clunk and when I put it into drive there was another clunk and after getting the car up to about 10mph (the car is still acting like its stuck in a high gear) there was another loud clunk and the transmission would catch and act like nothing happened. This process repeats ever single day unless I drive it with the over drive off, then it will still happen but about only twice a month. Ex:"V=sk3itic2-rs I have called Ford corporate after googling the problem and seem there are 1000's of cases explaining the same thing and they will only tell me "that's odd seems like your car is the only one that's doing this". I have taken it to several dealership, none of which will do anything because they cannot find a code. Even when the car has a wrench light on and will barley move. This problem needs to get resolved before a severe accident occurs. Have I mentioned this is my only car" from what I have read it could be a couple different sensors and if this is not resolved this was the only and last Ford I will ever own.

- Kenmore, WA, USA

problem #126

Jul 172015


  • 78,000 miles
Driving and a major road the car suddenly slowed down, it looked like someone put the brakes on, someone almost hit me from the back. After that, the car was jerking and shaking and made load noises. Unable to drive the car in drive I put the car on low gear and drove to the dealer. I was told yesterday that it is a transmission problem the cost 5,200 dollars. In November 2014 the car was leaking transmission fluid and was told it was the ptu the car only had 62,000 miles.I was told that was not covered and cost me 1,800 dollars updated 09/08/15

- East Brunswick, NJ, USA

problem #125

Jun 282015


  • 143,000 miles


As I was driving, dash flashed "odo data error", then wrench light came on followed by airbag, tpm, engine light, basically all warning lights, odometer went to zero, loss of accelaration, pulled over and placed in park, car was revving high, turned car off and restarted, same, put on drive, stepped on gas, car revved but no movement. Turned car off and waited couple minutes, restated, warning lights disappeared, odometer back to actual mileage. Put on drive, step on gas, hesitation then loud transmission thump and car started moving again.

- Union, NJ, USA

problem #124

May 162015


  • 62,864 miles
Gradual problems with transmission while driving, occurred on freeway, surging, electrical problems with panel, no speedometer, airbag light on, tire pressure monitor inop. Transmission slipping, and had bang in reverse. Parked and turned off. When turned back on, transmission in complete failure. Had transmission rebuilt through Firestone, $4300.

- North Highlands, CA, USA

problem #123

Apr 072015


  • 77,000 miles
The contact owns a 2008 Ford Edge. While driving approximately 45 mph, the vehicle failed to accelerate and felt as if it would stall. The vehicle jerked when attempting to accelerate. The failure recurred several times. The vehicle was not repaired. The manufacturer was not made aware of the failure. The VIN was unknown. The approximate failure mileage was 77,000.

- Center Point , AL, USA

problem #122

May 192015


  • 50,150 miles
Vehicle transmission failed in highway speed traffic, starting with large clunks and erratic shifting, total loss of acceleration, leading to very unsafe travel on freeway. No shoulder on road, stopped with no power to transmission.state police cordoned off the area enough for tow 45 min. Later. Still having problems with erratic stopping and going, sometimes you have to go to 3000 RPM until trans mission catches and causes unsafe acceleration. Only 50K on vehicle and Ford does not acknowledge a problem, many other complaints and video found on the web you-tube and such. How many complaints or injury's before a recall? please respond. Thank you!

- Salem, OR, USA

problem #121

Apr 252015


  • 89,876 miles
I was driving between 40-45 mph on a main road just after 12 am when the dashboard lit up. The check engine/wrench & airbag lights came on, the odometer displayed an 'odo data error' message (no mileage), & the speedometer needle dropped to 0 mph despite still traveling at 40-45 mph (I relied on my cell phone's gps for my traveling speed). The vehicle was responsive, braking, accelerating, & decelerating normally, as I looked for somewhere to pull over. I came to a full stop at a red light & when the light turned green, I pushed down on the gas pedal but the vehicle was nearly unresponsive. I fully pushed down on the gas pedal but the car only gained enough speed to crawl through the intersection. I pulled into a parking lot just past the intersection, put the car in park, shut it off, & waited 5 minutes before turning it back on. The warning lights were off & the odometer message was gone but when I shifted into drive, there was a loud, wrenching sound & the entire car jerked...still barely able to accelerate & the speedometer staying at 0, unresponsive to the gas pedal. I shifted into reverse with the same results. After a few unsuccessful attempts with the same results, I called for a ride & left the car in the parking lot, arranging a tow to the Ford dealer where it was purchased. The Ford service department did a test drive in their lot & the vehicle was operating normally but pulled computer error codes indicating faulty sensors (the output speed sensor & turbine speed sensor, which weren't 'communicating properly'). I took the vehicle to a local shop for repair since it had just run out of warranty. I'm lucky bethis could have been a much more dangerous situation if it had happened on a busy road or a road with a higher speed limit and fewer stops.

- Carol Stream, IL, USA

problem #120

Jan 242014


  • 138,000 miles
Popping noise made from front driver side tires when turning left, at gear change transmission jerks, powertrain AWD malfunction light came on, truck would not accelerate into 2nd gear loud grinding noise made, censor had to be replaced, popping noise still exist in left front tire

- Ocilla , GA, USA

problem #119

Mar 132015

Edge 6-cyl

  • 107,000 miles

- The Woodlands, TX, USA

problem #118

Apr 052015


  • 89,000 miles
This has been an ongoing problem for a while now (years). What is happening is my transmission is struggling to shift into gear, but more often when traveling at approximately 15-25 mph. At this speed, it will shift but oftentimes when it shifts there is a thud and hard jerk, almost seeming as my transmission is going to drop right out of my car. When I first had this diagnosed, the dealership thought perhaps my PCM needed recalibrated. Shortly after the recalibration, the entire PCM fried and it needed replaced. Luckily, it was covered under an 80,000 mile warranty (my car had about 75,000 miles on it...phew). Needless to say, after the entire PCM replacement, my car still struggles to shift and, unfortunately, it seems like I am not the only one having this problem.

- Tiffin, OH, USA

problem #117

Mar 282015

Edge 6-cyl

  • 115,997 miles
While traveling at a high rate of speed the car dropped into a lower gear. The dashboard displayed several error messages including the check powertrain symbol (lighted wrench) and a odp speed warning. Little to no power being transferred to the wheels.

- Hawaiian Gardens, CA, USA

problem #116

Mar 272015


  • 115,000 miles
1st occurrence: The vehicle's speedometer went to 0 and warning lights came on. As the vehicle slowed and I tried to accelerate out of traffic, the vehicle would not move. It seemed to be stuck in a high gear. I sat on the side of the road and was almost robbed while I was waiting on my husband to arrive for help. After my husband arrived and the car had been off for about 30 minutes, he started it and it drove like normal. 2nd occurrence: About 1 month later, the same thing happened with the vehicle, fortunately I was closer to home. My husband ran through the same process of allowing the car to cool off and restarting it. After some investigation online, this issue seems to be a common problem with the Ford Edge. It appears to be a pair of sensors, called the turbine sensor and transmission speed sensor. It also appears that these sensors cost about $800 to replace. If this is such a common problem, why has there not been a recall from Ford?

- Pearland, TX, USA

Read the next 20 complaints »

Not what you are looking for?