Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: Say what you will about the styling of the Ford Edge, but the bottom line is owners seem to love this vehicle. That is, of course, except in the case of it's dangerous, worrisome and unexplained issues with random engine stalling.

Our data suggests an early defect trend, as owners of the 2007-2008 models have started posting their accounts of what happens when you're driving down the road and the engine just stops. Some at high speed, some at low speed but always a random shutdown of the engine, electrical and power steering.

Time will tell if this becomes a widespread issue, but there's no drying the seriousness of the problem. With that in mind, we're flagging the Edge with our "Beware of the Clunker" rating until the situation improves.


really awful
Crashes / Fires:
6 / 1
Injuries / Deaths:
2 / 0
Average Mileage:
80,123 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2008 Ford Edge engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2008 Ford Edge Owner Comments (Page 2 of 3)

« Read the previous 20 complaints

problem #31

Apr 162015


  • 113,000 miles


Engine symbol on also wrench symbol lost acceleration pull over turn off put in rev heard loud clunk RPM high but not accelaration.

- Smyrna, DE, USA

problem #30

Mar 272015


  • 115,000 miles
1st occurrence: The vehicle's speedometer went to 0 and warning lights came on. As the vehicle slowed and I tried to accelerate out of traffic, the vehicle would not move. It seemed to be stuck in a high gear. I sat on the side of the road and was almost robbed while I was waiting on my husband to arrive for help. After my husband arrived and the car had been off for about 30 minutes, he started it and it drove like normal. 2nd occurrence: About 1 month later, the same thing happened with the vehicle, fortunately I was closer to home. My husband ran through the same process of allowing the car to cool off and restarting it. After some investigation online, this issue seems to be a common problem with the Ford Edge. It appears to be a pair of sensors, called the turbine sensor and transmission speed sensor. It also appears that these sensors cost about $800 to replace. If this is such a common problem, why has there not been a recall from Ford?

- Pearland, TX, USA

problem #29

Mar 072015

Edge 6-cyl

  • 70,000 miles
The speedometer stopped working, two or three warning light on the instrument panel came on, the car lost all power. I would only go forward with the gas petal pushed to the floor. It's a known issue, found out from youtube many people have had the same exact issue. It's an intermittent issue that happens when the vehicle is on the road creating a hazardous situation for everyone. Here is what is known about this issue. Technical service bulletin 07-3-11 6F50 transaxles built prior to 1/1/2007 - dtc P0715, P0717, P0718, P0720, P0721, P0722 and/or harsh engagement, no upshift, fifth gear only. Some 2007 Edge and mkx vehicles equipped with a 6F50 transaxle with a transaxle build date prior to 1/1/2007, with any output shaft speed (oss) sensor or turbine shaft speed (tss) sensor diagnostic trouble code(s) (dtcs) P0715, P0717, P0718, P0720, P0721, P0722 and/or harsh engagements, no upshift, fifth gear only, could have an intermittent short in the oss or tss sensor. Ford knows about this flaw and common problem and there is a tsb, but no recall. This is the problem that is causing the symptoms in the video.

- Dallas , TX, USA

problem #28

Sep 202014

Edge 6-cyl

  • 125,980 miles


I was driving under normal conditions at about 35 mph when the transmission seemed to be slipping and the wrench came on the dash and the car lost all power. I came to a stop and shut the car off and checked the transmission fluid and it was good. I started the car again and it would rev high but barely move. I got home slowly and parked it and when I came back out later and tried it, all the power was back and the wrench was gone and it didn't clunk into gears like it was earlier. I think by shutting it off and taking out the key for a couple hours reset a computer glitch in this car. I have heard many stories just like mine and speaking for many 08 Edge owners we want this recalled. This could result in tons of mechanic bills and unanswered issues for owners.

- Suamico, WI, USA

problem #27

Sep 172014

Edge 6-cyl

  • 118,000 miles
Vehicle lost all power while driving in traffic and steering locked when turning the corner at intersection causing loss of control of vehicle. This has happened on several occasions under random conditions. Weather conditions, vehicle temperature, speed, direction, braking or acceleration does not have any factors when this happens. The vehicle shuts off randomly and power is lost. No codes or warning of any kind. Ford factory has investigated, wiring harness to the mass airflow sensor has been replaced but still continues to have the same problem.

- Delray Beach, FL, USA

problem #26

Aug 302014

Edge 6-cyl

  • 88,637 miles
From time to time while driving wheather on a side road or on a highway in partiular at acceleration the powertrain malfunction/ reduced power light comes on then immediately following there is an extreme loss of power. Accelerator pressed to the floor will allow acceleration but with very minimal tork. I am cocerned this can lead to a dangerous situtation especially on a highway setting. Also the air bag service light, low tire pressure warning light and the serviced engine soon light all light up. There is also an odometer read error, speedometer and tachometer malfuction. The transmission shifts very roughly in and out of reverse and drive. This event generaly last until the vechicle is completely shut down and an appearant reset occurs. There is a period of normal operation for some time and then seems to spike in clusters of events.

- Carlsbad, NM, USA

problem #25

Aug 302014


  • 100,000 miles


This has now happened to me twice with both my small children in the car while on the highway, at highway speeds. T he speedometer went to 0, the maintenance wrench display lit up, along with the error message "tire pressure monitor fault" (or something to that effect) and I was unable after stopping at a stop light to accelerate almost causing the person behind me to rear end me. Once getting to my home when putting the car into park it makes a loud clunking noise then proceeds to jerk the entire vehicle. After letting the car sit for an hour I tried to turn it one once again and test driving a few feet forward, it only moved at a slow pace when gas pedal applied.

- Mesquite, TX, USA

problem #24

Aug 182014

Edge 6-cyl

  • 146,825 miles
Gauges on dash stop working. Tool symbol shows up also tire pressure warning and exclamation mark. Carstarts to slow down. When car is put in reverse it makes a loud clucking noise. Like the motor is gonna fall out. Can't drive it forward but U can go in reverse. This has happened several times. If you let the car sit for a few days it goes back to normal. This has to be a serious problem because lots of people on youtube have posted videos of the same problem! now I'm stuck over 100 miles away from home. Not cool Ford!!!!!

- Vacherie, LA, USA

problem #23

Jul 142014

Edge 6-cyl

  • 67,000 miles
2008 Ford Edge: I was stopped at an intersection pulling out into traffic after driving normally for about 15 minutes. When I hit the accelerator their was no power and the car inched forward at low speed and the rpms increased dramatically. I was able to hit the brake before an oncoming vehicle almost hit my drivers side as I was attempting to take a left. Once I was able to pull over in a safe location, I put it in park and tried to re-engage the transmission in drive. The vehicle was still unresponsive, no power to accelerate. I then shut off the car and restarted and the car behaved normally after the restart. I have had this car for 3 years with no similar issues. This is a safety concern because there is no warning sign and the car does not accelerate as expected. I was lucky that I was able to stop in time without getting hit by the oncoming traffic.

- Lowell, MA, USA

problem #22

Jul 112014

Edge 6-cyl

  • 107,000 miles
While driving down the highway the speedometer stopped and went to 0 mph, the odometer read dashes, the wrench illuminated in the corner, and the airbag warning sign appeared. The RPM's in my vehicle began to climb higher as well and the car speed began to decrease, again I was on the highway. I got off an exit about 1.5 miles from when I noticed the problem start. After slowing down at the end of the exit I noticed my car would barely move and it slowly crept until I was at a safe spot to park. As soon as I parked other warning lights began flashing such as the tire pressure sign and another that I can not remember. I turned the car off and then back on and I experienced a hard start, which was loud, and when I went to change gears the car jerked violently as if the motor was jumping. When placing in reverse gear the jerk was even more violent as if I was being rear ended. I turned the car off and back on multiple times and changed the gears and each time it did the same thing. When trying to see if the car would move I had to push the gas pedal almost all the way to the floor before the car would even move a little bit and again the RPM's revved really high. I ended up calling a tow truck and my car is currently in the shop. Prior to this incident I experienced occasional jerking while driving and the car was switching gears.

- Valdese, NC, USA

problem #21

May 022014


  • 125,000 miles


Transmission seems to be a issue with the Ford Edge. Why has there not been a recall on this product? so many complaints on the Ford Edge transmission. I witness this first hand, May 2, 2014. While driving on the high way, my car out of know where seem to have lost power. The only thing that was moving was the RPM, but the car was slowing down. Finally after pulling to the side of the highway, and turning the car off, it reset some how and at least got me to work. I had to get the car towed from work back home because I did not want to run into the same issue. I did research and seems like I have not been the only one with this issue. Matter of fact there is a long list on you tube. What has Ford done to correct this issue. Other than repeatedly taking income from hard working consumers, for a issue that has not been resolved.

- Mansfield, TX, USA

problem #20

Apr 132014

Edge 6-cyl

  • 68,000 miles
While driving my 2008 Ford Edge it would not shift than a loud bang and slammed into gear, went for a short time then would not shift lights came on dash board tech reved up no speedometer.

- Monroe, NY, USA

problem #19

Apr 042014


  • miles
My wife and I were driving on the freeway, with the cruise control on. At random the care kicked out on cruise and the speedometer was not working, we also had tire pressure warning, engine service warning, air bag warning and no odometer. We made it to the freeway exist, however when we went to accelerate the car barely moved. The engine would rev at high RPM's but would just crawl. We made it to our house (barely) and parked the car. The shift into park was very violent and made the care jump. With my foot on the brake I would shift from P to N, then N to R, then R to D and same order back to park. Each change was very violent. I turned the engine off, let it sit for about 1 minute, turned the car back on and the warning lights were gone and the odometer was back to normal. However, when I went to drive again the shift was still violent, I had not power (high rev and barely moved) and no speedometer. The car is currently in my driveway with that being the current state. I have done some research online and this appear to be a very common issue for these vehicles.

- Rochester , NY, USA

problem #18

Feb 122014


  • 140,000 miles
Here is the link to an exact detailed explanation. When I lost power my car rolled into the middle of the intersection and was hit.

- Fresno, CA, USA

problem #17

Mar 032011


  • miles
I have a 2008 Ford Edge purchased in 2011 6 months after purchase all of the lights came on in vehicle and the car was stalling. It would rev up but it was unable to pick up speed. I took it car dealership and they said they could not find problem. After the car sat for a while it started working fine. A couple of months later again the same problem we towed it to dealer and they said the same thing they could not detect the problem. This is continuing to happen. Again today Dec 2013 while driving the car started revving and would not pick up speed. I really don't know what to do at this point. I will never purchase another Ford again and would like to know what I could do about this issue. I have googled this issue and see that there are several people experiencing the same issue.

- Alpharetta, GA, USA

problem #16

Jun 012012

Edge 4-cyl

  • 61,000 miles
Driving the interstate car seemed to kick out of gear and engine revved up..went in and out of gear.also after that car shifted very hard in 1st 3 worked fine for awhile and then did it again a few months later..after a few more episodes over a years time the transmission finally went out while my wife was in the middle of an intersection..luckily, it coasted enough to get off the road..I was able to get it home in 1st gear, but, wouldn't go into gear after a stop light..had to put in park and back into drive..had the transmission replaced and ok so far, but, something should be done about this..she could have been in a crash as it was a high speed intersection..

- Branchport, NY, USA

problem #15

Jul 102009


  • 15,000 miles
2008 Ford Edge has hard shifts (engine races like it's in neutral and then slams into gear with a loud bang) in two scenarios - from 1st to 2nd, while coasting in stop-and-go traffic, and when quickly accelerating, as in a passing maneuver, from around 35 mph. This results in unpredictable automobile performance.

- Kansas City, MO, USA

problem #14

Aug 052013

Edge 6-cyl

  • 63,000 miles
Driving northbound on lake shore drive in Chicago, Illinois was accelerating on an incline and engine was racing but vehicle was losing power, made a popping noise, white smoke began billowing out of hood, lost all power was rolling to the nearest safety lane which was a turning lane just being opened by city workers when they said for me to get out of the car they saw flames coming out of the lower part of the engine. Had it towed to Ford dealer where mechanic stated there was a blown rod through the oil pan. The last oil change I had was 2/19/13 at 58,840 miles in car.

- Chicago, IL, USA

problem #13

Jun 122012

Edge 6-cyl

  • 38,000 miles
The contact owns a 2008 Ford Edge. The contact stated that while turning right at unknown speeds, the vehicle independently accelerated. The contact was able to stop the vehicle by applying the brakes. The contact stated that the failure happened several times before. The vehicle had not been taken to the dealer. The failure mileage was 38,000 and the current mileage was 54,000.

- Martinsville, VA, USA

problem #12

Apr 072010

Edge 6-cyl

  • 14,000 miles
Upon acceleration the RPM's will go up yet the car will slow down and you will feel a bang as if someone has rear-ended you. This has happened quite a few times within a year of us purchasing it brand new. The dealer couldn't find anything wrong several times I brought it to them. Finally, I left it there a few months ago and wouldn't take it back until it was fixed. They re-did the transmission and said it is fixed. I have been having the same issue with it still. I almost got into a car accident because it did it as I was turning and it just wouldn't kick into gear, then a big bang and it goes. I almost got hit dead on. Now they are telling me they can't do anything about it because I have 60,240 miles on it and it is out of warranty at 60,000. I have been complaining about it since they fixed it but everytime I went to bring it there to have it checked, they didn't have a loaner or the tech who needs to look at it is off. We called corporate and they did nothing. This is ridiculous that I am reading so many other people having the same issue and nothing is getting done - no recalls, nothing. This is unfair as to I have maintained everything on this vehicle and it should not be doing this. This is a Ford issue and they should be taking care of this. It is not the consumers fault for poor manufacturing of a vehicle that was advertised so great! they should be fixing this issue before someone gets hurt or killed in an accident.

- Wall, NJ, USA

Read the next 11 complaints »

Not what you are looking for?