Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


pretty bad
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
7,727 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2015 Ford Edge fuel system problems

fuel system problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2015 Ford Edge:

Unsubscribe any time. We don't sell/share your email.

2015 Ford Edge Owner Comments

problem #14

Sep 012016


  • 6,200 miles


At 6200 miles on a clear warm day of about 95 degrees, at about 40mph on a flat city road, the car lost all power of acceleration, and I had to pull over and come to a complete stop. The engine light and a wrench light appeared on the dash display, and hill start assist unavailable message appeared. I put car into park and shut off engine, waited about 2 minutes, and restarted engine. The engine idled roughly and the accelerator pedal produced no results when pushed. Shut engine off again and waited about 5 minutes and restarted. Accelerator pedal worked normally, and drove off. Wrench light went out and engine light went out after about 20 miles. No accidents were caused as there was enough time to react and travel was on a local street while going straight.

- Fresno, CA, USA

problem #13

Aug 252016


  • 17,000 miles
4/2016-car engine lost power on highway @ highway speeds down to 15 mph. Wrench icon shows on dashboard. Made way to shoulder, shut off car and 2X attempt restart. Drove to dealership. Replaced throttle body assy. 8-25-2016-issue happened for a 2nd time as above @ highway speeds. This car has the replacement throttle body assy. On freeway again and similar dashboard icons. Car had to be towed to dealership. Service says they replaced throttle body assy w/"updated model" per Ford recommendation.

- Mansfield, TX, USA

problem #12

Aug 172016


  • 439 miles
My car is Ford Edge 2015 with only 439 miles on it. I was turning right when attempted to accelerate the car just shut off by itself. I managed to drift into a parking lot to stop the car.. no check engine light was on just a message displayed on the dash "full accessory power active" and the green light on the starter button was flashing. Had to put the car in park and wait 2-3 min until I could successfully restart it. Request research help

- Roanoke, VA, USA

problem #11

Aug 112016


  • 5,754 miles


The throttle body of my car was replaced with 5500 milles. My car broke down at 70 milles/hour on the freeway. The car suddenly loss power.

- Miami, FL, USA

problem #10

Aug 172016


  • 4,560 miles
Vehicle suddenly and without warning lost all power while driving on roadway creating a near collision. Vehicle wouldn't drive, engine seem to stall and wouldn't accelerate. Service engine soon light and yellow wrench light came on, taken to dealership. Repaired electronic throttle body. Vehicle has 4560 miles on it! Ford employee stand very common and dangerous problem. He stated he is seeing this problem on a regular basis with 2015 and 2016 Ford Edges, and that this is a known problem with other Ford vehicles.

- East Northport, NY, USA

problem #9

Aug 032016


  • 9,300 miles
The etb (electronic throttle body) in our car malfunctioned, causing the transmission to disengage while driving on the highway. The engine still ran, but the transmission was non-functional. It was only after coasting to the side of the road and re-starting the vehicle could the transmission engage to get home. This happened twice within four miles. The car was towed to the dealer and the etb replaced. The service rep said this was a common problem with Ford vehicles. I asked it the replacement etb a corrective part to fix this issue, but he stated he 'did not know'. this car has only 9300 miles on the odometer. My concern is that this could be a very serious and dangerous problem in some circumstances, such as being in the middle of a high-speed multi-lane turnpike. You can easily imagine being stalled in such an instance and being hit from behind by following traffic. My online research shows this is a problem dating back on Ford vehicles from 2009 at least, and that the NHTSA is 'studying' the problem, but no recall has been issued. My question is why hasn't this been done since I am convinced most people would consider this issue as an extremely serious health and safety concern, very dangerous to both such vehicle owners, and other traffic.

- Cairo, GA, USA

problem #8

Jul 142016


  • 6,700 miles


Defective throttle body 3.5L V6. I was at a traffic light waiting for the light to change. After the light changed I attempted to go through the intersection and halfway through the intersection the vehicle lost power thus leaving me in the middle of the intersection with vehicles moving around me on both sides. The check engine light and a wrench icon appeared on the dash display. The engine was running at idle speed and the car would not go forward. By this time traffic from the other direction was passing me on both sides. I turned the engine off and restarted it, however, when placed in drive the same thing happened. The vehicle was towed to the Ford garage and repaired. The cause was a defective throttle body which was replaced. The check engine light showed a code that indicated the throttle body problem. The vehicle has 6,700 miles on it. Had we been turning left across oncoming traffic an accident would have been caused. The service department indicated that we were lucky that they had the part because of the numerous vehicles serviced with the same problem.

- Acworth, GA, USA

problem #7

Jun 282016


  • 6,000 miles
My car is Ford Edge 2015 with only 6000 miles on it. I was entering the ramp on a freeway and when attempted to accelerate the car just shut off by itself. I blocked the whole road because could not move. No check engine light was on just a message displayed on the dash "full accessory power active" and the green light on the starter button was flashing. Had to put the car in park and wait 2-3 min until I could successfully restart it. The next day my car did the same thing on a busy street intersection. I had to wait again a little bit to restart it and drove to the dealership. They took the car to check for one day, no rental was provided. I was told that they get many different Ford vehicles with this issue. Next day I received a phone call that they ran a computer scan and throttle body was defective. Throttle body air intake was replaced. Very scary and dangerous situation that can happen anytime, anywhere without any kind of warning. I believe it needs attention...

- Houston, TX, USA

problem #6

Jun 282016


  • 5,700 miles
While driving at 70 mph on a busy stretch of highway, the vehicle jerked slightly, a notification light (orange wrench) came on saying to check the owner's manual, and the accelerator ceased to function. I was able to navigate the car safely to the shoulder; however, the braking felt strained and there was no ability to throttle the engine at any point. Upon stopping another notification popped up saying that "hill assist unavailable". once stopped, I turned the engine off and let the car sit for a couple of minutes. The car restarted (albeit roughly), and I was able to drive home safely. The car is currently at the Ford dealer where the vehicle was purchased. No update has been provided. The only feedback we've gotten was that they may "find nothing". this is a very serious problem, and I do not believe the vehicle is safe to operate without identifying and repairing this issue.

- Novato, CA, USA

problem #5

Jun 032016


  • 28,030 miles
Pulled up to a red light and waited until the light turned green. Then I attempted to accelerate and the the engine shut off; however, it is possible that the engine shut off while the car was stopped prior to accelerating. A warning came up on the vehicle display, but I cannot remember the exact warning. I shifted into park and started the car back up, and all errors cleared. I drove an additional two miles home, and did not experience the same issue (even though I repeated the same procedure at two stop signs, fully stopping and gradually accelerating).

- Floresville, TX, USA

problem #4

May 242016


  • 6,900 miles


I purchased a brand new 2015 Ford Edge on 12/29/15. On January 19, 2016, the ABS break system went out and it took 2 wks to fix.this happened when I was 4 hours from my home and had to leave it at a dealership then drive 4 hours back to get it. Ford could have cared less. Yesterday(5/24/2016),I was driving down the highway at the speed limit (70mph) when suddenly my vehicle's gas pedal stopped working. I immediately felt the car de accelerate and tried to press the gas pedal to keep up with traffic. However, stomping on the gas pedal did nothing to increase the speed. There were cars slamming on their brakes and swerving to go around me. I was in the left lane of a 3 lane highway and many cars and 18 wheelers began swerving to pass me on the right. It was extremely difficult to coast to the shoulder. The power steering seemed to be limited as well.there were 2 near misses with other cars and it could have been a very bad crash. I turned the vehicle off and back on and made it to my destination. But, this happened a second time on my way home in the dark. I took it in the next morning and used all back roads but even at a lower speed, the same thing happened twice. Ford now tells me that they are having problems with the "throttle bodies" on the 2015 Edge and the part is backordered. Therefore it could be 2-3 weeks before my car is repaired. I purchased this car in December of 2016 brand new off the lot, less than 6 months & less than 7K miles later I experienced an extremely dangerous equipment failure with no warning. Ford customer svc does not seem the least bit concerned that their customers are not only inconvenienced by this issue, but could be killed! what is wrong with them" does someone have to die to get their attention. I am still expected to pay Ford moter credit on the car. However, I am unable to drive it.once again, does someone have to die"

- Baton Rouge, LA, USA

problem #3

Mar 292016


  • 6,000 miles
Vehicle stalled again. First time October 2015 (filed a complaint). I was traveling on a road at relatively low speed and vehicle just stalled. Restarted quickly, a vehicle should not just stall for no reason, especially a new vehicle.

- Camarillo, CA, USA

problem #2

Oct 212015


  • 600 miles
In a parking garage, turning right at slow speed and vehicle stalled. No warning, all was going smooth until vehicle just stalled. Vehicle restarted. Informed dealer. Dealer service department "reprogramed PCM per tsb 15-0123". thought all was taken care of until stalled again in March. So reporting now.

- Camarillo, CA, USA

problem #1

May 072016


  • 5,000 miles
Vehicle shut down while driving on a straight section of road. Error said "full accessory power active". nothing was plugged in to any acc. Ports. Very dangerous as you have to place vehicle in park to restart

- The Colony, TX, USA

Not what you are looking for?