Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
2 / 0
Injuries / Deaths:
1 / 0
Average Mileage:
52,726 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2010 Ford Escape engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2010 Ford Escape:

Unsubscribe any time. We don't sell/share your email.

2010 Ford Escape Owner Comments (Page 18 of 23)

« Read the previous 20 complaints

problem #113

Jun 192013

Escape 6-cyl

  • 45,140 miles


The vehicle either stalled or went into safe or limp home mode while traveling around 70 mph on the interstate. This happened during a busy traffic time causing other vehicles to brake hard to avoid an accident. I with my 3 year old son were stranded on the side of the highway until someone was able to get the car back home for me. It was a scary and dangerous situation. P2112 was the code that was read when we had it looked at. Apparently an issue with the throttle body.

- Norman, OK, USA

problem #112

Jun 062013


  • 59,837 miles
I was driving down the street when my car stopped and check engine light came on wrench icon also came on as I tried to accelerate car.

- Dallas, TX, USA

problem #111

Jun 162013


  • 68,500 miles
My vehicle loses all power while pressing the accelerator. I had it diagnosed with problem code P2111. A very dangerous situation to be put in while operating a vehicle. The only way to solve the problem is to stop the engine, then restart.

- Lakewood, CO, USA

problem #110

Jun 152013

Escape 6-cyl

  • 66,424 miles


Experienced repeated stalling of engine while going 40+ miles per hour. Engine would run for approx. One block then stall. Vehicle went to limp mode.

- Del Rey Oaks, CA, USA

problem #109

Jun 172013

Escape 6-cyl

  • 52,500 miles
Vehicle (2010 Ford Escape) traveling at appx. 20mph on freeway when it started bucking, lost some but not all power. Pulled vehicle to side of freeway, shut off engine. Restarted 30 seconds later. Restart was difficult but successful. Successfully drove vehicle to dealer for repair. Dealer claims this is electronic throttle body issue. Cannot repair until part arrives in approximately one week. Very similar behavior from car in two separate incidents last week - both happened immediately upon start up in my driveway. I shut engine off each time and restarted. Restart was difficult but not successful. Similar incident 9 months ago (Sept. 2012). Vehicle traveling at appx. 65mph on freeway when it noticeably jumped, immediately lost most but not all power. Towed to dealership. Dealer could not repeat nor verify concern in 4 days / 150 miles of testing. Research has shown that NHTSA is investigating similar issues on this and other model year Ford Escapes. My experience sounds very similar to complaints from other drivers.

- Ballston Spa, NY, USA

problem #108

Jun 302010


  • 200,000 miles
Purchased May 30, 2012....less than one month later, I was driving onto a ramp and could not accelerate. The car just stopped but I could steer so I was able to pull it over. A state policeman came by and I said I was on the phone with my mechanic. Apparently, the computer had shut down and the issue may have been that the key I was using was not programmed?. I followed steps to program keys and everything was fine for months until this past April, 2013. Driving along on a main road, the car did it again. Could steer it but could not repair same way as before. I know computers and say that when all else fails, disconnect it. So we disconnected battery and were able to start car and get home but the same thing happened again when arriving at my house. Of course the warranty ran out back in February. My mechanic could not duplicate the problem and therefore did not know why it happened. I do regular maintenance that is required and take care of the car. I also keep a log. It happened two more times since, yesterday and today, June 17, 2013. I have seen several complaints online about a similar problem with the same make, model and year. There should be a recall for this problem. The car was purchased used and was two years old. The previous driver did not have it for very long before turning it in. I asked for the car facts from the dealership and the car was brought in several times with no repairs done. Not even sure if they were the actual car facts.

- North Reading, MA, USA

problem #107

Jun 082011

Escape 6-cyl

  • 31,000 miles


As I was driving the car did a RPM surge and while my foot was on the gas, the car would not accelerate until I pulled over and turned the car off and restarted it. The part had to be replaced. My car is currently doing the same thing again.

- Durham , NC, USA

problem #106

May 212013

Escape 4-cyl

  • 62,000 miles
While getting on the freeway the car slowed down on its own and almost stalled out (this occurred twice). It also occurred while driving and speeding up on the freeway where it slowed down to where it felt like it was going to stall out. It also occurred while driving on a street in the city after stopping at a stop light tried to hit the gas and the car felt like it was going to stall out.

- Wickliffe, OH, USA

problem #105

Jun 062013

Escape 6-cyl

  • 68,955 miles
While driving on the interstate in morning rush hour traffic, the vehicle suddenly lost power and throttle control (went into limp mode). I had to move over to the emergency without power and stop the vehicle. After turning the vehicle off for a few minutes, it started and ran ok. Then on 10 June, the same issues occurred again at highway speeds but in little traffic. Again on 14 June it happened 3 times within driving 10 miles again on the interstate at highway speed and in afternoon rush hour traffic. The third time an obd II dtc was issued. Upon arrival home I scanned the code and it was P2112 throttle body stuck closed.

- Memphis, TN, USA

problem #104

Jun 022013

Escape 6-cyl

  • 70,500 miles
My vehicle is a 2010 Ford Escape 6 cyc with 4 wd. This was a new vehicle purchased in early 2010 as it had 4.7 miles on it when purchased and I put most of those miles on it during the test drive. When traveling at highway speed recently in heavy traffic the vehicle suddenly lost all ability to accelerate. It was as if there was no gas pedal in the vehicle at all. No shuddering, or chugging after this occurred and absolutely no warning at all before it occurred. It was extremely lucky that no one was injured as I attempted to make my way across 4 lanes of traffic to the shoulder. The vehicle never shut off when this occurred. I then turned the vehicle off, waited, and then restarted and it seemed to run fine. I took it to the Ford dealership where it was purchased to assess the situation. I was told the battery was bad which they replaced. I questioned as to how a battery could cause this type of problem as I understand some of the vehicle mechanics and my research showed that it was more than likely a throttle body issue and I was assured that battery was most certainly the issue due to the complex nature of vehicles today and their on board computers. When the battery was replaced my wife picked up the vehicle and had just entered the interstate when at highway speed the same exact problem occurred where an accident was almost caused by her efforts to exit the road. Again no warning. When it was restarted it was driven back to the dealership. Today, it was confirmed by the Ford dealership that in fact it was the throttle body issue that my research had show it to be, and more so, the part, which is somehow not a safety recalled item by the NHTSA, is on back-order by Ford because of the shear number of these parts going bad and needing to be replaced in so many vehicles. I now own a vehicle that cannot be operated safely without a safety recall.

- Norfolk, VA, USA

problem #103

Jun 132013

Escape 6-cyl

  • 36,960 miles


I was traveling at highway speed, 60 mph, when the engine suddenly lost power and I had to coast to the side of the road. The warning indicating a problem with the throttle control/powertrain came on. I turned the motor off and restarted the engine, the light went off, and I proceeded to work without further incident. After researching on the internet and talking to my dealer, I was told it was a defective throttle body part and is on "national back order" and will be at least 2 weeks before they can get the part in. On the same day, on the drive from home from work, the exact same problem happened, but this time at about 35 mph in traffic. Fortunately no one was right on my bumper at the time. There is absolutely no warning when this happens, it just suddenly loses power.

- Jefferson City, MO, USA

problem #102

Apr 202013

Escape 6-cyl

  • 54,000 miles
Vehicle suddenly lost power while traveling at highway speed. I was able to steer to the side of the road and stop. Vehicle restarted and had the same issue two more times in a 40 mile trip. Vehicle has continued to have the same problem intermittently both at surface street speed and highway speeds.

- Bay City, TX, USA

problem #101

Mar 252013


  • 74,000 miles
When driving down the road my Escape will all of a sudden start to shutter. The RPM will go down to 1 and then fluctuate between 1 and 2. the gas peddle will not respond. The engine light and small wrench light appear on the dash. I have to pull off on the side of the road and shut it off. Sometimes it would crank back up with no more problems for a few days or weeks. But other times the car will only travel a few yards before doing it again. I took it to the Ford dealership and they said they couldn't do anything with a light on. Finally it happened one day when I was close to the dealership. They ran a diagnostic test and said my throttle body was dirty. They charged me $406 to "clean" it. The next day after pulling into the parking lot while in park it started doing the shutter thing again. I took it straight back and without a light on the dash they couldn't tell me what was wrong. It did this 4 more times until my fiance' and I were on the interstate going 75 and it did it and jerked so badly we almost wrecked. His father had a diagnostic code reader to hook up to cars and the codes came back as the throttle body door was jammed open and the other code said it was jammed open at the same time? we took it back to the Ford dealership and they said a ton of people were having the same issue but to clean it again. We said no because that didn't solve the problem last time. Instead we wanted to buy a new throttle body. The dealer said it is on national back order because everyone is having huge problems with throttle body parts so we would have to tough it out until some came available. Luckily my fiance… called another dealer who happened to have one that they emergency ordered for someone else. Once we have that one installed we will be out about 1000 for something on a car that is not old and very well taken care of. I will never buy Ford again.

- Live Oak , FL, USA

problem #100

Jun 102013


  • 47,100 miles
Car cut off while driving. Ford dealer said it is the throttle body. Will take 4 to 5 weeks to receive the replacement part.

- New Castle, DE, USA

problem #99

Apr 102013

Escape 6-cyl

  • 41,500 miles
Vehicle cut off while traveling in traffic at about 45 mph, wrench light came on. The engine cranked back up, continue on my way. 2nd incident happen while traveling to work, engine kept running but, could not give engine gas, coast to a stop. Wrench light came on, engine was idling rough, turn vehicle off, engine cranked back up. 3rd incident engine surged and cut off after taking off from stop light. Another incident engine cut off while traveling about 40 mph, engine surged, stumble. Wrench light came on. Engine cut off, wrench light and service engine light came on, and stayed on for two days and then went off. Vehicle is out of warranty. Dealer thinks throttle body.

- Fayetteville, NC, USA

problem #98

Jun 102013


  • 56,000 miles
Three time within 5 miles the vehicle stopped accelerating and giving it more gas did nothing. I would have to coast to the side of the road and hope no one hit me in traffic. I took the car to a mechanic and he said the throttle body was faulty.

- Lockport, NY, USA

problem #97

May 192013

Escape 6-cyl

  • 48,000 miles
I was driving at 45 mph when the vehicle shuddered and lost power. It began coasting and I had no response from the gas pedal. I pulled the vehicle over and put it in park. I realized it was still running, just very roughly. I shut the vehicle off and restarted it, after which it drove fine. Since then, it has happened between 5-6 times in a 2 week period. I took the vehicle to the dealer to be diagnosed and they told me I needed a new throttle body, which is not covered under the power-train warranty.

- Bainbridge Island, WA, USA

problem #96

Dec 262012


  • 51,000 miles
This is the 2nd time I have taken my 2010 Ford Escape in for losing acceleration, stalling. The engine still runs but I am unable to accelerate. The car basically won't run, but will start up again. This is a major hazard if this were to happen on the freeway, or with a higher speed. It generally happens around 30 miles per hour. Back in December, 2012 I took it in to bill brown Ford and they could not figure out the problem, and returned the car to me, saying it didn't happen to them. After experiencing the problem on a daily basis all last week I took it in today to bil brown Ford on Plymouth rd in livonia, mi. They told me because I no longer have a warranty anything they do find I will have to pay for. It seems like with a safety concern like this they would fix it free of charge. Someone could very well run into me from behind when I lose acceleration and cannot run the car. Please I hope you can help and help others experiencing this problem. I hope they are able to diagnose the problem today and won't charge me for it. I didn't do anything to this car. It is not normal wear and tear. It should be fixed by Ford before a crash happens. Also of notation in case this helps I used regular gas only from December, (after this happened the first time), until last week when gas prices went up I switched to E-85. Wondering if this might be the problem? I tried to run the gas tank down before filling up with regular unleaded this week as I heard.

- Canton, MI, USA

problem #95

May 242013

Escape 6-cyl

  • 39,300 miles
Driving on highway, heard a little pop and had sudden loss of power from depressed accelerator, but engine was on - no warning light on dash. Was going on downward incline, able to go from left lane to shoulder on right; engine shook violently then and I turned it off. Waited a minutes, turned back on; idling had a little "miss" but able to finish trip. Upon return home, took vehicle to mechanic, found no historic code in computer and nothing found on test drive. On 6/07, again on highway and without warning, car again lost power from accelerator - immediate loss of momentum almost caused me to be broadsided by large SUV merging from off ramp as I am trying to coast to the shoulder. Same thing, engine shook, I turned it off; again no warning light. Occurred two more times and we turned around for home. Same thing happened two more times on the return trip - the yellow wrench warning light came on the last two times. Very hazardous condition, I plan to not drive and take to the dealer as soon as I can. I see there is a known issue with the throttle body and feel a recall should be implemented, especially since the condition suddenly puts a driver in a very dangerous position and I will have to pay for a known design / device problem to be repaired.

- Silver Spring, MD, USA

problem #94

May 232013


  • 32,000 miles
While driving coming to complete stop to make turn press gas pedal engine lose all power and wrench indicator came of dashboard. Pulled over to side of road out of traffic. Turn engine off then turn engine back on wrench was gone & power return. Problem existed 2 more times after this date. Call Ford service & took Escape in for service for problem to be throttle body valve sticking as of 060613 still waiting on new part for Escape. Escape is at dealership since 06/03/13.

- Glen Burnie, MD, USA

Read the next 20 complaints »

Not what you are looking for?