Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

7.3

pretty bad
Typical Repair Cost:
$180.00
Average Mileage:
67,459 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (2 reports)
  2. new idle control switch (1 reports)
2001 Ford Expedition engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2001 Ford Expedition Owner Comments

problem #3

Apr 102009

Expedition

  • Automatic transmission
  • 98,000 miles

A D V E R T I S E M E N T S

Occasionally, my Expedition will not restart. The engine cranks very well, but does not kick over. After waiting an hour or so, the engine will start just fine. This has happened about three times in the past month or so. In reading someone's previous complaint, an "idle control switch" malfunction was indicated. My problem cause has yet to be determined. I have left the vehicle at a dealership for two days on "the computer" in their attempt to replicate the problem, but to no avail. I was charged $100 for this "service," or should I say "mis-service." I would have thought that some problem-solving-thinking from those so-called experts would have come up with some possible causes, but no advice was forthcoming other than, "we couldn't replicate the problem. That will be $100 please." Could my problem also be the result of a failed idle control switch?

- , Phoenix, AZ, USA

problem #2

Sep 102007

Expedition XLT 4.6L V8

  • Automatic transmission
  • 79,177 miles

A couple years ago I noticed my 2001 expedition would hesitate when I would go to start it, kinda like it didn't want to catch. Didn't pay it any mind I was thinking, well its cold out and its been parked all night. well a few weeks later it did it again this time it wouldn't start after numerous times trying to get it to start. I had to call my friend for a ride to work. Later that day when I got home I was determined to get it to start and I did,but once started the idle would be low to the point it would stall, so I drove it straight to the shop. I described the problem and they ran the test. nothing came up on the test and at this point the car was starting up fine and the idle was fine. The mechanic told me maybe its a problem you may need to let get worse so we could catch it or bring it to us when its doing it. OMG WHAT KIND OF STUFF IS THAT!! For the next couple months it would do this maybe about 3 times a week. One day it did it when I was leaving work and I had enough so I drove it straight to the shop again. of course once I got there it was running fine so by this time the Mechanics knew me by first and last name. I told them I would leave it, So when they went to start it in the morning they would see what I was experiencing. I called that morning once they opened and the mechanic told me it started right up. WOW This went on for another week. then I just woke up one morning on my off day, got in the car and after trying to get it started for 20minutes I drove it to the mechanic and it finally did it for them continuously.They were finally feeling my pain. One of the mechanics who was working that day knew exactly what was wrong(idle control switch) it just so happened he wasn't working all the times I had gone before. They took off the part and one of the mechanics was looking at the part like I like ( I don't believe I couldn't figure this out) he was baffled.That's my drama filled story thanks for reading and be glad you didn't experience it.

- , Marrero, LA, USA

problem #1

Mar 212009

Expedition Eddie Bauer 5.4L

  • Automatic transmission
  • 25,200 miles

THIS PROBLEM STARTED ABOUT A YEAR AGO BUT NO ONE KNEW WHAT IT WAS. IT WOULD ONLY HAPPEN A COUPLE OF TIMES BUT NOW IT IS HAPPENING EVERY WEEK. I REALLY LIKE THIS TRUCK BUT THE COST TO FIX THIS IS HUGE. IF I WAIT ABOUT AN HOUR OR SO THEN THE TRUCK STARTS RIGHT UP WITH NO PROBLEMS. AT LEAST I HAVE THAT GOING FOR ME.

- , Lake In The Hills, IL, USA

Not what you are looking for?