Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


pretty bad
Typical Repair Cost:
No data
Average Mileage:
109,222 miles
Total Complaints:
4 complaints

Most Common Solutions:

  1. not sure (3 reports)
  2. replace actuator (1 reports)
2003 Ford Expedition AC / heater problems

AC / heater problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Ford Expedition:

Unsubscribe any time. We don't sell/share your email.

2003 Ford Expedition Owner Comments

problem #4

Dec 172010

Expedition XLT V8

  • Automatic transmission
  • 97,888 miles


Worst cold weather in 60 years in Texas (SuperBowl-45) and our family's FORD SUV EXPEDITION has NO HEAT due to the equivalent of the "FLUX CAPACITOR" known to all the Ford Dealers as the ACTUATOR! $1000.was the estimate according to the Labor Book Guide in Hours, to remove the Dashboard. We thought we could get a lower estimate, but most mechanics use the same guide...thanks Ford for the LOUSY DESIGN...we'll bundle up and wait it out!

- , Fort Worth, TX, USA

problem #3

Nov 022009

Expedition LTX V6

  • Automatic transmission
  • 126,000 miles

I've had my car at the garage for the past two days and after getting several defective parts from both Ford and other after market suppliers it was determined their is a design flaw. The parts were not working and I'm still getting cold air flowing from the passenger side of the dash. The manager of the garage told me Ford is experiencing tremendous problems across the country with this part.

- , Colleyville, TX, USA

problem #2

Jul 112007


  • Automatic transmission
  • 70,000 miles

My heat has worked on and off for the last 18 months I replace the fuses thinking that is the problem it works for a couple of days then no heat again I can't seem to get it fixed I have it at the shop at least 3 times a year for this problem...

- , Manchester, CT, USA

problem #1

Oct 302008

Expedition ELT 4.6L

  • Automatic transmission
  • 143,000 miles

my 03 Expedition does not blow warm air when I turn on the heat, it just blows room temp air. There are no leaks or smells that would indicate maybe a heater core issue. Can someone point me in the right direction to resolve my no heater issue??

- , Red Oak, TX, USA

Not what you are looking for?