Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

CarComplaints.com Notes: The 2003 Ford Explorer one of our worst vehicles on record. "Avoid like the plague" is putting it lightly.

The 2002-2005 Explorer has a very well-established record of expensive transmission failure at under 100k miles. The Explorer has an enclosed transmission which is typically replaced with a rebuilt transmission at a cost of almost $3,000.

Another common problem for the 2002-2003 Explorer is wheel bearing failure at around 90k miles, with a typical repair bill of $500 to $1000 depending on how many wheel bearings failed.

Adding insult to injury, the 2002-2005 Explorer also has a massive problem with the rear panel cracking. While it's a minor annoyance compared to transmission failure, ironically the crack usually goes right through the Ford logo.

10.0

really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
45,444 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2003 Ford Explorer brakes problems

brakes problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Ford Explorer:

Unsubscribe any time. We don't sell/share your email.

2003 Ford Explorer Owner Comments

problem #9

Sep 202010

Explorer

  • 93,000 miles

A D V E R T I S E M E N T S

93,000 miles and ABS light and loud grinding noise (in addition to applique crack in rear). Need to replace both rear hub bearings, brake pad rotors, and parking brake shoes. Search the web on these problems, and over 3 hundred complaints seen on just one site for 2003 Explorer alone.

- Philadelphia, PA, USA

problem #8

Mar 072010

Explorer

  • 142,000 miles
The vehicle is a 2003 Ford Explorer. Has 142,000 miles. Had tire rotation at 137,000 miles in Jan 2010. On 3/6, we drove 120 mi from home to baltimore, parked in parking lot for 6 hours. Drove 50 mi to tyson's corner va, parked in hotel parking lot. On 3/7, we drove 15mi to daughter's home in arlington. Left car there for 7 hours. Drove back home along routes 66, 495 and then 95. Went about 60 mi when I noticed the steering wheel was shaking a bit. Kept driving for maybe 5 mi before I heard a noise from the front end near the wheels. Decided to pull off the highway and get to a service station to check tire pressure. Checked tire pressure and began to back out when the right front wheel fell off. There was only 1 lug stud remaining that was broken off about 1/2 " above the brake drum. The other 4 lug studs were missing, and seemed to be sheered off about 1/2" below the drum. Thankfully, the wheel did not fall off on route 95, else we and, most likely others, would have been seriously injured or killed. I had the car towed to my body shop, also the dealership that I bought the car from and had the tire rotation done. Looking at some forums, it seems like this is not the first/only time that a Ford Explorer has lost a tire by broken lug studs disappearing. I will get the vehicle repaired and then will sell the vehicle. I will also have the other lug posts inspected, but who knows if anyone will see anything. I believe that this issue warrants further investigation, if none have already been done. Thank you.

- Ocean City, NJ, USA

problem #7

Jun 042009

Explorer

  • 54,000 miles
I was driving on the freeway at approximately 60 mph. When I depressed the brake, the car accelerated to 70 mph first, then to 80 mph. I tried applying the emergency brake, but it did not slow down the vehicle at all. To avoid colliding with the vehicle in front of me, I forced the transmission gear into parking. This momentarily slowed down the vehicle, and I tried to move it into the far right lane of the freeway. Then suddenly it started driving in reverse at a very high speed, causing me to collide with an oncoming truck on the freeway. Unable to control the car and fearing for my life, I turned the ignition key, which brought the car to a halt. The high patrol arrived within only a couple of minutes. When one of the officers turned on the car so as to determine what the problem was, the car immediately accelerated to 80 mph. He turned off the car and directed everyone to step away from the car, cautioning that the car was dangerous. Two officers disconnected the battery and said that there appeared to be a problem with the accelerator. They then pushed the car off the freeway to the nearest gas station. Fortunately, I did not get hurt. But there was significant body damage to my car and to the other truck with which I collided. However, the driver of that truck drove off, thus I was unable to get his information. I had the car immediately towed to my neighborhood Ford dealership, which determined that the accelerator pedal was defective. When I advised them that the emergency brake had failed, I was told that nothing works when the accelerator pedal breaks. This is a serious problem. The car was out of control on the freeway, driving in reverse, and it could have injured many people and caused a lot more damage. Ford refuses to pay for the body repair, and is charging me nearly $1,000 to replace the accelerator pedal. I would appreciate your investigating this problem. I would be happy to provide a copy of the letter that I sent to Ford.

- Los Angeles, CA, USA

problem #6

Oct 202006

Explorer

  • 50,000 miles

A D V E R T I S E M E N T S

I purchased a 2003 Explorer in August 2006; mileage was approximately 45,000. By October the car would not start and the alternator was replaced. A few weeks later, I was back because my car was jerking. Nothing showed up on the diagnostic tool at that time. However, I was told the starter would have to be replaced as would the recently installed alternator. I returned less than a month later with the same jerking issue, only this time I notified the repair shop that the O/D light had been coming on. Furthermore, my car had actually stalled in the middle of traffic. Again, nothing was found. By early December, I was back. My car had stalled on a few more occasions and would not "pick up". that is, even though the RPM's would reach anywhere from 2500 - 4000, my car could not accelerate above 25 - 30 mph. Several days later I was told that the transmission needed work. I got my car back a few days before christmas and decided last minute to head to the mountains. As soon as I reach a slight elevation, the car ceased to accelerate and what's more, a thick heavy cloud of black smoke came out of the rear and persisted for at least two miles. I headed back down the mountain for home. I took the car back and they kept it for at least a week and a half to repair the torque converter and other transmission related issue. In early fall 2007, I took the car to my local Ford dealer for some strange noise coming from the engine. It ended up costing $2500 to repair. I returned in November for more work, this time for the same torque converter and solenoid issue as a year ago. During this two year period, my vehicle was under extended warranty. The total repair cost for the first year of ownership is anywhere from $5000 - $9000, of which I paid at least $2500 out of pocket. My warranty has since expired and I am worried that these same issues will recur, as I have read they have. This is not an isolated incident and should be investigated and a recall issued.

- Las Vegas, NV, USA

problem #5

Jan 102008

Explorer

  • 70,000 miles
Brake pads completely disintegrated when inspecting pads, front edge of rotors have completely rusted. Pads were in good shape thickness wise in some areas and rotted in other areas. Pads and rotors were replaced now 5 months later it's starting again. Parking brake pads delaminated again. ABS light came on during trip for no reason?

- Chanhassen, MN, USA

problem #4

Dec 312003

Explorer 4WD 6-cyl

  • miles
Numerous problem: Brakes, rear window opening, seat belt retraction, heater, rear defrost, body work, etc.. while braking the brake pedal went to the floor and caused extended stopping distance. The rear window hinge failed which caused the window to open while the consumer went through a car wash. The seat belt retracted slowly which caused the belt to become hooked onto the door lock system. As a result the passenger could not get out of the vehicle. The left wiper was not clearing the windshield. The left rear door would not close all the way unless it was slammed hard.

- Mountain Home, ID, USA

problem #3

May 282004

Explorer

  • miles

A D V E R T I S E M E N T S

While stopped with foot on brake, the brake pedal went to floor when applied. Consumer was told that the vehicle was functioning properly.

- Cortland, OH, USA

problem #2

Sep 032003

Explorer

  • miles
Potential safety problems with the 2003 Ford Explorer.

- Huntington Beach, CA, USA

problem #1

Oct 082003

(reported on)

Explorer

  • miles
Problems with brakes, transmission and seat recliner handle. Dealer was notified.

- Jersey City, NJ, USA

Not what you are looking for?