Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


really awful
Crashes / Fires:
1 / 2
Injuries / Deaths:
0 / 0
Average Mileage:
80,644 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2005 Ford Five Hundred electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2005 Ford Five Hundred:

Unsubscribe any time. We don't sell/share your email.

2005 Ford Five Hundred Owner Comments (Page 1 of 4)

problem #65

Jul 072016

Five Hundred

  • 177,000 miles


I will never buy another Ford vehicle ever again!!!!!! I own a 2005 Ford Five hundred there was a recall in 2012 on the throttle body, a Ford dealer supposably cleaned the throttle body, well now its not driveable. We have since talked to several Ford dealers including Ford Motor Company, they all said it was our responsibility to fix the problem. I do not think it should be my responsibility to pay for this since the part was recalled !!! the car could stall at anytime while driving putting myself and my family at risk, I don't think much of this automobile company for not standing behind there product, I will never recommend a Ford vehicle to friends, family or even my worst enemy never never again!!!!

- Covington, OH, USA

problem #64

May 052016

Five Hundred

  • 110,000 miles
I dont feel safe driving my car I put 2000 dollars of work and still do not feel save.

- Chicopee, MA, USA

problem #63

Apr 042016

Five Hundred

  • 140,000 miles
Instrument cluster not working. Oil and brake light illuminate constantly. Reverse lights and brake lights constantly on on the exterior of the vehichle. Cruise does not work. Blinkers do not work. Starts doing this as soon as the car is started. Started while going down the expressway now constant.

- Howard City, MI, USA

problem #62

May 052010

Five Hundred

  • 95,000 miles


The contact owns a 2005 Ford Five hundred. While driving 50 mph, the vehicle lost power and jerked. All the lights on the instrument panel illuminated. The vehicle had to be turned off and restarted. The vehicle was taken to an independent mechanic who diagnosed that the computer needed to be replaced. The computer was replaced, but the failure recurred. The manufacturer was notified of the failure. The approximate failure mileage was 95,000.

- Germantown, MD, USA

problem #61

Apr 122016

Five Hundred

  • 188,000 miles
The transmission disengages at various speeds even on the interstate at 55+ mph causing it to lose power. You must be able to get it stopped on the side of the road and shut the car off and then restart it to correct the problem for a short period of time.

- Weston, WV, USA

problem #60

Dec 122012

Five Hundred

  • 101,000 miles
The contact owns a 2005 Ford Five hundred. The contact stated that when the ignition was turned to the on position, the vehicle was shifted out of park and the RPM gauge fluctuated. The failure recurred numerous times. The vehicle was taken to a dealer where it was diagnosed that the RPM surge failed and needed to be replaced. The vehicle was repaired, but the failure persisted. The manufacturer was notified of the failure. The failure mileage was approximately 101,000. The VIN was unavailable. MA 10/25/15

- Boilings Springs , SC, USA

problem #59

Aug 172015

Five Hundred

  • 220,000 miles


While driving dash lights, speedometer, tachometer, gas level, and temperature go out for several minutes at a time. Reverse lights come on and airbag light comes on. This is dangerous; unable to tell speed! per internet research this is happening in several Ford models and stems from a bad solder joint.

- Taneytown, MD, USA

problem #58

Aug 252014

Five Hundred 6-cyl

  • 159,985 miles
Was driving in heavy traffic through metro city in rush hour on interstate.on 4 lane highway had to cross 2 lanes of traffic to exit;car lost power and message center said engine fail safe mode.tried to accelerate to exit;car had lost power with no acceleration.when I finally got to exit was down to 20 miles per hour.

- Morristown, TN, USA

problem #57

Aug 212014

Five Hundred 6-cyl

  • 177,320 miles
I was driving in town going about 40 mph when the car lost all power, then engine failsafe mode displayed on the information center and a little wrench was also displayed. With no power steering, I had to pull over quickly in lunchtime traffic. After stopping the car, I waited a few seconds and restarted it. No problems with it until the next day when the check engine light came on. I have also noticed a mechanical smell coming from the ac. It appeared, at first, that this problem had come out of nowhere when I suddenly remembered two occasions when the rpms suddenly stuck on 3000 and would not stop until I put the car in neutral. Also, when using cruise control, the whole car shakes and stutters slightly when going up or down very slight inclines.

- Lexington, KY, USA

problem #56

Jun 162014

Five Hundred 6-cyl

  • 131,000 miles
Only had the car for five months driving down the street the check engine light came out car stopped in the middle of the street with my children in it and wouldn't start up..worst car I've ever bought second major incident that has happened since I got the should be a recall major safety violation.

- Wichita, KS, USA

problem #55

May 222014

Five Hundred 6-cyl

  • 36,000 miles


Part of an ongoing series of issues with this vehicle (see earlier reports), initial symptom was the dash lights & needles shutting off intermittently (but now for extended periods). Vehicle then began showing random warning lights including "check engine", which was diagnosed first time as low fuel level sensors a & B. since that time I'd disconnected the battery on a suggestion of a mechanic friend and all the issues disappeared for a few weeks. Yesterday the check engine light came back, and the car was running poorly (creeping when first off brakes, not up shifting), when the dash was operable it showed alternating check engine/check transmission warnings, and vehicle was surging/lagging noticeably at highway speeds. I again did the battery disconnect last night, and the car is operating normal today, but I'm sure it will recur shortly. I am hesitant to take it to a dealer as this sounds like a significant electronics issue, and I have already read up on the Ford tsb 06-17-9 that is documented online, not all of which aligns with my issues. Had the battery reset had no impact on the problems I would say it's a mechanical matter, but it seems clear its a computer or electrical issue.

- Northbridge, MA, USA

problem #54

May 092014

Five Hundred 6-cyl

  • 35,500 miles
I purchased the vehicle used on 2/21/14 w/31,000+/- miles, initial issue was with instrument cluster intermittently blipping on & off (sometimes for extended periods). That issue was followed by a check engine light, which when analyzed showed low fuel sensors a&B (occurred in late April 2014). Up to this point the vehicle was drivable with no impact on actual drivability. Last Friday 5/9/14, I was at a light and when it turned green I proceeded to drive off, but vehicle was barley moving or responding to throttle input, this continued for a short distance & eventually built up to normal speed. It recurred again at the next light, with same symptoms. I contacted a mechanic I know and the next day I disconnected the battery cable in an attempt to clear the system, and as of a week later only the dash lights issue has recurred. However I feel the loss of power is a significant concern if it were to occur on a busy road or at highway speeds.

- Northbridge, MA, USA

problem #53

Apr 012014

Five Hundred 6-cyl

  • 33,850 miles
Instrument cluster intermittently went dark and/or gauges went to zero/off positions, we pulled over to see if exterior lights worked and all did, as well as blinkers and flashers, but we noted that reverse lights were now on. It has recurred a few times, its most noticeable after dark as dash lights go black. Only light on dash was the airbag light. I went online & found info on a technical service bulletin "tsb 06-17-9 09/04/06 - intermittent instrument cluster", it does not appear to be a recall item so assuming any repairs are entirely owner cost ?

- Northbridge, MA, USA

problem #52

Oct 072013

Five Hundred

  • 75,000 miles
The contact owns a 2005 Ford Five hundred. The contact stated that the instrument cluster dimmed intermittently which made it difficult to see the display. The vehicle was not diagnosed or repaired. The manufacturer was not made aware of the issue. The approximate failure mileage was 75,000.

- Scappoose, OR, USA

problem #51

Jul 152013

Five Hundred

  • 87,530 miles
Car drives on its own! if I do not have foot on gas on break it will continue to move. Said failsafe mode then check engine light illuminated, dash board said check engine check transmission then the light went out the following day. Now driving back to normal. I took to auto zone the day it went haywire & they advised me its a possible recall several ppl said the same issue with their Ford.

- Washington, DC, USA

problem #50

May 202013

Five Hundred 6-cyl

  • 150,000 miles
Driving down the interstate and the instrument cluster stopped working. The speedometer, tacometer, fuel gauge, turn signal indicator as well as the rest of the digital insturments quite working. I pulled over and checked and my outside lights and radio worked.

- Arlington, VA, USA

problem #49

Jan 262013

Five Hundred

  • 79,000 miles
The contact owns a 2005 Ford Five hundred. The contact stated that while traveling at unknown speeds, the instrument panel failed. The vehicle was not repaired. The manufacturer was contacted about the failure. The failure mileage was 79,000.

- Sierra Vista, AZ, USA

problem #48

Jul 102012

Five Hundred 6-cyl

  • 160,000 miles
One day in June I was pulling up to a store parking space rolling roughly 5mph. I had my foot on the brake, I was about to stop. Without touching the gas my 2005 Ford Five hundred lunged at the building as if the throttle was stuck wide open! I had to push the break as hard as I could to keep it from crashing into the store! Ford should have a recall on this issue! it is extremely dangerous! this has happened to many Ford Five hundred owners! last month in January my Five hundred had other issues. I was driving 35mph and all of a sudden my car had no power, I gave it gas and it would growl but no power. I had to pull over and shut the car off. One restarted it returned to normal but the wrench icon light was on the dash. I have also had an idling problem. While at idle my car would sputter. The RPM's were low and it would idle rough and surge from low to high, I tried hitting the gas pedal and the car stalled! again other Ford Five hundred owners also experienced these issues! Ford its time to step up and do a recall!!!!

- Strafford, NH, USA

problem #47

Jun 012012

Five Hundred

  • miles
The headlight socket on both headlights are over heating and melting causing the bulb not to operate. I'm just nervous that this will cause a fire as all the parts are plastic. I also noted on line that it is a very real problem and I'm not the only one experiencing this.

- Worcester, MA, USA

problem #46

Oct 262012

Five Hundred 6-cyl

  • 135,000 miles
Was driving my 2005 Five hundred today. I pulled off the highway and stopped at a red light. When the light turned green I had hardly any power. No power steering, all gauges at home and a message say "engine failsafe mode". I turned the car off and restarted with no problems. I've read on different sites where people have had this same issue of the throttle sticking open and the car lunging forward or back nearly causing a wreck.

- Holden, MO, USA

Read the next 20 complaints »

Not what you are looking for?