8.0

pretty bad
Typical Repair Cost:
$235.00
Average Mileage:
109,667 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. http://leckemby.net/windstar/windstar01.html ...good info (1 reports)
  2. not sure (1 reports)
  3. replace plenum gaskets/isolator bolts (1 reports)
2001 Ford Windstar engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Ford Windstar:

Unsubscribe any time. We don't sell/share your email.

2001 Ford Windstar Owner Comments

problem #3

Feb 062016

Windstar SEL 3.8L

  • Automatic transmission
  • 169,000 miles

A D V E R T I S E M E N T S

I am the original owner and my van has been well maintained. Problem is the check engine light has been coming on, and I had a tuneup done less than 20,000 miles ago. First one spark plug was bad number 6. Had it replaced, then two months later the van is running extremely rough and missfiring again. So I have spark plug number 5 replaced it was really in bad condition, black with corrosion. After having that done check engine light is back on and boy am I sucking gas! Less than 17 miles per gallon. I take it back in and have a diagnostics read on it. Now it's P0174 bank 2 lean. Vehicle has not had a valve cover TSB update! Which causes oil burning and plug fouling. Ref lash also needed on PCM. Could be other things causing lean running condition. This is going to cost me over 700.00 dollars! Which I think should be a covered under ford fix! I took good car of my van! This should not be happening!

- , Waterloo, WI, USA

problem #2

Oct 012011

Windstar SEL 3.8L

  • Automatic transmission
  • 65,000 miles

I started receiving these two codes. The solution required me to replace the plenum gaskets and plenum isolator bolts.

- , Willowbrook, IL, USA

problem #1

Nov 042009

Windstar LX V6

  • Automatic transmission
  • 95,000 miles

This is an ongoing problem with this van. There is information all over the web about this. The isolator bolts are designed to fail in the conditions they are installed. I have replaced the plugs/wires, Mass Air flow sensor, all the oxygen sensors, PCV valve, air filter, and the light is still on.. Finally found this site on the internet:

http://leckemby.net/windstar/windstar01.html

I hope this helps!

- , Derby, NY, USA

Not what you are looking for?