If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

7.3

pretty bad
Typical Repair Cost:
$120.00
Average Mileage:
125,133 miles
Total Complaints:
3 complaints

Most Common Solutions:

  1. not sure (2 reports)
  2. replace battery (1 reports)
2003 GMC Envoy electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 GMC Envoy:

Unsubscribe any time. We don't sell/share your email.

2003 GMC Envoy Owner Comments

problem #3

Nov 172014

Envoy SLE 3.2L

  • Automatic transmission
  • 213,900 miles

A D V E R T I S E M E N T S

I have owned this car since July 2012 and since then it has done many weird things. My mechanic son says it is possessed. Two months after I had it I was driving down the road and ALL the gauges, radio etc. shut down but the engine was still running. It has done this on many occasions. Next it won't start and has twice killed 2 batteries in approx. 6 to 7 months as well as sometimes it will start with a boost other times NO but the best thing is when you shut the ignition off and remove the key it stills runs. You can also put it in gear when this happens and drive it anywhere. Now I have a crackling sound coming from the dash when everything is shut off (radio, blower etc.) Once I was sitting outside and the alarm went off all by itself and the keys were in the house also I was driving down the road once and the alarm went off and the lights were flashing, really exciting. You really hate to go anywhere because you never know when it is going to act up or just plain not start. I have been to many mechanics and dealerships and all they say is it is electrical. WOW I could have told them that. I have called GM twice and they said to take it to the dealer which I have and they don't know either. I may change my cars name from "Envoy" to "Christine" ever seen that movie?

- , Brockville, Ontario, Canada

problem #2

Apr 082013

Envoy SLE 4.2L V6

  • Automatic transmission
  • 121,500 miles

battery died. 3rd battery for this car. Called triple a and they fixed it.

- , Los Angeles, CA, USA

problem #1

Jul 062007

(reported on)

Envoy SLT 4.2L

  • Automatic transmission
  • 40,000 miles

Shut off vehicle and will not re-start. All gauges go hay wire when trying to re-start. Some times vehicle will crank, but will not start. Read blogs about similar problem but no definite answers. People who have gone to the dealer said the computer had to be re-programmed.

- , Rolling Meadows, IL, USA

Not what you are looking for?