Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

8.0

pretty bad
Typical Repair Cost:
$615.00
Average Mileage:
89,350 miles
Total Complaints:
8 complaints

Most Common Solutions:

  1. not sure (7 reports)
  2. replace catalytic converter (1 reports)
2004 GMC Envoy engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2004 GMC Envoy:

Unsubscribe any time. We don't sell/share your email.

2004 GMC Envoy Owner Comments

problem #8

Aug 242013

Envoy 4.2L V6

  • Automatic transmission
  • 124,980 miles

A D V E R T I S E M E N T S

driving down a dirt road aint a good thing when the envoy shuts down. i dont know what it is but it happened again when i stopped at a red light

- , Gonzales, TX, USA

problem #7

Jun 012011

Envoy SLT 3.2L

  • Automatic transmission
  • 75,000 miles

After spending $750 on repairs car still runs the same I was told there is no fix

- , Dover, FL, USA

problem #6

Sep 172009

Envoy SLT 4.2L

  • Automatic transmission
  • 73,322 miles

wow, I had 275 hp then I get about 120hp goes back and forth day to day ! don't know what it is!! I know it's not from the A/C being on!! so why GM? sooo much for you guys getting another 40,000 when we look for A new suv !! bye bye GMC !!

- , Hamilton, Ontario, Canada

problem #5

Oct 212009

Envoy

  • Automatic transmission
  • 90,000 miles

A D V E R T I S E M E N T S

i bought my envoy and had no problems then when i tried to pull my boat that only weighs about 3000lbs i found out it had no power, engine light was on dealer said the code came back too rich of a full mixture problem was the catalytic converter and of course warrenty did not cover this cost me $500 to fix but was well worth it gained gas mileage also

- , Napoleon, ND, USA

problem #4

Jun 152006

Envoy

  • Automatic transmission
  • 7,500 miles

We bought our car when it was 2 years old with very low miles. When driving or idling the lights would dim. Then it would lose power as I was driving between 30-40 mph. The dealership said it was just because it had not been driven a lot. Well, 2 years later I am still having the same problems and I am at 30,000 miles. Why is there a loss of power and how can it be fixed?

- , Washington, UT, USA

problem #3

Jul 152008

Envoy XL 4.2L

  • Automatic transmission
  • 156,000 miles

I love my truck, but at this point I am so sick of it. I have been beside the road every day for the last two weeks because of loss of power. please help anyone.

- , Meigs, GA, USA

problem #2

Apr 012008

Envoy SLT 4.2L V6

  • Automatic transmission
  • 100,000 miles

If you have had this problem please tell us how to fix it.

- , Lake Mills, WI, USA

problem #1

Jun 202007

(reported on)

Envoy SLT 4.2L I6

  • Automatic transmission
  • 88,000 miles

I was pulling a camper over the weekend (weight was 2600lbs, envoy totally capable of pulling it) and I was going up a steep hill and (had it in 3rd) when it started to rev up to 5000rpm (no increase of power) and held there until I put it in drive and let of the gas. Drove the rest of the way home no problem. Stopped at home then went to drop off the camper. After dropping off the camper I got back out on the main road and gave it some gas( about half throttle) and it revved up to 5000rpm (again no power) I let off the gas and felt it shift. Then it just didnt have the pep as it usually does. When I went to get on the highway I floored it on the ramp (slight hill) and I could barely get above 40mph. As i got on the highway I could go over 60 mph. I could tell something was really wrong and pulled over to check the tranny fluid. It was fine, oil was fine. Then my dad drove it and he thinks its the tranny. I thought it was running out of gas (it was almost on E) so I stopped to put gas in it hoping that was it. It wasnt. Then on the way home from the gas station the Service Engine Soon light came on, it drove alittle better( could go over 60mph) but had no power. I went to Advanced to get the code read and it came back with: P0172 System Too Rich (Bank1)

- , Lancaster, PA, USA

Not what you are looking for?