Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

2.1

hardly worth mentioning
Crashes / Fires:
0 / 1
Injuries / Deaths:
0 / 0
Average Mileage:
75,750 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2007 Honda Fit engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2007 Honda Fit:

Unsubscribe any time. We don't sell/share your email.

2007 Honda Fit Owner Comments

problem #14

Dec 012013

Fit

  • 75,000 miles

A D V E R T I S E M E N T S

Repeated engine misfires causing vehicle to die unexpectedly. Since late 2013 (approx. 75,000 miles), the engine functions erratically and all cylinders have on various occasions registered engine misfires, resulting in the vehicle dying unexpectedly - once nearly leading to an accident when it died as I pulled out into traffic. I have tried - unsuccessfully, using two different mechanics over nearly three years - to resolve the problem, but it persists, despite swapping engine coils in and out, adjusting the idle, and other proposed (but unsuccessful) solutions. Sometimes the "check engine" light comes on, at least giving me some warning, but often it does not. The problem mainly happens when the car is first turned on after sitting for a while, but it is unpredictable: Occasionally this problem happens in traffic, after it has been driven for a while. Because the problem continues, and endangers my safety, I went online to seek help, and uncovered many other Honda Fit owners plagued by this same issue, who had logged their complaints at www.fitfreak.net, so I know this is not a fluke; it's a common problem with the Honda Fit. I'm attaching invoices documenting the attempts to fix the vehicle. Sometimes, swapping the coils fixes the problem for a few days, but it always comes back. The widespread nature of this problem leads me to think something is fundamentally wrong with the Fit engine, and that Honda should recall the vehicle to repair the issue. Unexpectedly losing power, and coming to a halt in traffic, is scary. If I could afford to buy a different vehicle, I would. Please investigate! note: To the question "when did this happen?" I entered the approx. Date the problem began... but it has happened at least 4 times per week, since December 2013 (for 2.5 years!)

- Fort Collins, CO, USA

problem #13

Jul 172016

Fit

  • 116,000 miles
My check engine light came on this Sunday morning when I driving over 60 mph with A/C and radio on my car jerks, I have already had a major transmission repair that cost over $500 and the car continues to misfire I was told the car was fine by the dealer rusty wallis. I have a service history book of everytime I have ever had any type of service my car has ever had since I purchased it. I do everything that the dealer tells me I'm informed I M supposed to do for the care of my car. I get my book stamped with the seal from rusty wallis every time I get service, even just an oil change. My high beams turn on whenever I use the signal lights. I just replaced my battery and now my A/C will not work. I'm taking my car into rusty to have the latest recall the airbags fixed this Saturday. I have spent thousands of dollars on my car and all work on my car has been at the place I bought it rusty wallis. They have always been good with me, but I really think something is wrong with the engines and fuel/ electrical systems in the Fits 2007. I just don't want to keep spending money on a problem that will never be fixed. I'm afraid that my car is going to stop while I'm on the freeway for an issue I have already paid to have fixed. I have had major tune ups, brakes, transmission and gaskets engine stuff done every time I was informed my car needed it, but the issue is not resolved. I would prefer an impartial entity review the situation and give me the findings, because I feel like I'm spending money and the issues still persist. I have paid for most things on my credit card for a track record of the years. My car is only 9 yrs old. Rusty wallis has been good with me, I think the defects are factory made from Honda. I would like to know is this stuff just happening my car or are others having these issues too.

- Mesquite, TX, USA

problem #12

Feb 042016

Fit

  • 1 miles
This car stalls if driven in cold weather when engine is still cold. When shifted into neutral (manual transmission), say, approaching a traffic light, the engine shuts off, generally when car is still in motion. This has happened at speeds ranging near stopped to 45 mph. It has been happening for about a year, mostly in colder weather. Stalling does not create an error in the computer log, so it looks like it's not happening when taken in for repair. Same exact as previous complaint!!! not safe!!!

- Portage, WI, USA

problem #11

Oct 302015

Fit

  • 33,000 miles

A D V E R T I S E M E N T S

October 30, 2015 10:30am. I was in the parking lot and need to back my up about 100 feet. I put my foot on the brake, started the vehicle, I put the car in reverse, removed my foot from the brake, did not put my foot on the gas pedal, the car began to move in reverse, I had my foot on the brake with light pressure to slow the vehicle speed, after a few second the engine unexpectedly revved and accelerated, I pressed on the brake firmly, engine continued to rev, I placed shift into neutral, the engine continued to rev, I pressed on the gas pedal quickly released it, the RPM fell to normal operating idle. A about two week earlier I was driving at about 40mph in straight direction on a 4 lane divided city street under dry conditions and the engine accelerated. I was startled and instinctively pressed the brake hard. Realizing this was not going to slow the problem I shifted to neutral. The RPM fell to normal operating idle. I do not remember if I pressed the accelerator when the vehicle was in neutral. I finished my drive of about 2 miles to my home. I am the original owner. The vehicle has been driven 33,000 miles. I have not contacted the manufacturer or the dealer as of this writing.

- Bradenton, FL, USA

problem #10

Oct 252015

Fit

  • 107,500 miles
This car stalls if driven in cold weather when engine is still cold. When shifted into neutral (manual transmission), say, approaching a traffic light, the engine shuts off, generally when car is still in motion. This has happened at speeds ranging near stopped to 45 mph. It has been happening for about a year, mostly in colder weather. Stalling does not create an error in the computer log, so it looks like it's not happening when taken in for repair.

- Monmouth Junction, NJ, USA

problem #9

Sep 152014

Fit

  • 84,000 miles
The contact owns a 2007 Honda Fit. The contact stated that the check engine light illuminated. The vehicle was taken to a mechanic who stated that the spark plug was loose. The mechanic tightened the spark plug, but the engine light illuminated again six months later. The contact brought the vehicle back to the dealer and the mechanic stated that the spark plug had completely fallen out of its normal hole and that a heli-coil would need to be installed. The vehicle was repaired again. Two months later, while driving 55 mph, the contact heard a loud bang and noticed smoke around the vehicle. The vehicle was towed to the mechanic again. The mechanic could not re repair the spark plug and stated that a new cylinder head was needed. The manufacturer was made aware of the failure. The vehicle was not repaired. The failure mileage was 84,000.

- Haverhill , MA, USA

problem #8

Aug 022014

Fit

  • 140,000 miles

A D V E R T I S E M E N T S

Honda Fit sport :engine warning light stays on for weeks then turns off unexpectedly then back on again since about August 2014. I completed the 120,000 mile recommended service at the Honda dealership near where I was at the time but the engine light came back on then off again intermittently regardless of the service. Not sure if it is related to the engine surge I am worried about now (March 2015) accompanied by my paddle shifters not working while in D mode. I experienced this when accelerating at 20mph and again at 35mph my engine had high rpms the engine sounded like it surged and made a thud as though the engine would fall out of my car. I was really nervous to continue driving in stop and go traffic as each time I accelerated it happened again at 20 mph. At my destination for two hours I then drove home with some hills and winding roads and put my car in S mode to see if paddle shifters would work or reset in some manner, which it did start working. The surging ceased to happen in S mode so I decided to shift into D mode to see if paddle shifters would work properly and they did as I continued to drive home forty minutes. The orange engine light is still on and paddle shifters seem to be working in both S and D mode now wondering what to get checked out. Since I spent all that money on the major service and was told the car should work well for the next 150,000 it's now near 148,000 miles I want to know whether I can count on the paddle shifters or if they will fail me again. The engine warning light usually turns off once I get an oil change and reset it has remained on. I don't know if a diagnostic will reveal anything or if I should just get the paddle shifters checked. I use the paddle shifters a great deal while in D mode over the past eight years I have owned the car since I bought it new I am the original owner and only person driving the vehicle.

- Oceano, CA, USA

problem #7

Jul 012014

Fit

  • 72,000 miles
My engine coils were misfiring and the car shuddered. I had the coil that was misfiring replaced, however now a second coil is misfiring.

- Oviedo, FL, USA

problem #6

Dec 012011

Fit

  • 100,000 miles
Since around 100 K miles, my car's check engine light has been flickering or staying on and then going off on its own after a cold start. Sometimes the light flickers upon driving before warm, once the gas is let up, the light either stops flickering, or continues to flicker and then remains on for a few days, then goes off on its own. Every time the car has been taken in to have the code read, it's a misfire on a specific coil. I had one coil replaced, and this fixed the problem (or not, because soon after, the weather warmed and this problem does not occur in warmer weather). This problem has occurred for at least the last 3 winters, maybe 4. I just had all 4 coil packs and all spark plugs replaced. This fixed the problem for about a week, and the cel flickered and eventually remained on. This is common problem with this model of Fit, and it seems that not even Honda dealerships can remedy the issue. The car now has approximately 150 K miles, and there are absolutely no other major issues. Routine maintenance has been kept up on the vehicle, and my mechanic has checked for hose leaks, etc. He suggested using a fuel injector cleaner, which also helped the issue very temporarily. The only problem that has been remedied with the spark/coil pack replacement is that the car no longer stutters during highway driving (at 50-70 mph, the car seemed as though it was about to stall - this problem was remedied by using spark plugs with a shorter distance on the diode, there has been no difference after the coil pack replacement, and the last time the codes were read, all coils were randomly putting out misfire codes).

- Exeter, RI, USA

problem #5

Nov 012010

Fit 4-cyl

  • 92,000 miles
Recurring engine misfire causing, rattling, slowing down, panel light out, engine shut off.

- Garden City Park, NY, USA

problem #4

Dec 032012

Fit 4-cyl

  • 84,000 miles

A D V E R T I S E M E N T S

On cold mornings (<~50 F) the vehicle starts fine but has a rough idle. When stopping at a stop sign ~1/4 mile from my home the car will lose engine power and sometimes stall (once in the middle of a oncoming traffic). Once the cold engine light goes away (after a few minutes of driving) the stalling/lose of power goes away. There is no check engine light after stalling and the car produces no diagnostic codes.

- Havre De Grace, MD, USA

problem #3

Apr 252013

Fit

  • 86,000 miles
The vehicle would stall when comes to a complete stop - this has happened at numerous occasion. A lot of other same vehicle owners have confirmed this as well (this started at around 45K miles). Also, the engine would give a vibrating noise now when the car is started. All oil changes and maintenance were done according to the user manual but these issue still arise from normal light driving condition.

- San Gabriel, CA, USA

problem #2

Feb 082011

Fit 4-cyl

  • 36,000 miles
2007 Honda Fit base with manual transmission in Florida, the problem first appeared after the the vehicle reached the 30,000-35,000 mile mark and continues to this day. When the ambient temperature is less than 75 degrees F and the engine has not reached normal operating temperature the engine will stall every time the clutch pedal is depressed, this behavior continues until the vehicle reaches normal operating temperature. My vehicle has been to several Honda dealerships over the past 2 years to diagnose the problem but they were unable to determine the cause as no diagnostic trouble codes are registered. It makes it difficult to safely merge with traffic as the engine stalls whenever the clutch pedal is depressed.

- Titusville, FL, USA

problem #1

Dec 192011

Fit 4-cyl

  • 35,000 miles
Accelerated out of an intersection, from a stop at a stop sign, car lost power, steering...coasted across intersection to a stop. Called for a tow. While waiting, attempted to start car-it started. Drove home and had it towed to dealer, examined for several days, could not find a problem to fix. Same problem just occurred while car was in motion driving at approximately 30 miles per hour. Car suddenly lost steering/power. Got car to side of road. Again, it restarted on its own after a few minutes. Weather conditions cold and dry.

- Devon, PA, USA

Not what you are looking for?