Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety. Notes: The 2014 Jeep Cherokee shows an early trend of transmission complaints. Most of the complaints are for rough shifting — things like jerking & hesitation when shifting gears.

We are keeping an eye on things but the 2014 Cherokee doesn't look like a good model year compared to past years.


really awful
Crashes / Fires:
2 / 3
Injuries / Deaths:
1 / 0
Average Mileage:
14,401 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2014 Jeep Cherokee engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2014 Jeep Cherokee:

Unsubscribe any time. We don't sell/share your email.

2014 Jeep Cherokee Owner Comments (Page 7 of 9)

« Read the previous 20 complaints

problem #51

Mar 062014


  • 3,616 miles


Vehicle has been taken to dealer for same issue 4 times. The information reflected indicates the first time that we brought the care in. Initially we took the care in because vehicle was shifting roughly and would sometimes delay before engaging gear when pressing accelerator. After vehicle reprogrammed and returned to customer it was being driven on freeway at normal speeds when the check transmission light came on, told driver to pull over and the vehicle lost ability to accelerate. Vehicle coasted to side of freeway and was towed to dealer who attempted to fix vehicle. Vehicle returned to customer, a short time later vehicle had same issue on freeway. Again towed to dealer who again attempted to repair vehicle and replaced transmission. A couple of months later while driving on the freeway again vehicle exhibited same exact behavior. Was towed to dealer awaiting resolution of issue. This problem represents a significant safety hazard. Review of similar incidents on this website as well as other websites indicates this is a widespread problem that tends to occur at high rates of speed when a complete loss of vehicle power is dangerous to both those driving the affected vehicle and those on the road.

- Niantic , CT, USA

problem #50

Nov 172014


  • 7,350 miles
On my way to work one morning, I was driving on a three-lane highway, going roughly 73 mph when suddenly, as I was attempting to maintain my current speed ┐consistent with traffic flow ┐my vehicle would not enable me to accelerate. During my inability to accelerate, my vehicles electrical system surged, illuminating my check engine light, traction control light, and cabin lights. As a result, in order to remain uninjured, I crossed three lanes of moderately congested traffic, and turned my vehicle off for approximately 5-7 mins. Upon starting my car, I was able to accelerate; however, both lights were lit on my dashboard. After driving 130 plus miles, I immediately drove to the dealership I purchased my vehicle from┐┐they conducted tests; resulting in a computer glitch. The dealership addressed this by clearing the transmission control module. This answer was very unsatisfactory to me as I purchased this vehicle brand new in June 2014 with less than 100 miles. Therefore, I contacted the manufacture and sought assistance. Since, I have been asked to make an appointment with 2 different dealerships, totaling 4 service visits ┐all inclusive. Over all, I am extremely upset and unsatisfied. Buying a new vehicle with transmission issues and or computer issues is not ideal or expected. Now, I am slightly paranoid every time I drive my vehicle ┐hoping I will be alive to retell both the dealership and manufacture this problem has been duplicated.

- Saint Albans, WV, USA

problem #49

Dec 102014


  • 10,720 miles
I was traveling on the freeway during rush hour traffic in the left lane, traffic was stop and go. Traffic slowed down, once traffic started moving again I stepped on the gas but the car would not accelerate, it would not respond at all. I looked at the dash board and a service transmission message appeared on the screen. I also had a (P)! light on but the parking brake was not on. I tried turning the car off and turning it back on and the car jerked very strongly because I was in traffic I thought someone had hit me but it was my car that had shaken very violently. I put it in neutral it roll just a bit and then would not move the car would not move at all. Chp had to tow me off the freeway. After a day at the dealer, we were told it was a bad connection between the computer and the transmission and that the car was now fixed. I was lucky no one hit me while I was stuck in the middle of the freeway and that my kids were not in the car. I drive on the freeway all the time, the car is less than a year old and I am very afraid to drive this car. After reading other similar cases I feel this is a major safety issue with this type of car and that someone (ntsb) should review transmission issues with these cars further.

- La Mirada, CA, USA

problem #48

Dec 112014


  • 6,000 miles


While driving down the interstate at 70 mph the electronic transmission disengaged and the vehicle started decelerating to a stop.. luckily the traffic was light and I was able to pull off to the shoulder before coming to a stop. The vehicle did not roll, it started slowing as if braking., I was lucky to not be rear ended, there was no for warning and probably no brake lights. I feel the vehicle is unsafe to drive and want to know why it just shut down at 70 miles per hour, it may have resulted in a serious accident if the traffic hadn't been so light. Articles on the internet indicate the launch of the vehicle was delayed by transmission faults. I believe it was put into production faulty. Please investigate.

- Knoxville, TN, USA

problem #47

Dec 032014

Cherokee 6-cyl

  • 12,380 miles
Again, I just got back the car from the dealership at around 4pm (12/3). The work order says that they have changed/replaced the adaption part of the car to re-learn to drive. So, I drove it home. Around 510pm, in the middle of the rain the car stopped again. Luckily again, that im not in the freeway.the same thing, the car stopped and the dashboard gave me a message to shift gear and the car started to shake/jitter. I called the tow truck and they towed it again to the glendale dealership. This is the 4th time that it happen, with the same problem. I am risking my life and my family's life. Please help!

- Monterey Park, CA, USA

problem #46

Nov 252014


  • 12,380 miles
This is the 3rd time it happened. My previous ODI # 16038484. While driving out of the parking lot the car just stopped and the car screen has a message to shift the gear. I did that and the car shakes/jitter. The parking attendant helped me to push the car on the side.

- Monterey Park, CA, USA

problem #45

Oct 302014

Cherokee 4-cyl

  • 1,500 miles


While driving, when I take my foot off the gas pedal in order to coast, the car will accelerate. While driving, when I take my foot off the gas and begin to brake, my car will accelerate. This has been happening since I purchased the vehicle on Oct 30, 2014. It was a minimal occurrence and would come and go, but now it occurs every single time I drive the car. This daily issue where my vehicle accelerates when it should not has been going on since approximately mid-late November 2014.

- Johns Island, SC, USA

problem #44

Nov 132014

Cherokee 4-cyl

  • 8,500 miles
Second incident for this car. First incident was 10.18.14. I was parking car at a restaurant. While edging near ending point of parking space, park sense suddenly disabled and would not enable. Immediately therefore, a series of icons appeared on the dashboard in this order: 1) red lightening bolt for the etc, 2) front end collision light like I had a wreck, 3) engine light, 4) traction light. The power steering appeared very stiff. Car was still running. Drove car out of parking space and it would not accelerate; it moved at a very slow pace like it was stuck in molasses or quick sand. Placed car in park and turned off ignition. While shifting from D to P, the shift was so violent it shook the entire car and I could hear grinding. Let car rest for 60-90 seconds. Turned car back on and only the engine light remained lit. Power steering was not stiff. Drove car to dealership the next morning.

- Broken Arrow, OK, USA

problem #43

Jul 012014


  • 200 miles
Sorry I'm not sure why it does this... when I'm driving sometimes and I take my foot off the gas to slow down.. for some reason my car on it own.. speeds up.. I watch the RPM and there is a big jump in rev.. I'm not sure what that is.. I actually lurch forward. I'm scared that one day it's going to hit a person or go through the wall of my garage! the second thing is my light switch I am not sure why but twice it's pushed into my dash board...the first time it happened I was stuck at dusk.. couldn't drive.. my normal dealership in North seattle called the dwayne lane in everett and they told my dealership that they won't do warranty work.. so my dealership had to send out a guy from service and drive all the way to everett to do a temporary fix... the third complaint.. now at 9500 miles there's a leak in my engine coolant.. and it left me stranded in everett and had to be towed.. by the way tried to go to the everett dealership dwayne lane and again they wouldn't help me this time.. I had no ride home and they wouldn't provide a rental car.. even though I paid for a very expensive extended warranty. I had the car towed the next day to marysville Jeep dealership and they are wonderful! don't buy from dwayne lane in everett!!!! the service department is the worst in the country. I've heard many horror stories from clients.. to tow truck drivers.. to other dealers.

- Marysville, WA, USA

problem #42

Oct 242014


  • 1,450 miles
At a highway cruising speed, when the gas pedal is released and the car is allowed to decelerate itself without pressing the brake, at certain downshifts the car will experience a jump in engine RPM of 1000 and the car will lurch forward and accelerate on its own. This is especially dangerous when going around curves or if there were ice on the road or the car were hydroplaning. Chrysler Jeep has not released a fix or a recall for this issue and it is being said that it is normal for the transmission to do this. I believe it is a dangerous condition with high potential for accidents unless fixed.

- West Columbia, SC, USA

problem #41

Nov 192014

Cherokee 4WD 4-cyl

  • 7,490 miles


I received a phone call from my wife who was on her way home from work at approximately 1825hrs. She went on to explain to me that her vehicle was "acting" up again with all the same symptoms as last time (first incident has already been submitted under same information). She lost a significant amount of power while traveling on a busy highway where the speed posted is 65mph. When this happened she pulled off to shoulder and took photographs with her iphone to keep for our records and to what her dash was displaying. She stopped while on the shoulder and put the vehicle in park and turned off the ignition. After some time she turned the ignition on and put the vehicle in drive when she noticed the vehicle "jerked" and made a loud clunky noise. This is the second incident. The first incident dealership was unable to find any problems under the diagnostics they ran.

- Hemet, CA, USA

problem #40

Nov 032014

Cherokee 4-cyl

  • 6,400 miles
On the above date while traveling to work my wife called me and informed that her vehicle had lost power during operation on a busy highway. Upon further explanation she informed me while accelerating to the proper speed for the posted speed limit of 55mph the vehicle had lost power and the "service transmission" light illuminated. She then pulled off the busy road to a safe a spot and proceeded to contact our insurance and the local Jeep/Chrysler dealership, as we are currently under warranty. Once I arrived to my wife's location we waited for the tow truck and upon his arrival he asked if the vehicle could be driven, at this time I turned on the vehicle and placed it in drive, the "service transmission" light was still on. I was able to drive in approximately 3 miles to the dealership all awhile being followed by the tow truck and without incident.

- Hemet, CA, USA

problem #39

Oct 312014

Cherokee 4WD 6-cyl

  • 12,630 miles
The car is only 5 months old. Has a zf 9 speed automatic transmission and 3.2L 46 24V -vvt engine. I was driving on a tollway in moderate traffic at a speed of approximately 60-65 mph. Without slowing down or changing speed, the display on the dash listed "service transmission". all power to the engine was lost and car began to slow down. Would not respond to acceleration. Check engine light, stability control light, P! were all displayed. Had to find a way to the shoulder and stop car. Turned off car and restarted it. "check transmission " was displayed. Put it in drive and it felt like it was starting in 2nd or 3rd gear. Would not shift gears. Could get up to 35 mph with the tach at 2000 RPM. Would not shift at all. Got home and let car sit for a few hours. Started car after sitting for a few hours and the "service transmission" was gone. All other warning lights were gone except for service engine light. Drove to dealer next day and car appeared to shift ok. Dealer loaded PCM flash update. Reprogrammed tcm per tsb 21-018-14. Reprogrammed rf hub per 08-077-14. Car appears to be driving ok. Dealer said they couldn't find any problems with the transmission. They treated this very lightly. I feel this is a significant safety issue. Lost all acceleration and control at high speed. No notification of updates were sent previously.

- Chicago, IL, USA

problem #38

Jul 232014


  • 4,500 miles
When decelerating for a speed zone, the transmission downshifted from 5th to 4th, the rpms went up approximately 1000 and the car accelerated. The 'unintended' acceleration characteristic is also evident on downhill driving in the mountainous terrain. This occurs or a frequent basis and was evident prior to, and after, a transmission/tcm replacement. My wife no longer feels safe driving this vehicle and has gone back to using her Subaru for commuting. There are obvious issues with the engine/transmission control firmware/hardware which need to be addressed.

- Weaverville, CA, USA

problem #37

Oct 032014

Cherokee 4-cyl

  • 6,900 miles
At freeway speed of 65, the vehicle suddenly had no power, went into neutral, and "service transmission" warning came on. Upon trying to accelerate to pull to the shoulder, the engine would simply rev rpms but provided no power, even after trying to shift between neutral and drive. After getting to the side of the road, the vehicle was shut off and turned back on, at which time the service transmission light was still on, but the vehicle worked again. The dealer replaced the entire transmission under warranty but provided no explanation of why it suddenly lost all power on the freeway and could have easily caused a wreck when trying to get over several lanes on a busy freeway.

- Anaheim, CA, USA

problem #36

Oct 182014

Cherokee 4-cyl

  • 7,500 miles
While parking the vehicle, the parksense feature disabled on its own. Immediately thereafter, the red lightning bolt indicator light appeared on the dash, which has been known to be associated with the electronic throttle control, glow plugs, swirl motor failure (low pressure in rail or fuel rail pressure malfunction) and also speed sensors. The vehicle then revved up on its own without acceleration while my foot was positioned firmly on the brake pedal. Immediately following that, the word "transmission" appeared on the dash, then the check engine light, then the collision indicator as if a car crash had occurred, which it had not. Finally, the power steering became very stiff. Drove the vehicle to the dealership it was purchased from and they said the codes were unknown like hieroglyphics. Left vehicle there. The following Monday the dealership informed me there were 3 software upgrades that were needed on the vehicle, however, those upgrades did not correct the problem. Technician also informed me the car was not safe to drive and they didn't feel safe driving it themselves and got off of the highway during a test run. The technician further explained the vehicle had 3 test runs and failed all 3 and it was beyond their expertise so Chrysler engineers would be consulted this week. Lastly, the technician informed me I "may be ahead of a recall issue." The car is 5 and half months old. I ordered the car, meaning, I had it made/built from the manufacturer. It was not a car purchased from the lot. Therefore, no other drivers of the car and it is brand new. It is a safety concern, especially since the Cherokee has been out of production for many years until the 2014 release. As a side note, I remember an incident that occurred the week prior when the vehicle had difficulty shifting gears (automatic transmission). Instead it stalled and revved on its own.

- Broken Arrow, OK, USA

problem #35

Jul 152014


  • 13 miles
When accelerating from a stop, between 13-20 mph just before the transmission shifts into the next gear the whole vehicle shimmies or wobbles for a few seconds. It happens every time, whether under hard or soft acceleration. It is also more noticeable when turning right. The passenger is even able to feel the shimmy, so it does not only transfer through the pedals or steering wheel. Axles have been replaced, software has been updated, but at this point in time there is no known fix for the vehicle.

- Le Roy, NY, USA

problem #34

Oct 022014

Cherokee 6-cyl

  • miles
The vehicle stopped and engine was dead while driving on the freeway. It is the third time within a month, one week after the second time repaired at the dealership.

- San Dimas, CA, USA

problem #33

Aug 282014

Cherokee 4WD 4-cyl

  • 1,583 miles
Car stalled 6X with my 4 and 5 year olds in the vehicle. Smoke billows out of back of car. Ignition coil, spark plugs, filter and oil replaced. 9/2/14 car shifting incorrectly. Computer system reset due to transmission issues. Customer told to bring back after drives 500 miles for oil consumption test. 9/29/14 oil consumption test failed. Pvc intake valve replaced. Dealer to drive car 250 miles and test oil consumption again. As of 10/3, no resolution. Customer has requested replacement from manufacturer. Not approved as of yet.

- Westfield, NJ, USA

problem #32

Aug 202014

Cherokee 6-cyl

  • miles
Driving at 70 miles per hour, vehicle suddenly stop accelerate, all lights came on dash, read service transmission.

- San Dimas , CA, USA

Read the next 20 complaints »

Not what you are looking for?