Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 1
Injuries / Deaths:
0 / 0
Average Mileage:
55,622 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2011 Jeep Liberty engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2011 Jeep Liberty:

Unsubscribe any time. We don't sell/share your email.

2011 Jeep Liberty Owner Comments

problem #10

Aug 062016


  • 39,700 miles


Own 2011 Jeep Liberty, problem is thetipm dash lights on, are ABS, traction control, air bag, check engine, brakes, seatbelt, speedometer. At first they re flashed it and up dated software, which ended up being 3 times, at no charge obviously they know theres a problem, now they said need to replace tipm 1100 $ to replace ( so much for no charge )after replacement, now they say the ABS module is bad unother 600$,did they cause that problem from re-flashing 3 times, did re-seach there are thousands @ thousands upon thousand of complaints

- Ravenna, OH, USA

problem #9

Jan 182016


  • 55,000 miles
Driving on highway, began hearing a high pitched humming noise, began smelling a burning rubber smell, pulled over to side of highway, and smoke began coming from under the hood. Within 10 mins, the front end of the vehicle was completely engulfed in flames. Have owned vehicle for a year and a half, and have had no issues prior to this incident. Car seemed to be functioning normally prior to this incident.

- Baltimore, MD, USA

problem #8

Aug 062015


  • 230,000 miles
The engine was maintained with periodic synthetic oil & filter changes. The engine ran flawlessly. The plugs and wires were premium. The engine began to vibrate when the key was turned. This occurred after shopping on the way home. There was no loss of power or other anomaly prior to this catastrophic failure. The shop I brought it to tested the computer and fuel pump all ok. There are numerous complaints and engine re-manufacturers are posting comments that the engine design is flawed.

- East Wakefield, NH, USA

problem #7

Sep 152014

Liberty 4WD 6-cyl

  • 47,022 miles


I was driving out of my neighborhood and my car just shut off. I had to turn the key off, put it in park and restart it.

- Chesapeake, VA, USA

problem #6

Feb 102014

Liberty 6-cyl

  • 55,000 miles
Drove all over town and to and from work without incident or indication that something is wrong. I parked the Liberty for about 15 minutes before restating. I turned the key and the engine turned over but was loud noise and was shaking as if was struggling for fuel ( 1/2 tank by the way). Tried starting her up and just kept shutting off. Had her towed to authorized Jeep dealer service shop. Can't seem to diagnose the problem they say it might be a misfire in cylinder # or a broken valve. Jeeps been into shop numerous times to fix TPMS they've change the controls but still vic says check TPMS.

- Valley Stream, NY, USA

problem #5

Jan 102014

Liberty 4-cyl

  • 47,000 miles
I purchased my Jeep Liberty on 1/7/14 and in the first 3 days the car began to stall while driving. It first happened going at slower speeds (15-20mph) and then happened to me going down a busy road at over 45 mph. The engine completely turns off and power steering fails. Luckily I did not cause any accidents. I immediately contacted the dealer (carmax in orlando fl) and notified them of the issue. I brought my Jeep in for repairs and multiple repairs were done to the engine, suspension etc. I picked up my Jeep up on 1/22/14 and was told all repairs needed had been taken care of. I began my commute to work and got there safely. When I went to lunch on my break once again at a red light my Jeep stalled. And then again another.5 mi down the road going at approx. 20 mph. I would like to know what is the concern that is being addressed with this problem that multiple people are having with their vehicles. So at least I can tell my mechanic what I would liked fixed when it goes back into the maintenance dept. Please help.

- Orlando, FL, USA

problem #4

Nov 122012


  • miles


The contact owns a 2011 Jeep Liberty 4X4. The contact stated that the engine warning indicator illuminated continuously. The vehicle was taken to an authorized dealer for diagnosis. The technician was unable to diagnose the problem. The manufacturer was not notified of the defect. The failure mileage and VIN were unavailable. Kmj

- Pine Bush , NY, USA

problem #3

May 312013

Liberty 6-cyl

  • 52,000 miles
The contact owns a 2011 Jeep Liberty. The contact stated that coolant was leaking onto the driver's side floorboard area. The vehicle was taken to the dealer. The technician diagnosed that the heater core was defective and needed to be replaced. The manufacturer was made aware of the failure. The vehicle was not repaired. The failure mileage was 52,000 and the current mileage was 52,600.

- Champaign, IL, USA

problem #2

Oct 302012

Liberty 6-cyl

  • 18,500 miles
This has happened multiple times since I bought the car. I have taken to dealer multiple time advised computer says ok and they cant find a problem. First, time happened as pulling out into traffic crossing 6 lanes and engine power died..foot still on accelerator and engine and power on but RPM drop to 0 and car wont move..large 18 wheel semi slammed on brakes as I sat helpless in the middle of lanes unable to move and came to a stop 2 inches from my door. After reapplying foot to accelerator car moved and I drove straight to dealer advised everything fine and nothing they could do.....incidents sometimes only happen once every 3-6 weeks.after a few more incidents of same problem took to dealer advised same unable to find problem..last time they said they changed a few computer chips...for about 6 weeks thought and prayed problem fixed...however, this past week on way to work sitting at idle in double turn lane in one of busiest/largest intersections the arrow light turned green I started to accelerate and RPM dropped and car wouldn't move..I pushed foot all the way to ground multiple times and car would not respond. However, power and engine on. This time I was desperate as cars were honking at me and racing around me almost hitting me. I even tried to put car in park and hit accelerator and no RPM engine response...trying not to panic, I decided to risk shutting car off. I turned key and shut off engine and turned key and restarted engine put in drive and car went back to normal..with work I cannot afford to keep sitting at a dealer with a car only 1 year old. Try dealer again. 1 other episode when someone in car with me as I accelerated car sputtered and clunked and I had to release and apply to accelerator and then went to normal..I am only blessed with an angel that this car has not yet killed me or someone else.

- Tamarac, FL, USA

problem #1

Jun 252012

Liberty 4WD

  • 12,000 miles
No matter what speed (40-75mph), when vehicle is in 4th gear, the power train shutters. Dealer acknowledges something is wrong but doesn't know what to change...they are now talking to me like its road noise...which is completely wrong. If driving it and it is shutters you can shift into neutral and it goes away....its a definite problem with the transmission/drive train.

- Orrick, MO, USA

Not what you are looking for?