Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


fairly significant
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
18,438 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2014 Mazda CX-5 engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2014 Mazda CX-5:

Unsubscribe any time. We don't sell/share your email.

2014 Mazda CX-5 Owner Comments

problem #7

Dec 042014

CX-5 4-cyl

  • 33,000 miles


Bought a 2014 Mazda Cx-5 back in November 2013.up until December 2014 and 33K miles, no issues. Second week of December, was entering the highway and decided to accelerate a bit, got up to about 80 mph and let off the gas.that's when all of a sudden the engine light, traction light and TPMS came lost power but was able to pull off to the side of the highway.sounded like it was running on 3 cylinders, pushing the gas pedal, car wouldn't go. Shut the car off and on and performed like normal.took it the dealer to have checked out.they couldn't replicate the issue and says it was my K&N filter I had, which is false since I've had the filter for the last 20K miles on the car and another 30K on my 2012 Mazda 3.let it go then the following did it again and but this time it happened twice in a row and the engine light stayed the code of P0301 which is a cylinder 1 misfire issue.take it back again and they keep for almost 3 weeks. They finally got the car to do shut off. Replaced fuel injector with no luck.ended up replacing the crank pulley and belts and say it's working.they also replaced the battery because they said it died and had a bad cell.pick the car on a Tuesday evening and sure Friday morning did it again!! already called Mazda customer support and got a case number set up. Dealer "says" Mazda wanted me to take a tech out to replicate problem, which they can, why they want me too, I have no clue. Sure enough the day I take it to the dealer, it did again on my way there. Tech scans the car, sees the same codes and prints them out. Couldn't get the car to shut off again, so I wait. The following week, call Mazda customer support and say the dealer said no codes were found, bullcrap!! complained to the dealer service manager and he "says" that Mazda knows the problem, software related but no release date. I'm done and fed with Mazda and the dealer.

- Burlington, KY, USA

problem #6

Nov 192014

CX-5 4-cyl

  • 27,060 miles
I approached a traffic light, early in the morning on Nov 17, 2014; and just slowed my speed to turn right (did not make a complete stop) when I tried to accelerate my car, speed did not respond and was stuck between 10 to 30 mph. The engine was making a horrible noise, the tachometer was going crazy, got scared, so I pulled to the side of the road and shift gear to P, waited a minute and shift back to D, but car did not respond. Drove about a mile and decided to pull out and turn off my car for a few minutes an restarted fine. I took my car to the dealer the same day. They kept it for two days and said there was nothing wrong. On Feb 13, 2015 had the same problem again, but this time I was at a red light, when tried to accelerate, car did not respond stuck at 25 to 30 mph. I had to make a U turn, to be able to get to a parking lot. I parked and turned off engine, restarted the car and worked fine. I took my car to the dealer again, they kept it a few days and said there is nothing wrong. I do not feel safe driving my Mazda anymore, I was very lucky I did not have an accident the two times I had this problem! there is definitely something very wrong with the power train of this car.

- Homestead, FL, USA

problem #5

Dec 122014

CX-5 4-cyl

  • 26,800 miles
About an hour into my commute from work, stopped at traffic light. Accelerator didn't respond after several attempts to reach full speed. Maximum speed reached 5-10 mph on a 50 mph road. Several warning lights displayed immediately and was able to safely pull over onto side road. Restarted veh and engine light remained on; accelerator responded normal and was able to get home cautiously. Veh was taken to service next day, advisor explained issue has been alerted on service bulletin. Currently waiting on transmission parts.

- Austin, TX, USA

problem #4

Oct 092014


  • 22,000 miles


Mazda cx 5 AWD atm. I stopped my Mazda cx 5 on the stop light and put the gear neutral. When I switched the gear to drive, it didn't upshifted but stayed on the same gear. It couldn't make more than 30 mph with rmp shooting up very high. I pulled it over, stopped the engine, restarted the engine and the problem was gone.

- Newton, MA, USA

problem #3

Oct 162013


  • 1,000 miles
The contact owns a 2014 Mazda CX5. The contact stated that while driving 5 mph, the vehicle suddenly accelerated without any warnings. The vehicle was taken to the dealer. The technician was unable to diagnose the failure. The manufacturer was made aware of the failure. The vehicle was not repaired. The failure mileage was 1,000 and the current mileage was 1,500.

- Anacortes, WA, USA

problem #2

Feb 102014

CX-5 4-cyl

  • 8,300 miles
I was driving at approximately 20 mph. I gently reduced speed to make a turn and when tried to accelerate again, my new car did not accelerated. I had to fully stop having cars behind in a mayor road. After few seconds it did accelerate but did not pass the 10 mph. The defect was only seen that day and fortunately I could get home at 10 mph. The car was turned on the next day and was working properly. It was taken to the dealer and was found nothing.

- Bayamon, PR, USA

problem #1

Feb 162014

CX-5 4-cyl

  • 10,903 miles
Upon entering the highway a car came up on me very fast, whereupon I floored the gas pedal. The car jetted forward to about 65 mph then suddenly lost all power; like it was functioning on one cylinder. I had to pull over and coast down to my max speed of 5-mph. Even though the pedal was floored I could not get above 1000 rpms and 5-mph. Various warning lights came on, including the tcs and engine lights. All warning lights remained on without flashing. Once I got to a safe place I shut the car down and within one minute restarted it with no sign of a problem. I drove over 100-miles today and nervously had to passe someone, but without problem.

- Longmeadow, MA, USA

Not what you are looking for?