Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
34,276 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2003 Mercedes-Benz C230 electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Mercedes-Benz C230:

Unsubscribe any time. We don't sell/share your email.

2003 Mercedes-Benz C230 Owner Comments

problem #7

Jan 012011


  • 32,879 miles


The contact owns a 2003 Mercedes Benz clk430. The contact stated that the speedometer and radio were defective. He mentioned that the pixels on both were missing. The dealer was contacted who stated that the instrument cluster would need to be replaced. The manufacturer was not made aware of the problem and the vehicle was not repaired. The failure and current mileage was 32,879.

- Bloomfield , NJ, USA

problem #6

May 212009


  • miles
Just like other reports here - electrical malfunction. 50K miles. Took to mb dealer for rough idle at cold start up and low speeds; louder than normal idle at start and in reverse. No check engine light, no error or problem indicated in dash at all. Same diagnosis - dealer reported cam solenoids leaking engine oil into the wiring harness shorting harness components (O2 sensors etc.), high $$$ $3600-$4000 repair. Issue should be resolved and paid for by mb since this is known defect that severely reduces the drive-ability and value of the vehicle.

- San Jose, CA, USA

problem #5

Apr 092008


  • 57,000 miles
Check engine light on, with occasional poor gas mileage, rough running. When engine starts rough, engine stop/re-start gets engine to idle/run properly. Dealer reported cam solenoids leaking engine oil into the wiring harness shorting harness components (O2 sensors etc.), high $$$ repair. First occurrence at 57K miles (just out of warranty). Contacted mb, no concern, too bad for you. Sporadic red led warning about gas cap, blinking indicator in fuel gauge, stop/restart engine, goes away (error not in owners manual). Car still running at 78K miles and usually 35 mpg during normal commute so far (without repair so far, do not have tail pipe emission check in area yet, so not mandated to fix mil light issue), clear ECM codes occasionally, come back after 3 key cycles. Stuck with car that is not worth fixing to have same problem come back. This cam solenoid/wiring harness/O2 sensor/check engine light issue should be resolved and paid for by mb since this is known defect that severely reduces the drivablilty and value of the vehicle.

- Virginia Beach , VA, USA

problem #4

Apr 132009


  • 61,750 miles


Check engine light lead to rough idling and inability to drive vehicle. 2003 Mercedes Benz C230 with 61,650 miles on it. All cam sensors, O2 sensors, maf sensor, engine wiring harness replaced with necessary O-rings at dealer. Car was laid up 5 days and at a cost of $2,500.

- Danbury, CT, USA

problem #3

Dec 172008


  • 70,003 miles
2003 Mercedes C240 stalls immediately after prolonged turnpike travel ( 1.5 hours) at exit ramp to an arterial roadway. This increases rearend accident potential. Mercedes checked vehicle but no report codes indicated. Suggested that it may be computer of sensor related. Mercedes suggested pulling over for 30 min. To let computer reset. First incident 12/17/08 second incident 12/28/08.

- Jupiter, FL, USA

problem #2

Aug 262005

C230 6-cyl

  • Automatic transmission
  • 18,300 miles
My Mercedes-Benz C-240 (2003 model), having less than 18500 miles, suddenly lost power after some 2-hour worth of free-way driving. Around noon on Friday, 8/26/05, I was driving South -bound on I-15 past victorville (ca), about 9 miles past the exit for route 18, when my C-240 suddenly lost power. As I depressed the accelerator, I felt no power and the RPM was decreasing. It felt like the entire engine-transmission system was shutting down. There was no prior warning. I made right turn signal letting other vehicles know I was coming off the free-way. I managed to pull off to the right shoulder safely and came to full stop on the gravel. At that time, my digital odometer read "1 malfunction". using my cell phone, I immediately called the Mercedes hotline. The roadside assistance representative, kristin, advised me not to drive the vehicle, even after the "1 malfunction" sign became "no malfunction" a little later. My vehicle was towed to a Mercedes-Benz dealer in riverside, some 50 miles away. At the dealers service dept, after a basic check involving computer and electronics, some faulty identifications were made, but it was determined to be safe and drivable. I drove my vehicle home, planning to have a major check up later.

- Arcadia, CA, USA

problem #1

Apr 052003

C230 4-cyl

  • miles
Consumer disappointed with her problematic, unreliable and potentially unsafe vehicle. The window seals scratched the glass tint. The radio reception was poor and the keyless entry system only worked at close range. The technician indicated that the tint was likely the cause of the poor reception and inability to use the entry system at further distances. The dealer installed scraper seals to alleviate the scratching. The vehicle shut off five times in a 45 min period and all the service lights illuminated. The vehicle was taken tot he dealer who determined that a cylinder had misfired and water was in the spark plugs. The dealer replaced he cylinder head and all valves. The bas, esp and ABS light illuminated while driving. There was a lack of airflow power when the A/C was used. The vehicle hesitated when accelerating. There was a strong mildew odor coming through the vents. Cd skipped when turning corners. A rattling noise could be heard from the engine while the A/C was on.

- Long Beach, CA, USA

Not what you are looking for?