Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

10.0

really awful
Crashes / Fires:
1 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
48,006 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2010 Mercury Milan drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2010 Mercury Milan:

Unsubscribe any time. We don't sell/share your email.

2010 Mercury Milan Owner Comments (Page 3 of 7)

« Read the previous 20 complaints

problem #90

Sep 022013

Milan

  • 45,000 miles

A D V E R T I S E M E N T S

The car loses power while driving, the wrench light comes on and then I have to pull over to the side of the road, it has also happened on the highway which is scary? also the car sometimes has an idle problem, like its trying not to stall, but causes the car to jump a little while at stop lights. Also when I get gas, the car does not want to start, but if I leave the car running while getting gas the car is fine.

- Olean , NY, USA

problem #89

Oct 112013

Milan 6-cyl

  • 50,125 miles
While driving on a freeway (middle lane) at ~ 50 mph the "wrench" light cane on and the vehicle slowed to 20mph. Very unsafe.

- White Bear Lake, MN, USA

problem #88

Oct 102013

Milan 4-cyl

  • Automatic transmission
  • 45,000 miles
The contact owns a 2010 Mercury Milan. The contact stated while driving 55 mph, the vehicle shook with a jerking motion and shut off. The wrench warning icon and the check engine light simultaneously illuminated when the failure occurred. The vehicle restarted within a minute but operated for an unpredictable time and distance. The contact cleaned the throttle body and started the engine but it shut off again. The vehicle was not taken to the dealer or an independent mechanic. The manufacturer was not made aware of the failure. The failure and current mileage was 45,000. Updated 11/5/13 the consumer purchased the part, and installed it himself. Updated 11/12/13

- Little Lake, MI, USA

problem #87

Oct 102013

Milan 4-cyl

  • 45,500 miles

A D V E R T I S E M E N T S

Driving down rural highway traveling at 58mph and suddenly lost all power and car started bucking. Able to pull off and coast to stop. Rough idling. Wrench light came on when this happened. Turned off car and restarted 5 min later. Wrench light went out. Proceed to drive and approached 58 again incident happened again. Same symptoms but now engine light came on. Turned off car and waited over 15 min. To restart. Restarted and wrench light went out but engine light remained on. Able to drive home on shoulders at speeds not above 40 mph. Called dealership and not covered under drivetrain/emissions standard manufactures warranty. Need to diagnose it in shop at labor rates. No money.

- Little Lake, MI, USA

problem #86

Oct 082013

Milan 4-cyl

  • 40,323 miles
I was driving on a local road. Suddenly the car lost power and the wrench light was on. It could only go very slowly before I parked it on the roadside. I waited for several minutes and started the engine, then everything seemed just fine and the wrench light went off. After the trip I tried to connect obdii code reader but cannot get any error code.

- Syosset, NY, USA

Search CarComplaints.com for these popular complaint phrases...

problem #85

Sep 152013

Milan 4-cyl

  • 35,100 miles
Driving approximately 30 mph, the car coasted to a stop and the wrench showed on the dashboard. Waited a short while, restarted and it was okay. Did notice some lurching and the car felt like it was in the wrong gear, prior to the second incident on 10/07/20. Driving through an intersection at 30 mph, wrench showed on dashboard and car slowed to a crawl. I had to make it through the busy intersection and off ramp from a highway in order to safely get the car off the road. I could have been rear-ended both times, to say nothing about the fear of your car just conking out in the dark at 5:30am. The 3 year/36,000 mile warranty expired May 27, 2013... and my current mileage is 35,581 miles!!!!!!!!!! 111 days over the months and 419 miles under the warranty.... so, I am paying around $300+ to have this fixed. With all the exact complaints as happened to others, I am surprised Ford did not send a notice to owners to get it fixed or face the potential of being involved in a crash... thank you.

- Poughkepsie, NY, USA

problem #84

Sep 182013

Milan 6-cyl

  • 27,600 miles

A D V E R T I S E M E N T S

Just after moving from a stop at a red light, while accelerating, the vehicle began to lose power. As I drifted off the side of the road the "wrench" icon on the dash illuminated, which indicates throttle body issues, among other possible things. I had to stop the vehicle as the vehicle was unable to move under any power, and shut the vehicle off. I re-started it and I was able to continue on my way. The icon was not illuminated. This has since occurred approximately five (5) times since the initial instance. There was never any indication of performance issues prior to this first instance. In researching the occurrence I became aware of the fact that this has been an issue with the throttle bodies on several Ford products manufactured around the same time as my Mercury, and that there is apparently an investigation already in progress.

- Lancaster, PA, USA

problem #83

Sep 132013

Milan

  • 55,000 miles
Driver was proceeding on I-290 in left lane at speed of 60mph with moderate traffic. The engine started misfiring and bucking without warning and the vehicle experienced a drastic reduction of speed nearly causing accident from behind since the speed reduction was without warning. The wrench light illuminated. The engine continued to decelerate and created a situation where driver could not change lanes to right and was forced to move to left shoulder. The engine completely stalled and shut off before car stopped. After 30 minutes, vehicle started and operation resumed. Service department denied any problem with vehicle. 3 weeks later, while traveling 55 mph on NY rte 33, the vehicle stalled again at highway speed. The engine could be restarted but only operated with very rough condition. This vehicle is unfit and unsafe to be operated on a public highway.

- Williamsville, NY, USA

problem #82

Sep 182013

Milan 6-cyl

  • 43,500 miles
Intermittent problem which occurred at variable speeds (25 mph, 40 mph, 60 mph) with rapidly increasing frequency in the week before the throttle body was replaced. While driving, the engine seemed to shift out of gear. However, there was no increase in RPM in response to the accelerator. Pulled to side of road with very low RPM, the vehicle was turned off and then restarted each time without problem.

- Montgomery, AL, USA

problem #81

Sep 212013

Milan 6-cyl

  • 58,500 miles
I was in cincinnati that weekend (3 hours away from home) and as I was pulling into the parking lot of a store, the car jerked very hard and then the wrench showed up on the dash and I lost all power. I was able to coast into a parking space. I then shut off the car and waited a bit and restarted it. The wrench came off the dash and the car was working properly again. We then went about our day and as we were heading back to my nephews football game, we were driving down 4 lanes of traffic and I had just passed a slower moving vehicle when the car jerked abruptly again and I lost all power. I put my turn signal on and was able to turn off a side road. The wrench came on again. It happen the next day as we were attempting to drive back home. We tried to drive the car back home in manual and it worked just fine. I got our car into our local car dealership and they said that it was the throttle body that needed replaced. So after forking out $375, it hasn't done anything since. The reason I'm filing this complaint is that if the throttle body would've acted up while we were traveling through the hilly roads in cincinnati, we would've been in a severe car accident. This problem is a huge concern as you lose all control of the car. You have no gas and the RPM's just quiver on the dash. If I hadn't been able to pull off of the side of the road, we would've been hurt due to a car crash. This concern needs to be sent to Ford/Mercury as this seems to be a huge problem once I researched it. We were fortunate that this didn't happen while we were traveling 70 mph on I-75 in Ohio on our way back. The problem with the throttle body needs to be issued as a recall. It is going to get someone in a very bad accident or killed.

- Defiance, OH, USA

problem #80

Sep 302013

Milan

  • 66,000 miles

A D V E R T I S E M E N T S

The contact owns a 2010 Mercury Milan. The contact stated that the vehicle simultaneously shook, jerked and decelerated to 5 mph as the wrench warning icon illuminated. The vehicle was not taken to the dealer. The manufacturer was not made aware of the failure. The failure and current mileage was 66,000. The VIN was not available.

- Little Rock , AR, USA

problem #79

Sep 122013

Milan 6-cyl

  • 55,650 miles
On 12 September I went to take off from a light and the car had no acceleration, and the wrench light came on in control panel...I was able to coast to the shoulder on other side of intersection and placed the car in park and turned it off. When I turned the car back on it started fine and the light was no longer on. It was about two weeks later on 27 September was driving to work on a 2-lane road going about 45 mph and the car lost all acceleration and the wrench light came back on. There was not much of a shoulder to pull off on but found a spot and placed car in park and turned it off. I smelled a slight burning smell so waited little bit longer than last time and turned the car back on. It started up and the light was no longer on and it drove fine. I took to a mechanic on Saturday morning and told me the diagnostic could not produce a code because the incident could not be replicated but believed it was the throttle body and needed a replacement.

- Aurora, CO, USA

problem #78

Sep 212013

Milan

  • 54,312 miles
Wrench icon appears and engine RPM drops and vehicle slows while unable to accelerate. Engine surges at idle slightly below 1,000 RPM. If vehicle is shutoff and then restarted it will operate for an unpredictable time/distance. Very dangerous to drive due to unpredictability. Vehicle has been driven approximately 140 miles since first shutoff and has shut off numerous time since. On 9/27/13 it shutoff four times in 12 miles. Wife is terrified to operate this car. Vehicle will remain parked because of potential life-threatening safety hazard. Hopefully a recall for this will occur.

- Kinsman, OH, USA

problem #77

Sep 242013

Milan

  • 57,330 miles
My 2010 Mercury Milan premier stalled - check engine came on - I was unable to move forward as it seemed it was trying to move forward but would not - had the code checked and it was P2112 - throttle actuator-control system - stuck closed permanent was the message for this code - was not expecting this at all - was driving perfect and this happened suddenly - my concern is had this happened on an interstate highway - what would I have done" from what I read this is very dangerous - and is there a recall for this safety concern"

- Georgetown, TX, USA

problem #76

Sep 172013

Milan 6-cyl

  • 46,000 miles
7I bought my car with around 20,000 miles on it and experienced jerking, rough idling, and a complete loss of power when driving. I returned it to the dealership a total of 3 times for this issue. I was told it was a transmission issue and they were resetting something that had to do with the computer in the transmission. After the first instance of the car stalling, I googled any issues with my particular vehicle and came upon a throttle body problem. I mentioned this to the dealership on several occasions and was told that this was not a common issue, nor was it the problem with my vehicle. Last week, I was driving to work, my car completely stalled while going 75mph on a 4 lane highway. I was almost rear ended by the semi that was behind me as my car's speed suddenly, and without warning, dropped by over 15mph. I made my way to the right side and slowly coasted up an off ramp to get off the highway (as there was no shoulder). Even if you press the gas, nothing happens. You do not accelerate at all. I turned the car off and restarted it. I drove maybe 5 minutes and it stalled again. I had to restart my car a total of 5 times on the 7 mile drive to work that day and was almost hit by other cars just about every time. I called my personal mechanic and had it towed to him instead of the dealership because I was told that this was a different issue than my previous 3 visits to the dealership and Ford would not be covering it under my warranty. The mechanic replaced the throttle body and my car runs perfectly now. He said when he called around to get a part he had a horrible time even finding one because they are on back order due to this being such a huge issue across the country. I've been telling the dealership for 25,000 miles and almost 2 years this was what was wrong with my car and now its suddenly not covered under my warranty.

- Jefferson City, MO, USA

problem #75

Sep 122013

Milan

  • 33,500 miles
I've experienced several instances of my vehicle stalling while in motion at various speeds (30-65 mph). At the dealership it was determined that the problem is with the throttle & the part is on back order. It is my only means of transportation & cannot get it repaired. Despite the low mileage, I am being told that this is not covered under the manufacturer's warranty. This issue is not due to wear & tear but to a manufacturer's mechanical failure. Why is the consumer responsible for the repairs to a preexisting problem in these cars?

- San Antonio, TX, USA

problem #74

Sep 202013

Milan

  • 74,000 miles
Stop at red light and the car refuse to accelerate. Had to coast to the side of the road. When car is cut off and turn back on it will run for a little while and does the same thing again. Kids in the car on the side of the road. When I first got the car the transmission went out, had it less than 2 wks. Now this is happening, cost over $600 dollars for something that is manufactured screw up. I need my car to get kids to school and work. All these complaints about the same problem needs a recall very quick before someone gets into an accident.

- Chattanooga, TN, USA

problem #73

Aug 242013

Milan 4-cyl

  • miles
2010 Mercury Milan. Consumer writes in regards to sudden deceleration while stepping on gas pedal. The consumer stated even though he was stepping on the gas pedal, the vehicle was shaking and lurching. The vehicle would not move any faster. The vehicle was towed to the dealer, where they replaced the throttle body and reprogrammed the PCM.

- Falls Church, VA, USA

problem #72

Sep 132013

Milan 4-cyl

  • 31,000 miles
Driving at highway speeds vehicle stalls out without warning. When attempting restart engine light and "orange wrench" light turn on. Vehicle does eventually restart.

- National Patk, NJ, USA

problem #71

Sep 152013

Milan 6-cyl

  • 36,340 miles
When leaving a red-light the throttle (gas pedal) did not work. I had to coast to off the road. Turn off the car and re-start. At that time the gas pedal worked.

- Brentwood, TN, USA

Read the next 20 complaints »

Not what you are looking for?