Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


fairly significant
Typical Repair Cost:
Average Mileage:
91,616 miles
Total Complaints:
2 complaints

Most Common Solutions:

  1. not sure (2 reports)
1999 Nissan Altima engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 1999 Nissan Altima:

Unsubscribe any time. We don't sell/share your email.

1999 Nissan Altima Owner Comments

problem #2

Jan 102010

Altima GXE

  • Automatic transmission
  • 80,000 miles


My car started misfiring at first. It got worse and worse. It sounds like my car is trying to catch its breath. It was very frustrating I was told it was spark plugs & distributor needs tune up, changed all plugs battery and everything else that is listed on this site. I just wish I to would have checked online first. I would have saved a lot of time and and money. I hate car problems! Out of all the cars I've had this has been the hardest problem to figure out. I am a single mom, with my job being 20 miles away from home I really depend on this car. Turning it in tomorrow to get it fixed will be car-less for 3 days. I hope replacing the intake manifold gasket will fix the problem! Fingers crossed.

- , El Dorado Hills, CA, USA

problem #1

Sep 012010

Altima XE 2.4L 4 cyl

  • Automatic transmission
  • 103,232 miles

The problem is the car shakes when driving slow 1500-2000rpm. Mr tire tried to get me for $3000 and I did the work myself and the problem still happens. heard it might be my harmonic balancer.?.... I noticed a bad motor mount on front passenger top mount. gonna fix . I hope it solves this crap...

- , Balto, MD, USA

Not what you are looking for?