Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

CarComplaints.com Notes: The 2005 Nissan Altima has two fairly significant problems with the floor pan rusting through & motor mounts breaking.

Altima owners report that up to a basketball-size hole develops under the floor mats where the floor pan metal rusts through. Average repair cost is over $1,000.

The broken motor mounts are less of a problem - they break at ~75,000 miles average & it's $400 to fix. Still, motor mounts should not break!

7.5

pretty bad
Typical Repair Cost:
$75.00
Average Mileage:
86,551 miles
Total Complaints:
13 complaints

Most Common Solutions:

  1. not sure (9 reports)
  2. no heat when idling (2 reports)
  3. replaced coil (1 reports)
  4. see above (1 reports)
2005 Nissan Altima AC / heater problems

AC / heater problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2005 Nissan Altima:

Unsubscribe any time. We don't sell/share your email.

2005 Nissan Altima Owner Comments

problem #13

Oct 082015

Altima 2.5s

  • Automatic transmission
  • 175,000 miles

A D V E R T I S E M E N T S

I bought my 2005 Nissan Altima used with 175,000 miles (terrible mistake). However, I had my mechanic check the car out all together to make sure it was good. One week in I go to use the heat and nothing but air came out. Never got the heat to work in the car. Week later the radiator is busted.

- , Philadelphia, USA

problem #12

Aug 012009

Altima

  • Automatic transmission
  • 99,000 miles

The heat only works when I get up to 2,000 RPM. If I am in traffic, stopped at traffic lights, or idle at all...no heat at all whatsoever. Feels like the AC is on.

- , Spring Hill, TN, USA

problem #11

Jul 302015

Altima 2.5S 2.5L

  • Automatic transmission
  • 83,214 miles

click to see larger images

heat/ac does't work properly

The a/c failed to blow cold air. It was 1:30pm and very hot. I got drenched in my sweat. Took it to garage next morning and by evening car was fixed. He said the coil needed replacement.

- , Dubai, Dubai, United Arab Emirates

problem #10

Dec 122012

Altima ES 4 cyl

  • Automatic transmission
  • 172,000 miles

A D V E R T I S E M E N T S

When I accelerate, the fan blows lukewarm air. When I brake, slow down or idle, the fan blows cool to cold air.

- , Stanhope, NJ, USA

problem #9

Nov 012012

Altima SL 2.5L

  • Automatic transmission
  • 129,783 miles

Heater use to work fine but recently went out. It blows out extremely cold air. When i start my car, it sounds like there is water swooshing around somewhere. There is no leak anywhere and all of the fluids are in the car. Another thing that is happening now is that when i accelerate the vehicle, the cars temperature meter goes all the way up to hot and cools down when i slow down. i do not know if it is related.

- , Las Vegas, NV, USA

problem #8

Jan 012012

Altima

  • Automatic transmission
  • 105,000 miles

I've been told so far it may be the water pump, will find out soon if that's the case or not once I take my car in. It also makes a water "swooshing" sound from inside the car when I take off.

Update from Dec 11, 2012: The auto tech flushed my heating system to make sure nothing was blocking it. Otherwise, it would have came down to changing the heater core due to a possible crack in it. THANKFULLY, flushing it out did the trick and it save me a lot of trouble and money!

- , Huntley, IL, USA

problem #7

Oct 282011

Altima ES

  • Automatic transmission
  • 34,000 miles

A D V E R T I S E M E N T S

JUST NOTICED THIS YEAR THE HEATER WILL NOT WORK WHILE IDLING.

- , Zanesville, OH, USA

problem #6

May 302011

Altima 2.5L

  • Automatic transmission
  • 51,000 miles

returning from a 45 minute road trip the air stopped blowing cold air. checked fuse, freion levels both fine . what caused it ?

- , Cleveland, TN, USA

problem #5

Feb 102011

Altima 2.2L V6

  • Automatic transmission
  • 146,000 miles

No heat when at idle. Heater blows warm air when accelerating.

- , Kansas City, KS, USA

problem #4

Dec 062010

Altima Extra Pkg 2.2L V4

  • Automatic transmission
  • 86,992 miles

NO HEAT WHEN IDLE ONLY WHEN DRIVING CHANGED THERMOSTAT AND FLUSHED RAD NO CHANGE

- , Barrie, Ontario, canada

problem #3

Mar 042008

Altima 2.5L

  • Manual transmission
  • 34,175 miles

A D V E R T I S E M E N T S

when A/C is turned on it is impossible to turn it off unless engine is turned off, pain it the ... dealer won,t help

- , Toronto, Ontario, Canada

problem #2

Jan 012006

Altima SE 4 cyl

  • Automatic transmission
  • 500 miles

Even if the car runs for 20-30 minutes, the windows are still frozen up/foggy on the INSIDE and won't clear up until you have been accelerating approximately 15 minutes.

When the car warms up and the fan blows warm air, if you stop in traffic or at a red light and are no longer accelerating, the air goes cool again.

- , 1825 Ky 225, Barbourville, USA

problem #1

Jun 152005

Altima SE 3.5L V6

  • Automatic transmission
  • 8,500 miles

Well, heating and A/C simply sux on this car. A/C is never cold enough and heating is never warm enough. Went back to the dealer to claim the warranty, and got refused 4 times - tried to fill lemon law claim against them and Nissan Customer Service never helped and nothing happened. After a while my lawyer charged me $400 and did nothing about it. I am suspicious he acted in their favor.

- , Libertyville, IL, USA

Not what you are looking for?