If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

7.2

pretty bad
Typical Repair Cost:
$350.00
Average Mileage:
27,243 miles
Total Complaints:
5 complaints

Most Common Solutions:

  1. not sure (4 reports)
  2. replace brake switch & sub harness (1 reports)
Get free help with your lemon!
close ad
2008 Nissan Altima engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Nissan Altima:

Unsubscribe any time. We don't sell/share your email.

2008 Nissan Altima Owner Comments

problem #5

Mar 092011

Altima

  • Automatic transmission
  • 55,000 miles

A D V E R T I S E M E N T S

I have had my 2008 Nissan Altima for 3 years now of course it is out of warranty but I have had several issues with this model. I bought this as a car that I thought would be dependable and "last for years" as several people have told me. Well it hasn't been very reliable. Luckily I have had people available to come to my rescue. At 40,000 miles my transmission had to be replaced due to a weird noise as accelerating. Also now I have had to have the brake switch replaced which is highly inconvenient due to I could no longer get it started. This has been the most frustrating car that I have ever owned and will never own another nissan after this one is gone. It seems like you fix one thing and something else goes wrong which yes things will happen but 3 years old and 70,000 miles?

- , Little Rock, AR, USA

problem #4

Apr 122011

Altima S 2.5L 4 cyl

  • CVT transmission
  • 43,224 miles

I'm leaving work and go to start my car but it really strains to start but does eventually start. Thinking it was the battery (which I had replaced 6 months prior) I took it back where I bought the battery and it tested bad. They replaced the battery and when I was going to leave it didn't start at all this time. The radio would come on, the horn worked, the windows would roll up/down but just wouldn't start. So....after many different attempts and out of ideas I leave it there and have it towed to the dealer in the morning. 3-4 hours after they received it they finally figured out it was the Brake Switch & Sub Harness which tells the car you are pressing on the brake and starts. My car (since it the switch and harness shorted out) didn't realize I was pressing on the brake so it wouldn't start. Of course I'm out of warranty and it costs $499.57 to replace and Thank God I have towing through insurance or it would have been more!

I really love this car, I love the push button start/unlock doors, I love the CVT transmission and "instant power" but in 3 years this is the 5th time it's been in the shop and 2 of those 5 have been something major. I've very disapointed and hope the car treats me well in the future.

Bryan

- , Burleson, TX, USA

problem #3

Dec 062010

Altima

  • Automatic transmission
  • 16,777 miles

I left my car sitting outside for 3 hours and went to start my car and it barely turned over, I tried to push the button again and then there was no power at all? I finally got the car going and the next morning I had the same problem, barely started. I left the car running and took it into the shop, well there it started no problem and they said that there was no problem? So they recommended that I have the battery winterized which I did and tonight once again when I left the car in a little bit of cold air went to start it and the dash came on and said push brake which I was already doing? I tried the button start again and received the message need key? I already had it? So I took the key out of my purse and put it directly in front of the dash??? The car did start at that point?

- , Calgary, AB, Canada

problem #2

Oct 162009

Altima 2.5L

  • Automatic transmission
  • 6,214 miles

WE MADE A STOP PAYMENT FOR THE LOCATION THIS MONTH BECAUSE IT'S THE 7th TIME THAT THE CAR DON'T START FOR NO REASON. THE DEALER SAYS THAT THE CAR IS OK ???? WE SAW AN OTHER DEALER AND HE SAID THAT HE SAW THE SAME PROBLEM WITH SOME SENTRA TOO BUT HE DON'T KNOW WHAT TO DO BECAUSE NISSAN DIDN'T FIND THE SOLUTION. NISSAN SAID TO ME : NO PROBLEM, 0 COMPLAINTS FOR WHAT WE SAID ???

- , Terrebonne, Quebec, Canada

problem #1

Feb 062010

Altima 2.5A

  • Automatic transmission
  • 15,000 miles

My 08/Nissan/Altima 2.5s will not start this is the 5 time this happen to me w/this car. I had the car tow to the dealer 3 time they had the car for couple of days ,they said it was the starter they change it .I had the car for 2 days it started ok but last night it just wont start . I am sick of this problem . i purchase this car thinking i had made i good choice .I have had the for 1 month and 1week and this is happen. Just Great

Update from Mar 5, 2010: So i Brought back My Nissan to the dealer and they fix the problem..... Which they said it was the starter harness.... The car start without no problem ever time i push the push to start button .... I still have the car but I planning to trade it for something else in 2011......

- , Queens, NY, USA

Not what you are looking for?