If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

8.8

pretty bad
Typical Repair Cost:
$869.00
Average Mileage:
93,118 miles
Total Complaints:
13 complaints

Most Common Solutions:

  1. not sure (6 reports)
  2. dealer can't duplicate my problems (3 reports)
  3. replaced main module (3 reports)
  4. rebuild cable (1 reports)
2002 Pontiac Aztek electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2002 Pontiac Aztek:

Unsubscribe any time. We don't sell/share your email.

2002 Pontiac Aztek Owner Comments

problem #13

Jun 012012

Aztek Aztek 3.2lV6

  • Automatic transmission
  • 420,000 miles

A D V E R T I S E M E N T S

Pontiac Aztek 2002, when the weather gets warmer the car will randomly not start. The ABS light, Brake light, security light, radio will shut off. The vehicle will not start for 20-30 minutes & then will start up again. Have replaced fuse block, switch key Vincut key, replaced ECM Module & reprogram, replaced the BCM module twice, reprogrammed the security system twice, replaced the mass air flow sensor, greased the ground wires, grease on terminals fuse block. I have spent over 1,700.00 on this vehicle. I have gone to 2 mechanic shops & one was a GMC dealership. The Pontiac Aztek 2002 is still not fixed.

- , Princeton, MN, USA

problem #12

Oct 292004

Aztek 3.4L V6

  • Automatic transmission
  • 44,694 miles

GM in there infinite wisdom routed the wire harness for the dashboard against the mount for the anti-lock brake cylinder. Over time the mount sawed through the cable till it hit a power wire which shorted out the car. No radio, car would not start, all while it is pouring ass rain and cold. Of course I am in traffic on an entry ramp to I-55. But I was not alone folks. I had three police cars for company. One officer was kind enough to inform me that I could not stay there as I was blocking the ramp and traffic was heavy. The police called a wrecker and towed me to a dealer. Since it was five o'clock in the morning the dealer was not open. The tow driver dropped me at the entrance gate and left after I paid for the tow. ($100.00) Then this fella pulls up and says he is there to collect the guard dogs. So we push my car into the lot after he unlocks gate. Then he says please stay in your car because the dogs will attack you and I don't know if I can stop them. Great, thanks. So I wait. When they opened they pushed my car in because it wouldn't start. (If finger bones could rap around neck bones so help me....) After missing another day of work and sitting at the dealer in wet clothes for about 6 hours I got my car back.

- , Joliet, IL, USA

problem #11

Jul 152010

Aztek V6

  • Automatic transmission
  • 100,000 miles

Too many problems. From the security system, abs,no odometer, radio , hatch, service light. I just don't kno0w if i want to keep trying to figure it out. I love this vehicle but can't afford to keep fixing it. Who's to say that when it is repaired that it won't happen later. Why can't Pontiac just recall it and fix it.

- , Springfield, OH, USA

problem #10

May 312008

Aztek

  • Automatic transmission
  • 71,000 miles

A D V E R T I S E M E N T S

My car was dead one night when I came out from work...we jumped it and got it running. Took to the shop and had the battery replaced. A week later, I came out of work again and it wouldn't start. I had to have it towed because the battery was fine (it just wasn't turning over), but nothing would happen. It was taken to a shop in town where the technicians were stumped. They finally (after hours of research) determined that the anti-theft system had malfunctioned and was telling the system that the vehicle had been stolen so it was shutting down. In order to take care of the problem, it would have to go to the dealer because they are the only ones who could recode everything. So, they got it started for me (they could disconnect battery, restart and it would run...once!) and I drove to the dealer. There, they replaced the theft deterrent system and thought they would be done...then it still wouldn't start again. It could see and read the key now with the new system, but he engine wasn't firing. After two hours on the phone w/ GM, they determined that BOTH the BCM (Body Control Module) and PCM (Powertrain Control Module) were shot and needed to be replaced. Now, $1300 later I still have a problem with my AWD (the system works sometimes, not others) and the seat heaters and internal air pump don't work. All this within a month of replacing all four tires and the muffler...It's been an expensive month! GRRRRR!

- , Holmen, Wisconsin, USA

problem #9

Apr 122008

Aztek

  • Automatic transmission
  • 127,000 miles

I was driving and my fuel gauge dropped to empty. This occurred after the dealership fixed the fuel tank leak.

- , Pekin, IL, USA

problem #8

Apr 172007

(reported on)

Aztek

  • Automatic transmission
  • 45,000 miles

The car acted at first like a bad battery. After replacing the battery the gages still went crazy - on and off; acted very weird. Mechanic replaced switch assembly; still not fixed. Finally took to GM garage, they said it was the body control module. They fixed it for $500, but forgot to program for the security system. They had to put in a new one as once programmed it can not be reprogrammed. It has worked fine since.

- , College Place, WA, USA

problem #7

Jul 262006

(reported on)

Aztek

  • 72,400 miles

A D V E R T I S E M E N T S

So far dealer has replaced Ignition switch, Multifunction switch and today main module and when I stopped in driveway this time instead of driving on highway - same problem. Daylight driving lights, ( luckily today it was during daylight at night it's the headlights ), all dash lights and guages, and radio all went off. Before everything comes on the Instrument cluster ID lights flash on ( as if ignition is shut off and turned back on ) but engine remains running.

- , Hillsboro, IL, USA

problem #6

Jul 262006

(reported on)

Aztek

  • 72,244 miles

Dealer replaced Ignition switch for this on same problem previously. Drove car for about a week with no problem them started doing the same thing as before. While driving & a few times just at idle before driveing off all lights and radio will go off then Instrument cluster ID lights flash while all other lights and radio come back on. Dealer replaced Multifunction switch ( turn signal, bright n dim switch ) but problem still persists at random....

- , Hillsboro, IL, USA

problem #5

Jul 262006

(reported on)

Aztek

  • 72,190 miles

After getting car back from previous repair of A/C & Leaking intake gasket started having electrical problem, 1rst. dead battery after setting overnight. recharged battery & hasn't happened again. MORE SERIOUS while driving at night, switched to dims and all interior, dash & exterior lights, including headlights and radio went off. After hitting brakes everything came back on. Engine remained on and didn't shut off or die....

- , Hillsboro, IL, USA

problem #4

Feb 062007

(reported on)

Aztek 3.4

  • Automatic transmission
  • 60,000 miles

the car runs away with you i have had wire harness replaced, computer, and many other parts replaced still no fix to the problem

- , Brodnax, VA, USA

problem #3

Nov 102006

(reported on)

Aztek

  • Automatic transmission
  • 50,000 miles

A D V E R T I S E M E N T S

I'm not even going to mention the oil leak and the coolant leak.

Next the fuel gauge started suddenly dropping to empty and the LOW FUEL light would come on. Then it started doing the following intermittently:

When we start the car, the horn honks briefly once, the KEY FOB BATTERY LOW light comes on (we don't even HAVE a remote entry system so there is no key fob battery) and the SERVICE VEHICLE SOON light comes on, and the idiot bell starts ringing. The A/C stops working, the door locks don't work, and when we turn off the car, the lights will not go off and the warning bell continues to ding constantly. We have to disconnect the battery to get the lights and bell to go off. Then when we reconnect the battery it works again just fine (unless the battery is dead). This is happening with increasing frequency. Because the battery died the first few times this happened, we of course got a new battery. But we have had to have it towed twice to different dealers, and both times the tow truck driver jump-started the battery because the gearshift was locked, and the problem went away. The dealers can't duplicate the problem -- they claim. Because I have an excellent extended warranty, the first dealer replaced $1600 worth of parts, including a new fuel tank, new cluster etc. But it's still doing the same thing and it's getting worse. It's a cluster, all right, but not the replaceable kind. I loved my Aztek, but I am soooooo sick of this crap.

- , Tampa, FL, USA

problem #2

Jul 052006

(reported on)

Aztek

  • Automatic transmission
  • 48,000 miles

My mechanic doesn't know what to do to fix it. Diagnostics don't shed any light as it is electrical. Had alternator, battery, ignition switch all checked or replaced, but still not fixed. I love the basic car and planned on keeping it for a long time, but once the electrical system starts to go out, I'll probably have to dump it. In the first year already had to replace the air conditioner. I can handle mechanical items, but electrical problems are different. Of course, the warranty ran out and they wanted a fortune for just a one year extended warranty which of course would have expired anyway. I had been warned about Pontiac, but did not listen. It was love at first sight, but if this continues, I'll be getting a divorce!

- , College Place, WA, USA

problem #1

Sep 222003

(reported on)

Aztek

  • 28,000 miles

There is a MAJOR electrical problem with my car. Every problem I've had somehow seem to relate to the electrical system. From my CD player shorting out, to my radio losing 2 minutes of time a week, to the power door locks working intermitently, to the rear hatch release not working properly (if at all), the A/C not blowing cold air, to the "service vehicle now" light being on for the first 3500 miles, and also my lights (AUTO) staying on for hours after I lock my car. Problem is dealer can't duplicate the problem with the locks and lights. Funny thing is the night I got it back from the dealer, it happened again. Maybe because it's light out at 3:30 when they all go home, they'll never see it!

- , Toms River, NJ, USA

Not what you are looking for?