Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


hardly worth mentioning
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
63,629 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2009 Chevrolet Aveo drivetrain problems

drivetrain problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2009 Chevrolet Aveo:

Unsubscribe any time. We don't sell/share your email.

2009 Chevrolet Aveo Owner Comments

problem #9

Jul 132010

Aveo 4-cyl

  • 3,000 miles


1st incident: Was on interstate during rush hour in St. Paul, mn w/ 2 toddlers in the back seat. The car suddenly started bucking and then shut off. I was in the 2nd left lane on 4 lane so I had to coast to the right hand shoulder w/ no power steering and no acceleration almost getting hit by multiple vehicles. Took four hours for tow truck.. 3 weeks for the fuel pump to be manufactured and shipped as the car was brand new w/ less than 3000 miles on it and they didn't have spare parts for it. Also, discovered that the onstar wasn't connected even though I was supposed to receive a free year. It wouldn't even come on. They fixed that at the same time as the fuel pump but then when I got it back I noticed my clock wouldn't keep time and the onstar wasn't showing the free year which never got resolved. The dealer said they wasn't sure what was wrong with the clock but the replaced some fuses, etc. To this day it still doesn't work. 2nd incident which is still ongoing: Dash and radio fuses randomly blow, car eats coil packs and spark plugs every 3-4 months. At red lights/extended stops it will start idling roughly and usually will shut off. Car will sometimes not accelerate and other times it will shoot off like a rocket w/ a mild press of gas pedal. Gas mileage is a joke, I'm lucky to get 20/mpg. I have taken this car to 3 Chevy dealer mechanics and 2 independents and no one can tell me what is wrong other than 'electrical' saying I could replace the computer and wiring harness but that is not a guaranteed fix and at almost $2500 not worth it at this point. I will just be so glad to have this thing paid off in a few months (bought it brand new w/ 43 miles on it) so I can sell or trade it in though every dealer I've approached about trading it in tells me they do not accept them B/C of 'known' problems in the auto community. 2 wrecks, airbags never deployed, front & rear.

- Burgaw, NC, USA

problem #8

Mar 282014


  • 85,000 miles
I was stopped at a red light waiting to make a left southbound turn at approximately 10:30 P.M. the Aveo malfunctioned on turning. I ended up going southbound in the northbound turning lane and was completely stopped. I was unable to start the car, change gears, turn on headlights, or turn on flashers to warn other drivers of impending danger. The car was completely stalled with absolutely nothing working - confirmed by police, a friend, and wrecker operator. It was impossible to even push the car to a safe location as the wheels would not move/turn. A manual override was required by the wrecker operator to even load the car onto the wrecker. I was blessed to have a good samaritan pull up behind me and put on flashers and wait until the police arrived as without lights or flashers, it was difficult to see the car stalled in the wrong lane of traffic - creating the potential for an accident. In the weeks preceding this complete malfunction, I had replaced both front hub bearings, brakes, timing belt and water pump. Shortly after the last repair - replacing the timing belt and water pump - the air conditioning stopped working and received an estimate of approx another $1,400 for this repair from a Chevrolet dealer in my area.

- Glenpool, OK, USA

problem #7

Dec 312012

Aveo 4-cyl

  • 109,136 miles
So we bought this car and noticed that it would lose power, buck, jerk, and sometime die. Usually after dying it will start right back up and drive fine for a while. We took it to a repair shop that told us to replace the throttle body. After we replaced the throttle body and had the dealer program it the problem persisted. We bought a new ECU from the Chevy dealer and had them install and program it and the problem persisted. We replaced the coil pack for the second time in this vehicles history with no luck, same problem. Drained the fuel tank and installed a new fuel pump...... same problem.... amidst all these part replacements the car has been to the local Chevy dealer at least three times and now a fourth time they finally called me after a week and suggested that they clean the throttle body.... I explained that it is brand new and should not need cleaning. They still apparently have no clue what's wrong with this piece of junk that is only 4 years old! between the Chevy dealer and our own time we have spent over $2000 dollars and the car still won't operate correctly.

- Santa Rosa, CA, USA

problem #6

Jun 182013


  • 39,292 miles


The car just lose acceleration and won't respond to the pressing of acceleration. The engine slow and shaky. It would pickup sometimes after flooring the accelerator couple of times. The check engine also came up after the second occurrence.

- White Plains, MD, USA

problem #5

Feb 042013

Aveo 4-cyl

  • 80,000 miles
I have only had this car for 6/7 months before I started having problems. First the passenger door stopped opening and then the interior lights went out within the first 3 months. I was on my way to work one day and the car started decellerating until it just stopped. At first this was an off an on issue but now it wont start at all. I replaced the ignition coil and spark plugs, just to find that there was a recall I wasnt aware of, but the car still wont move and the battery is dead now.

- Norcross, GA, USA

Search for these popular complaint phrases...

problem #4

Dec 312012

Aveo 4-cyl

  • 106,234 miles
Just put it in drive give it gas wont go over 20 mph, put in nutreal it reves up rpms go up and sounds good put back in drive back to 20 mph even when giving it gas no rpms no go just 20 mph wont go any faster. What is going on. This seems to be a problem...

- Flint, MI, USA

problem #3

Oct 182012


  • 54,000 miles


I had an issue with the clutch wearing out, at this low of a mileage I assumed that it was covered under warranty. I made an appointment with pape Chevrolet in South portland Maine, and they told me to bring it in to take a look at it. As I was driving it there to drop it off, the clutch gave out in the middle of an intersection and made a loud cracking or dropping noise. I wasn't able to drive it thereafter, and had to use aaa to tow it to pape. Today I go there and they say that the clutch is a wear item and isn't covered, they also state that the case was cracked and leaking fluid. I asked for a what was covered on the warranty and they became very defensive and said that they couldn't provide me with that and to just look at my manual, they then told me that they wouldn't work on the car and to take it somewhere else. So now it sits at their lot.

- Gorham, ME, USA

problem #2

Sep 012012


  • 51,000 miles
The lights on the shifter no longer work on my 2009 Chevy Aveo. More specifically, these are the lights on the shift lever located on the console between the seats.

- Tacoma, WA, USA

problem #1

Jun 292012


  • 45,000 miles
1st time-I was driving and my car started to sputter and when I hit the gas pedal for acceleration nothing would happen, the RPM would raise and the car wouldn't accelerate. 2nd time- same as above but stalled after sputtering 3rd time-sitting at a light when the light turned green I couldn't move(pushed gas all the way to the floor with no results) 4th time-driving and it started to sputter aggressively and un able to get power and then stalled. 5th time- pulled out of parking spot and couldn't get any gas could only coast, in a half mile distance it stalled 3 time when I finally parked it and called a tow truck. **each time the car acted up I took it to the dealership and each time they tell me there is nothing wrong with it they couldn't get an error code. 5 times being in the dealership, the 3rd time they said they received a low idle code and did a decarbon costing me $53, put that didn't help. The 4th time it was at the dealers I was told to drive a long distance and open up the engine (are you kidding me) there is defiantly something wrong with this car! this could be very deadly if it happens in the wrong place.

- Shelby Twp , MI, USA

Not what you are looking for?