Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.


definitely annoying
Crashes / Fires:
0 / 0
Injuries / Deaths:
0 / 0
Average Mileage:
45,992 miles

About These NHTSA Complaints:

This data is from the NHTSA — the US gov't agency tasked with vehicle safety. Complaints are spread across multiple & redundant categories, & are not organized by problem.

So how do you find out what problems are occurring? For this NHTSA complaint data, the only way is to read through the comments below. Any duplicates or errors? It's not us.

2011 Chevrolet Aveo engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2011 Chevrolet Aveo:

Unsubscribe any time. We don't sell/share your email.

2011 Chevrolet Aveo Owner Comments

problem #17

Jun 232016


  • 74,756 miles


Last month will driving( highway, city street and parked) all my hoses to my cooling system all busted one after another with in 5 day we could see the week spot in the hose after thy busted, had the thermastate changed, it also blow my head gasket now I cant drive my car it has 74,756 miles I don't now the cause VIN number is kl1td5de3bb134567

- Waynesville, NC, USA

problem #16

Aug 142016


  • 79,000 miles
The contact owns a 2011 Chevrolet Aveo. While driving approximately 45 mph, the engine overheated and caused the radiator holes to explode. The contact independently repaired the radiator holes. The manufacturer was notified of the failure. The approximate failure mileage was 79,000.

- Seminole, OK, USA

problem #15

Jul 252016


  • 7,552 miles
This Aveo has only 7,552 miles and when accelerated to pull out it has no power.when you do get out in road it only goes 15-20 mpg even when acceleration is to the floor.I had to pull over to the side of road-turned it off and restarted then drove it about 2 miles and it did it again-very dangerous-unsafe-hope someone looks into this.

- Spruce Pine, NC, USA

problem #14

Apr 012016


  • 65,000 miles


The contact owns a 2011 Chevrolet Aveo. While driving 35 mph, the check engine light illuminated. The vehicle was taken to the dealer where it was diagnosed that the thermostat failed and needed to be replaced. The vehicle was repaired. The contact stated that the thermostat was replaced three times; however, the failure recurred. The manufacturer was not notified of the failure. The approximate failure mileage was 65,000.

- Powder Spring, GA, USA

problem #13

May 272016


  • 58,000 miles
My car has had multiple issue within the 8 months is have had it. My car has 68900 miles on it and is a 2011. My car was in the shop for a total of two months because, my breaks stopped working on the interstate, it was running hot, my acceleration ( pickup speed) will not work properly. My car is always drifting to the left when I do drive. My check oil light came on, took it to the dealership and had a full tank of oil. They told me again nothing was wrong. A large amount of liquid comes out my car after parking it, assuming it is from my A/C but its more then usual. My A/C does not get cold all the time, its pretty hot. My steering wheel has been shaking since I purchased it, when I go up hill my car wont go past 40 mph, then when it reaches to 60 mph it wont stop increasing, when I hit my break going down hill the steering wheel shakes, and the car too.the dealership keeps telling me nothing is wrong with my car.

- Buford, GA, USA

problem #12

Apr 282016


  • 86,000 miles
The contact owns a 2011 Chevrolet Aveo. While driving 45 mph, the speedometer displayed incorrect information. In addition, when the accelerator pedal was depressed, the vehicle jerked before accelerating and the check engine warning light illuminated. The vehicle was taken to two independent mechanics where it was diagnosed that radiator fluid contaminated the transmission. The vehicle was taken to a dealer where it was diagnosed that the radiator, transmission, and trans lines needed to be replaced. The vehicle was not repaired. The manufacturer was notified of the failure. The failure mileage was 86,000. Updated 07/12/16

- Davison, MI, USA

problem #11

Nov 012015


  • 55,000 miles


So as I'm driving (in motion) whether it be 30 mph or 70 mph my car dies out. Does not shut off, but I do not have any acceleration. I have to immediately pull over because I cannot move. I spoke to mechanics and they are saying it is the throttle body. As I research this, there has been so many complaints regarding this against GM and nothing not one thing has been done. Do they not understand that as your driving 70 mph and then have no control of speed in the passing lane or regular lane that you can get killed my another car? if you go under Chevrolet you can see complaints about this. I asked if this was under warranty and it is not. It is not part of the power train. Yet GM knows there is a defective part and they are just not willing to fix it. They will wait til someone dies first and then fix it. I am filing a complaint regarding the throttle for it is just not my car for I have researched how many cars this has happened to, and knowing that GM knows about this indicated on complaints to GM this needs to be fixed for safety reasons. If something was to happen while I was driving my grandchildren around or when my daughter drives the car I will never forgive GM. Especially where they know about this part. Now I put this as of 11/1/15 but that is not the only time it's been ongoing since then. I am very worried to drive this car, yet it is very expensive to have this fix and it is not under a $2,000 warranty insurance I purchased when I bought this car. April 2014 is when I bought this used car and have had it towed 2X already and engine lights on 2X had to have repaired. So thinking there has to be recalls on this car and nothing is being shown.

- Bradford, NH, USA

problem #10

Jun 242015


  • 45,000 miles
I bought by Chevy Aveo in 2013 with roughly 27,000 miles on it. I loved that car and it worked well for me until recently at 45,000 miles. While driving, 15-20 minutes into the drive, the car would lose power and fail to accelerate. I would put the pedal all the way to the ground and the spedometer would barely creep up. The first two times it did this it "snapped out" of it and drove the rest of the way with no problems. This last time I had some leaking radiator fluid which the dealer wrote off as a "loose radiator cap". when the cap was screwed back on it still stalled for my father, and it wasn't from overheating. The dealer says they can't find anything wrong with my car. I currently have it at another mechanic for a second opinion. I am extremely disappointed with Chevrolet. Will sell this car asap and never buy from Chevy again!

- Spokane, WA, USA

problem #9

Apr 032013


  • miles
Driving down road and car starts shaking and if you do not press pedal to the floor, the car will go dead. If at red light, the RPM needle goes up and down. If you do not constantly press on gas, it will go dead. I have had to replace my headlights at least 5 times since I bought the car in 2012. I have a 2005 corolla and I have had to change my headlights maybe twice since 2005. I am also having other electrical issues inside. The "seat belt" light that is above clock goes on and off as well as my gear shift lights. With the gear shift lights, just hit it and they will come back on. All of these issues could not be found when I took to dealership under warranty. Now check engine light is on and I will be getting a new car soon. I highly recommend to not buy this car! there's a reason they stopped selling them.

- Mobile, AL, USA

problem #8

Dec 172014


  • 62,000 miles
I was driving on a backroad going about 30 mph. My engine shut off causing me to lose my power steering and power brakes. I was able to get the car into a parking lot and pull my emergency brake. I then shut off and restarted my car. It started fine. It is now at a dealership where they can find nothing wrong. Although it is still stalling on them as well.

- Fort Thomas, KY, USA

problem #7

Aug 222014


  • 55,000 miles


I bought a Chevy Aveo back in Feb 2014. Was on way home sometime in August and getting on to highway from ramp would not accelerate and running hot according to temp gauge. I got it towed to shop and called the next day to find they could not find nothing wrong!! so I picked up the car and about three weeks later on way home this time only on back roads doing 35, the car does same thing. What is it gonna take for Chevy to fix this issue that I have seen numerous complaints about. I am not able to just go but another car!!!! wake up Chevrolet!!!!!!!!!!!!!

- Cincinnati, OH, USA

problem #6

Aug 092014

Aveo 4-cyl

  • 41,000 miles
After driving vehicle I parked it. Started vehicle, accelerated and engine stalled. Idled to parking lot and engine died. Started back up and eventually got it running. Took off from a stop light and stalled when apply gas, finally got it to drive at speed posted.

- Indianapolis, IN, USA

problem #5

May 052014


  • 54,000 miles
The contact owns a 2011 Chevrolet Aveo. The contact stated that while driving approximately 55 mph, the vehicle decelerated and stalled without warning. The vehicle restarted after numerous attempts and the contact mentioned that the failure occurred five times. The vehicle was not diagnosed or repaired. The manufacturer was notified of the failure. The approximate failure mileage was 54,000.

- Tarzana, CA, USA

problem #4

Mar 122014


  • miles
The contact rented a 2011 Chevrolet Aveo. The contact was driving an unknown speed and traveled over a pot hole when the vehicle stalled. The vehicle was taken to a private mechanic where the failure could not be diagnosed. The vehicle was not repaired. The manufacturer was not contacted about the failure. The failure mileage and VIN was not available.

- Louisville, KY, USA

problem #3

Apr 102013

Aveo 4-cyl

  • 41,699 miles
The contact owns a 2011 Chevrolet Aveo. The contact stated that after having the spark plugs replaced, the engine begin to malfunction while driving 70 mph. The vehicle would not shift out of first gear and an egg smell entered the vehicle. The contact took the vehicle to the dealer for a diagnostic test however, the dealer could not identify the defect of the engine. The dealer repaired the heater blower but that did not remedy the defect. The failure mileage was 41,699. Updated 12/30/13

- Atoka, OK, USA

problem #2

Aug 012012


  • 24,000 miles
I have been trying to get this issue resolved for about a year to no avail. My 2011 Chevy Aveo 1.4L has a very bad vibration at idle that can be felt on the whole front end and through to the steering column. I have motor mounts replaced (they had broken), replaced spark plugs, and motor and transmission shifted to sit better. Unfortunately, none of this has rectified the issue. I have been speaking with Chevy's customer service department that has proven useless and dealerships stating that this is just what the car does. I'm concerned that since this vibration can break motor mounts it can obviously cause damage elsewhere. I now have a burning smell that can't seem to be located and none at Chevy seems to be concerned.

- Richmond, VA, USA

problem #1

May 062013


  • 33,861 miles
The contact owns a 2011 Chevrolet Aveo. The contact stated that the vehicle hesitated to accelerate and overheated. The vehicle was taken to a dealer for diagnostics, who stated that the camshaft was damaged. In addition, the head gaskets were blown and needed a new timing belt. The parts were replaced but the failure recurred. The vehicle was taken to dealer again and the contact was advised that the failure was caused by low cooling fluid. The failure was reported to the manufacturer. The failure mileage was 33,861. The current mileage was 33,890.

- Auburn , NY, USA

Not what you are looking for?