If you find CarComplaints.com is helpful ... We rely completely on word of mouth. Talk about us on Facebook, Twitter, tell your mother-in-law. Help us help more people.

6.0

fairly significant
Typical Repair Cost:
No data
Average Mileage:
101,500 miles
Total Complaints:
2 complaints

Most Common Solutions:

  1. not sure (2 reports)
2000 Mitsubishi Galant electrical problems

electrical problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 2000 Mitsubishi Galant:

Unsubscribe any time. We don't sell/share your email.

2000 Mitsubishi Galant Owner Comments

problem #2

Mar 012008

Galant V6

  • Automatic transmission
  • 104,000 miles

A D V E R T I S E M E N T S

Cannot read the numbers on the radio because the light is dim, even at night. The radio does not hold the channels and continues to reset itself. I've given up going to the mechanic for this because it's not even worth it.

- , Stony Brook, NY, USA

problem #1

Nov 012010

Galant ES ES v3

  • Automatic transmission
  • 99,000 miles

2000 Mistsubishi Galant ES, While the head lights ON i turned off the engine and head lights were auto off and i went and again when i entered IN and started the engine (head light switch being at ON position), from here onwards i see following problems:

1. Remote and Auto lock/unlock is not working, needs manually operation. 2.Seat belt indicator still works fine but buzzing is not heard if seat belt is not put which was used to. 3. Inside reading lamp(Inside car) is not working, bulbs are fine.. 4. Audio player asks for Code, entered code and works fine but only till i take off keys, again morning player asks for the code.

Looks like an fuse is blown out but not able to find which one, Computer shows no problem. Please let me know if any other than fuse and if fuse problem please let me know which one needs to be changed and how to find out which fuse is blownout by seeing or inspecting fuse.

Regards, Balaji M balajimcat25@gmail.com

Tried So far: Checked fuse box, but computer says no problem.

Had Service Engine Soon indicator coming while running and Computer said, Oxygen Sensor 2 is bad but didn't fix as it was okay for me, but later to this problem(fuse related as per my knowledge) this indicator is getting off after starting :) but i know Oxy Sensor 2 is till bad but not indicated due a failure of an fuse.

- , Cedar Rapids, IA, USA

Not what you are looking for?