Huge win for car owners! All TSBs to be made public. The Center for Auto Safety just made the NHTSA (US Government) make public the full text of all TSBs from now on. They are the same organization that has petitioned the NHTSA & filed lawsuits to protect car owners over exploding gas tanks & other major safety issues. Whenever you drive in your car, you are safer thanks in part to a lot of work over the years by this small but very effective consumer advocacy group.

Please take a moment & say thank you by donating $5 or whatever you can to the Center for Auto Safety.

Runs Roughly


really awful
Typical Repair Cost:
No data
Average Mileage:
124,364 miles
Total Complaints:
4 complaints

Most Common Solutions:

  1. not sure (4 reports)
1999 Oldsmobile Alero engine problems

engine problem

Find something helpful? Spread the word.
Get notified about new defects, investigations, recalls & lawsuits for the 1999 Oldsmobile Alero:

Unsubscribe any time. We don't sell/share your email.

1999 Oldsmobile Alero Owner Comments

problem #4

Jul 242011

Alero 4 cyl

  • Automatic transmission
  • 213,000 miles


I noticed when I was on my way home (40 miles away) that at first I had more power and brighter lights and cooler air than I've had for a while. But about 1/2 home, It started. The car started cutting out especially when it went up the hills. When I got home and went to turn it around to park it, it nearly died, cutting out severely. don't have any clue what else. hope somebody can suggest something. It kind of acts like it's not getting gas or maybe the timing? I'm just tired of taking it to mechanics. I think I'll just join the person above and run it off a cliff, but I will have the added touch of beating the hell out of it with a baseball bat first!

Well, I understand the car has mucho miles, but it's had a pretty good run up until I had to start traveling 70 miles a day to work. Since then, it's slowly been screwing up. yesterday, my car totally quit 40 miles away from my home on the parkway in the hot, hot sun. Why always in JULY does this happen? Can't I ever have money to sit and relax by the ocean? NO. I have to always spend my vacation money on my pieces of crap cars! ANYWAY, I spent $210.00 on a new alternator and "plug" that was supposed to be next to the alternator (per the mechanic) and it started right up when I picked it up from the mechanic.

- , West, KY, USA

problem #3

Jun 082010

Alero 3.4L V6

  • Automatic transmission
  • 92,000 miles

So, Once again this car has freakin issues! When I start my car if I do not push the gas pedal it will stall/not stay running when I back out and go to move the car forward it will "jump, slip" like it just didn't get gas at that moment and will stall again if I do not ease the gas pedal and the same happens when i go to move from a complete stop, it feels like the gas pedal is slipping like a possible transmission problem but IDK I've had it to the shop just to pay $99 for a diagnostic that told me absolutely nothing.

Now(January 2011) this problem has escalated to the point that I cannot drive my car up hills and expect it to go over 25 mph(the speed limit is 40) which causes drivers around me to become irritated with me as i cannot avoid hills where i live, i also noticed i cannot go over 45 mph on the roads and decided taking it on the freeway is a really bad idea so now i am limited to where i can go in fear of the POS breaking down or stalling in the middle of the road. I still have yet to get a legit answer for the reason as to why it stutters like that when beginning to move or going to fast/uphill. If anyone out there has a suggestion so maybe i can get it fixed please feel free to let me know and maybe i can mention it to a mechanic. Email:

- , Vancouver, WA, USA

problem #2

May 162007

Alero 3.4L V6

  • Automatic transmission
  • 71,458 miles

Well first of all, I'm at the end of my rope with this car. The car began to studder more and more each week. Almost to the point where I thought it may die, but putting it in neutral would seem to releave the studder. So I brought it in to a dealer and they told me they couldnt find anything wrong with it and charged me for the dyno. So I took it to a local repair shop where they told me it was reading missfires which was most likely my sparkplugs and wires needing to be replaced. After replacing them both and a few weeks later, the car still had a studder. I brought it back into the mechanics and he told me I needed a new intake gasket. So, I replaced the intake gasket! The car still has a studder, worst then ever, so someone asked if there was water in the tank cus I was close to empty. I bought some gasline antifreeze which at first I thought worked, but now it seems to studder after a couple minutes of driving. Do you have any suggestions on what this problem could be? PLEASE! lol

- , Sault Ste. Marie, ON, Canada

problem #1

Mar 052007

(reported on)

Alero 2.4

  • Automatic transmission
  • 121,000 miles

Car keeps saying trac off and jumps until you stop and restart two times or you put it in neutral and turn it off and restart.

- , Oxford, AL, USA

Not what you are looking for?